Author Topic: No Loader is installed, please try to run this command or contact support:  (Read 1153 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Good Afternoon Team,

 Centos 6 running CWP 6 click on update from CP after 20seconds it is completed

  Logout, then action the login url and you get the following

No Loader is installed, please try to run this command or contact support: sh /scripts/update_ioncube restart

After running that command, the problem still exists

Could someone give me some pointers please....

All the best and thanks from Alan

Offline
*
same error for me following to see if you get any responses :)

Offline
*
Hi,

Same problem for Me.

Offline
*
Hi I have the same problem and od more servers .. .
JPa

Offline
*
I have the same problem.

It started out for me with an email notice from the server that said:

CWP Update FAILED
Please urgently run update of cwpphp rpm: yum update cwpphp --enablerepo=cwp

I ran that command which seemed to go ok. Then my admin panel said: No Loader is installed, please try to run this command or contact support. I ran that command as well.

I have tried to work with it, and set the ioncube version in the ini... but it's come down to my error logs saying stuff like

path/to/admin/script was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0.

Hope this extra info helps.



Offline
*
Code: [Select]
/usr/local/cwp/php71/bin/php -vPHP 7.2.30

if PHP was not updated to 7.2 then try manually
Code: [Select]
yum update cwpphp --enablerepo=cwp
**Manual update CentOS 7 (skip if you have CentOS 6)**
Code: [Select]
chattr -i -R /usr/local/cwpsrv/htdocs
cd /usr/local/cwpsrv/htdocs
wget static.cdn-cwp.com/files/cwp/el7/cwp-el7-0.9.8.961.zip
unzip -o -q cwp-el7-0.9.8.961.zip
rm -f cwp-el7-0.9.8.961.zip


**Manual update CentOS 6 (skip if you have CentOS 7)**
Code: [Select]
chattr -i -R /usr/local/cwpsrv/htdocs
cd /usr/local/cwpsrv/htdocs
wget dl1.centos-webpanel.com/files/cwp/cwp2-0.9.8.765.zip
unzip -o cwp2-0.9.8.765.zip
rm -f cwp2-0.9.8.765.zip



**Manual update for services (required CentOS 6 and 7)**
Code: [Select]
cd /usr/local/cwpsrv/var/services/
wget static.cdn-cwp.com/files/cwp/el7/cwp-services.zip
unzip -o -q cwp-services.zip
rm -f cwp-services.zip

Test if all is ok, it should run update without errors
Code: [Select]
sh /scripts/update_cwp
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Code: [Select]
/usr/local/cwp/php71/bin/php -vPHP 7.2.30

if PHP was not updated to 7.2 then try manually
Code: [Select]
yum update cwpphp --enablerepo=cwp
**Manual update CentOS 7 (skip if you have CentOS 6)**
Code: [Select]
chattr -i -R /usr/local/cwpsrv/htdocs
cd /usr/local/cwpsrv/htdocs
wget static.cdn-cwp.com/files/cwp/el7/cwp-el7-0.9.8.961.zip
unzip -o -q cwp-el7-0.9.8.961.zip
rm -f cwp-el7-0.9.8.961.zip


**Manual update CentOS 6 (skip if you have CentOS 7)**
Code: [Select]
chattr -i -R /usr/local/cwpsrv/htdocs
cd /usr/local/cwpsrv/htdocs
wget dl1.centos-webpanel.com/files/cwp/cwp2-0.9.8.765.zip
unzip -o cwp2-0.9.8.765.zip
rm -f cwp2-0.9.8.765.zip



**Manual update for services (required CentOS 6 and 7)**
Code: [Select]
cd /usr/local/cwpsrv/var/services/
wget static.cdn-cwp.com/files/cwp/el7/cwp-services.zip
unzip -o -q cwp-services.zip
rm -f cwp-services.zip

Test if all is ok, it should run update without errors
Code: [Select]
sh /scripts/update_cwp

awesome thanks worked for me :)

Also don't forget > sh /scripts/restart_cwpsrv

Offline
*
HI I have done all needed steps.
And after update_cwpsrv this error:
Cannot load the ionCube PHP Loader - it was built with configuration API320160303,NTS, whereas running engine is API320170718,NTS
No Loader is installed, please try to run this command or contact support: sh /scripts/update_ioncube restart[root@omega services]#
???
JPA
« Last Edit: April 24, 2020, 07:58:29 PM by JPa_SK »

Offline
*
another Update issue takes you down..... >:(.... its aggravating

I cannot get the above to work since I am transcribing and cannot paste into the server provider panel...
this stuff gets old when you have stuff to do maybe better to stop their auto updates

Offline
**
Just saw this on one of my Centos 6.9 servers.
try this

sed -i "s/ioncube_loader_lin_7.0/ioncube_loader_lin_7.2/g" /usr/local/cwp/php71/php.ini
sh /scripts/restart_cwpsrv

Offline
*
Glenn.....

I am on php 5.6 on centos 6.9

would it be the same entry??

thanks

Offline
**
Your site may be on any of the other php builds available but CWP should be on its own (now php 7.2.)
So changing the version of ioncube won’t have any effect on your sites on the server , you can run the sed command above without any worries (-;

Offline
*
After having gone through that useful information, I just used the CWP PHP Switcher to upgrade to PHP7.2.30 - seems to have worked fine.

Thank to all for the advice...Alan