Author Topic: php ini not changing  (Read 381 times)

0 Members and 2 Guests are viewing this topic.

Offline
*
php ini not changing
« on: April 25, 2020, 11:43:59 PM »
hello,

I want to change my php ini settings about upload max filesize.
when i try to change on php simple editor or php.ini configurator, its look good but when i try to open php info, its not changing. which file need to change? whats problem about that?

 i try to change its 20 megs, but still lookin 2 megs.

Online
***
Re: php ini not changing
« Reply #1 on: April 26, 2020, 12:15:49 AM »
More information is needed to answer that question.

What setup do you have?  (APache Only, NGINX+APACHE, ETC)
CWP Pro?  If Yes, PHP FPM enabled


To try to help:

php-fpm has user files
EX: php-fpm73
/opt/alt/php-fpm73/usr/etc/php-fpm.d/users/user.conf

you can define any php variable here. EX
php_admin_value[post_max_size] = 20M
php_admin_value[upload_max_filesize] = 20M

systemctl restart php-fpm73  after editing

-----------------------------------------
Non fpm version, you'll have to look at phpinfo() to find the correct php.ini to modify.

It's alwasy best to restart all servers after making modifications.
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: php ini not changing
« Reply #2 on: April 26, 2020, 12:29:56 AM »
i have free licence cwp and nginx+apache+varnish

phpinfo command says that;
Configuration File (php.ini) Path   /usr/local/php
Loaded Configuration File   /usr/local/bin/php.ini
Scan this dir for additional .ini files   /usr/local/php/php.d

i opened that file php.ini with console nano and changed.. restarted the server but still looking size like that;

upload_max_filesize   2M   2M




Online
***
Re: php ini not changing
« Reply #3 on: April 26, 2020, 12:33:47 AM »
cd /usr/local/php/php.d
grep upload *
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: php ini not changing
« Reply #4 on: April 26, 2020, 01:22:10 AM »
no such file or directory

Offline
*
Re: php ini not changing
« Reply #5 on: April 26, 2020, 01:24:05 AM »
i changed /usr/local/bin/php.ini name ph.i but still working.. then, its not using this file.. but which one?

Online
***
Re: php ini not changing
« Reply #6 on: April 26, 2020, 01:34:42 AM »
possibly /etc/php.ini

to find all instances of php.ini, you would use " locate php.ini "
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: php ini not changing
« Reply #7 on: April 26, 2020, 01:36:07 AM »
/etc/php.ini
/opt/alt/php7/usr/php/php.ini
/usr/local/bin/php.ini
/usr/local/cwp/.conf/backups/file_editor_backups/2020-04-22_22-06-59_php.ini
/usr/local/cwp/.conf/backups/file_editor_backups/2020-04-22_22-07-15_php.ini
/usr/local/cwp/.conf/backups/file_editor_backups/2020-04-22_22-25-37_php.ini
/usr/local/cwp/.conf/backups/file_editor_backups/2020-04-25_14-21-01_php.ini
/usr/local/cwp/.conf/backups/file_editor_backups/2020-04-25_14-21-18_php.ini
/usr/local/cwp/.conf/backups/file_editor_backups/2020-04-25_23-25-55_php.ini
/usr/local/cwp/.conf/backups/file_editor_backups/2020-04-26_03-01-49_php.ini
/usr/local/cwp/php71/php.ini
/usr/local/cwp/php71/php.ini.rpmsave
/usr/share/doc/php-common-5.4.16/php.ini-development
/usr/share/doc/php-common-5.4.16/php.ini-production


i checked all of them.. and i will check again now.. hope i can find :)

Offline
*
Re: php ini not changing
« Reply #8 on: April 26, 2020, 01:41:32 AM »
i changed 3 files more 2m but still lookin info.php upload_max_filesize 2 m


Offline
*
Re: php ini not changing
« Reply #9 on: April 26, 2020, 02:04:31 AM »
i solved that like this, maybe the other users need the solve

i created file in /usr/local/php/php.d/user.ini

and i put this in the file,

upload_max_filesize = 40M
post_max_size = 35M

save and exit and now php info looking correct size.

Online
***
Re: php ini not changing
« Reply #10 on: April 26, 2020, 02:11:57 AM »
Glad you got it working.

I just finally got my test enviro to work, and modifying /usr/local/php/php.ini worked for me, so somethings odd with yours.
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: php ini not changing
« Reply #11 on: May 14, 2020, 07:46:09 AM »
Good Morning.

I wrote to the Centos Web Panel support and they respond with a arrogance that I sincerely consider changing the control panel, I've got Centos Web Panel Pro but I'm tired because this control panel has 3 serious problems and maybe someone who can help me.

1) I changed all the settings of all the php.ini corresponding to the default version and each version (I have a pro license) and always when a file is being uploaded, when it reaches 100MB the transfer is stoped and I can't transfer files. There is nothing to indicate that it stops at 100MB, nor does the time limit elapse.

2) Although it corresponds to another topic but I write it here in case someone could solve it because the centos web panel support does not respond to me, when I create a hosting plans from the root user, I assign a space to each plan. When I create the hosting account, no plan has an allocated space and it appears as if each hosting account is empty (but the files exist) and no space limit works with this failure. This error has always existed since I acquired the pro license and no one ever solved it.

3) I can't find a way to make the server work faster, the same VPS and with half the RAM it works faster with cPanel than with Centos Web Panel, there is no logic. I made the comparison having both activated simultaneously and with the same number of hosting accounts. It's a shame that cPanel has been so expensive for not too long.

Maybe can help help me or maybe I can help to another person, but I'm tired, when I comment on the errors of this control panel, it seems that the support gets angry. If I programmed something wrong and someone warned me, I would try to fix it.

At first I never wrote criticizing, I just wrote pleading to fix those flaws but they never did. Automatic import from cPanel also never worked correctly.


Best regards,
Horacio Adolfo Aulicino.

Online
***
Re: php ini not changing
« Reply #12 on: May 14, 2020, 08:30:59 AM »
Good Morning.

I wrote to the Centos Web Panel support and they respond with a arrogance that I sincerely consider changing the control panel, I've got Centos Web Panel Pro but I'm tired because this control panel has 3 serious problems and maybe someone who can help me.

1) I changed all the settings of all the php.ini corresponding to the default version and each version (I have a pro license) and always when a file is being uploaded, when it reaches 100MB the transfer is stoped and I can't transfer files. There is nothing to indicate that it stops at 100MB, nor does the time limit elapse.
Most likely it's not a PHP issue, but a server timeout issue withing the web applications.   Please provide your setup.  (Ngx-Var-Apache/ Ngx->Apache)  ETC
Quote
2) Although it corresponds to another topic but I write it here in case someone could solve it because the centos web panel support does not respond to me, when I create a hosting plans from the root user, I assign a space to each plan. When I create the hosting account, no plan has an allocated space and it appears as if each hosting account is empty (but the files exist) and no space limit works with this failure. This error has always existed since I acquired the pro license and no one ever solved it.
If your using XFS filesystem with CentOS7, you need to enable quota's via the kernal.  Search the forum for "XFS Quota" and there is a guide.
Quote

3) I can't find a way to make the server work faster, the same VPS and with half the RAM it works faster with cPanel than with Centos Web Panel, there is no logic. I made the comparison having both activated simultaneously and with the same number of hosting accounts. It's a shame that cPanel has been so expensive for not too long.
Is ClamAV running?  PLease post the output of the "top" command.

Maybe can help help me or maybe I can help to another person, but I'm tired, when I comment on the errors of this control panel, it seems that the support gets angry. If I programmed something wrong and someone warned me, I would try to fix it.

At first I never wrote criticizing, I just wrote pleading to fix those flaws but they never did. Automatic import from cPanel also never worked correctly.


Best regards,
Horacio Adolfo Aulicino.
[/quote]
Google Hangouts:  rcschaff82@gmail.com