Author Topic: CWP7.Pro Error | Unable to Login Admin Panel  (Read 3907 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Re: CWP7.Pro Error | Unable to Login Admin Panel
« Reply #15 on: April 30, 2020, 04:56:56 PM »
Details Error:

Code: [Select]
# sh /scripts/restart_cwpsrv

** (pkttyagent:1643): WARNING **: 22:56:12.093: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject
Error registering authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject (polkit-error-quark, 0)

** (pkttyagent:1661): WARNING **: 22:56:12.200: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject
Error registering authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject (polkit-error-quark, 0)

** (pkttyagent:1669): WARNING **: 22:56:12.249: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject
Error registering authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject (polkit-error-quark, 0)

Code: [Select]
# sh /scripts/restart_httpd

** (pkttyagent:1746): WARNING **: 22:56:28.733: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject
Error registering authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject (polkit-error-quark, 0)

Offline
*****
Re: CWP7.Pro Error | Unable to Login Admin Panel
« Reply #16 on: April 30, 2020, 05:39:39 PM »
disable secure process from admin > security

Offline
*
Re: CWP7.Pro Error | Unable to Login Admin Panel
« Reply #17 on: April 30, 2020, 07:44:02 PM »
hi
It is working and solved after disabling it but Website loading speed dramatically decreases

Offline
*
Re: CWP7.Pro Error | Unable to Login Admin Panel
« Reply #18 on: June 03, 2020, 01:22:56 PM »
It worked like a charm.. Thanks a lot @ rcschaff bro...!!

you save my 2 days lots of RnD.... God bless you bro... cheers !!


This is the standard response to your issue.   Your Update failed at some point, and some files were not updated.  YOu need to do the manual file update for your CentOS and the services...
Code: [Select]
Hello,

Test what is the cwp PHP version and if it is updated to 7.2

/usr/local/cwp/php71/bin/php -v
PHP 7.2.30

if PHP was not updated to 7.2 then try manually
yum update cwpphp --enablerepo=cwp

**Manual update CentOS 7 (ignore if you have CentOS 6)**
```
chattr -i -R /usr/local/cwpsrv/htdocs
cd /usr/local/cwpsrv/htdocs
wget static.cdn-cwp.com/files/cwp/el7/cwp-el7-0.9.8.961.zip
unzip -o -q cwp-el7-0.9.8.961.zip
rm -f cwp-el7-0.9.8.961.zip
```

**Manual update CentOS 6 (ignore if you have CentOS 7)**
```
chattr -i -R /usr/local/cwpsrv/htdocs
cd /usr/local/cwpsrv/htdocs
wget dl1.centos-webpanel.com/files/cwp/cwp2-0.9.8.765.zip
unzip -o cwp2-0.9.8.765.zip
rm -f cwp2-0.9.8.765.zip
```


**Manual update for services (This steep must be done for CentOS 6 and 7)**
```
cd /usr/local/cwpsrv/var/services/
wget static.cdn-cwp.com/files/cwp/el7/cwp-services.zip
unzip -o -q cwp-services.zip
rm -f cwp-services.zip
```

Test if all is ok, it should run update without errors
```
sh /scripts/update_cwp
```

If you get error like:
> Cannot load the ionCube PHP Loader - it was built with configuration API320151012,NTS, whereas running engine is API320170718,NTS

then run this:

```
sed -i "s/ioncube_loader_lin_7.0/ioncube_loader_lin_7.2/g" /usr/local/cwp/php71/php.ini
sh /scripts/restart_cwpsrv