Author Topic: Packages not getting updated  (Read 718 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Packages not getting updated
« on: April 10, 2020, 04:59:10 PM »
I have notifications that there are 2 pending updates

cmake3-data.noarch   3.14.7-1.el7   epel   Update
cmake3.x86_64   3.14.7-1.el7   epel

When I confirm update, I get the message

Quote
cmake3-data.noarch

Package updated successfully.

Quote
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.neterra.net
 * epel: mirrors.neterra.net
 * extras: mirrors.neterra.net
 * updates: mirrors.neterra.net
Resolving Dependencies
--> Running transaction check
---> Package cmake3-data.noarch 0:3.14.6-2.el7 will be updated
--> Processing Dependency: cmake3-data = 3.14.6-2.el7 for package: cmake3-3.14.6-2.el7.x86_64
---> Package cmake3-data.noarch 0:3.14.7-1.el7 will be an update
--> Processing Dependency: /usr/bin/python3 for package: cmake3-data-3.14.7-1.el7.noarch
--> Running transaction check
---> Package cmake3.x86_64 0:3.14.6-2.el7 will be updated
---> Package cmake3.x86_64 0:3.14.7-1.el7 will be an update
---> Package python3.x86_64 0:3.6.8-10.el7 will be installed
--> Processing Dependency: python3-libs(x86-64) = 3.6.8-10.el7 for package: python3-3.6.8-10.el7.x86_64
--> Processing Dependency: python3-setuptools for package: python3-3.6.8-10.el7.x86_64
--> Processing Dependency: python3-pip for package: python3-3.6.8-10.el7.x86_64
--> Running transaction check
---> Package python3-libs.x86_64 0:3.6.8-10.el7 will be installed
---> Package python3-pip.noarch 0:9.0.3-7.el7_7 will be installed
---> Package python3-setuptools.noarch 0:39.2.0-10.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch         Version              Repository     Size
================================================================================
Updating:
 cmake3-data              noarch       3.14.7-1.el7         epel          1.5 M
Installing for dependencies:
 python3                  x86_64       3.6.8-10.el7         base           69 k
 python3-libs             x86_64       3.6.8-10.el7         base          7.0 M
 python3-pip              noarch       9.0.3-7.el7_7        updates       1.8 M
 python3-setuptools       noarch       39.2.0-10.el7        base          629 k
Updating for dependencies:
 cmake3                   x86_64       3.14.7-1.el7         epel          7.7 M

Transaction Summary
================================================================================
Install             ( 4 Dependent packages)
Upgrade  1 Package  (+1 Dependent package)

Total size: 19 M
Downloading packages:
Running transaction check
Running transaction test

It stops at "Running transaction test"

How to complete these updates

Re: Packages not getting updated
« Reply #1 on: April 10, 2020, 05:02:16 PM »
Try manually removing python3* then rerun.

Offline
*
Re: Packages not getting updated
« Reply #2 on: April 29, 2020, 01:26:32 AM »
I have the same problem..only with those two not updating none of the other updates work either, all I can do is manually update all the other packages and still have those two listed.  Seems a major Bug!

Offline
***
Re: Packages not getting updated
« Reply #3 on: April 29, 2020, 01:43:41 AM »
 yum remove  python36u-3.6.8-1.el7.ius.x86_64 
 yum -y update
yum -y install cmake3
Google Hangouts:  rcschaff82@gmail.com

Offline
***
Re: Packages not getting updated
« Reply #4 on: April 29, 2020, 02:34:48 AM »
yum remove  python36u-3.6.8-1.el7.ius.x86_64 
 yum -y update
yum -y install cmake3

I had the same issue and rcschaff helped me to get out this issue using the above commands.