Author Topic: New Update issue, Older files but new versions of php selected  (Read 516 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Hi

I found in new update, there is Ioncube loader error. I have changed to ioncube_loader_lin_7.2.so and ran the command of sh /scripts/update_ioncube restart and it was fine. but when I try access my panel it gives following error

Fatal error: The file /usr/local/cwpsrv/htdocs/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

kindly give me some directions on this. why still files are encoded with php version that i was using and when i switch back to  ioncube_loader_lin_5.6.so it give me error

Failed loading /usr/local/ioncube/ioncube_loader_lin_5.6.so:  /usr/local/ioncube/ioncube_loader_lin_5.6.so: undefined symbol: zend_block_interruptions

so new update, is not working with 5.6.so and it need 7.2.so, but files are still on php5.6


Offline
***
Re: New Update issue, Older files but new versions of php selected
« Reply #1 on: April 28, 2020, 08:24:01 AM »
Seriously, does no one know how to search the forum.

http://forum.centos-webpanel.com/index.php?topic=8783.msg30569#msg30569
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: New Update issue, Older files but new versions of php selected
« Reply #2 on: April 29, 2020, 04:39:57 AM »
Seriously, does no one know how to search the forum.

http://forum.centos-webpanel.com/index.php?topic=8783.msg30569#msg30569

Issue comes after updating to ioncube 7.2 because files still require ioncube 5.6 But cwp require ioncube 7.2 ? its little tricky