Author Topic: Redirect to https, port 2031, http error 500  (Read 632 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Redirect to https, port 2031, http error 500
« on: April 30, 2020, 09:43:34 AM »
hi

I tried installing centos CWP several times on a VPS. Installations does not produce any errors, installation seems to be fine.

When I go to the admin page : http://104.140.100.27:2030 I am redirected to https://104.140.100.27:2031, followed by an http error 500

Anyone any idea how to solve this?

thank you

Offline
*
Re: Redirect to https, port 2031, http error 500
« Reply #1 on: May 04, 2020, 07:41:38 AM »
I also have this problem. Hope the helping!

Offline
*
Re: Redirect to https, port 2031, http error 500
« Reply #2 on: May 04, 2020, 07:52:54 AM »
try to restart cwp

Code: [Select]
sh /scripts/restart_cwpsrv
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: Redirect to https, port 2031, http error 500
« Reply #3 on: May 06, 2020, 04:36:32 PM »
I'm having the same issues. Can't connect to web panel. Get the following error when trying to restart CWPSRV

[root@customer ~]# sh /scripts/restart_cwpsrv
/scripts/restart_cwpsrv: line 4: systemctl: command not found
/scripts/restart_cwpsrv: line 5: systemctl: command not found

I did notice before this issue happened that CWP update failed to install.

All the websites seem to be working, but no way to modify anything. Did a yum update, and there was another CWP update, but did not fix anything.

Offline
***
Re: Redirect to https, port 2031, http error 500
« Reply #4 on: May 06, 2020, 09:27:51 PM »
I'm having the same issues. Can't connect to web panel. Get the following error when trying to restart CWPSRV

[root@customer ~]# sh /scripts/restart_cwpsrv
/scripts/restart_cwpsrv: line 4: systemctl: command not found
/scripts/restart_cwpsrv: line 5: systemctl: command not found

I did notice before this issue happened that CWP update failed to install.

All the websites seem to be working, but no way to modify anything. Did a yum update, and there was another CWP update, but did not fix anything.

If your missing systemctl, you've got bigger problems.
try which systemctl from the root shell and post reply.

As for the 500 error
Code: [Select]
Hello,

Test what is the cwp PHP version and if it is updated to 7.2

/usr/local/cwp/php71/bin/php -v
PHP 7.2.30

if PHP was not updated to 7.2 then try manually
yum update cwpphp --enablerepo=cwp

**Manual update CentOS 7 (ignore if you have CentOS 6)**
```
chattr -i -R /usr/local/cwpsrv/htdocs
cd /usr/local/cwpsrv/htdocs
wget static.cdn-cwp.com/files/cwp/el7/cwp-el7-0.9.8.961.zip
unzip -o -q cwp-el7-0.9.8.961.zip
rm -f cwp-el7-0.9.8.961.zip
```

**Manual update CentOS 6 (ignore if you have CentOS 7)**
```
chattr -i -R /usr/local/cwpsrv/htdocs
cd /usr/local/cwpsrv/htdocs
wget dl1.centos-webpanel.com/files/cwp/cwp2-0.9.8.765.zip
unzip -o cwp2-0.9.8.765.zip
rm -f cwp2-0.9.8.765.zip
```


**Manual update for services (This steep must be done for CentOS 6 and 7)**
```
cd /usr/local/cwpsrv/var/services/
wget static.cdn-cwp.com/files/cwp/el7/cwp-services.zip
unzip -o -q cwp-services.zip
rm -f cwp-services.zip
```

Test if all is ok, it should run update without errors
```
sh /scripts/update_cwp
```

If you get error like:
> Cannot load the ionCube PHP Loader - it was built with configuration API320151012,NTS, whereas running engine is API320170718,NTS

then run this:

```
sed -i "s/ioncube_loader_lin_7.0/ioncube_loader_lin_7.2/g" /usr/local/cwp/php71/php.ini
sh /scripts/restart_cwpsrv
Google Hangouts:  rcschaff82@gmail.com

Offline
*****
Re: Redirect to https, port 2031, http error 500
« Reply #5 on: May 07, 2020, 10:46:59 AM »
I'm having the same issues. Can't connect to web panel. Get the following error when trying to restart CWPSRV

[root@customer ~]# sh /scripts/restart_cwpsrv
/scripts/restart_cwpsrv: line 4: systemctl: command not found
/scripts/restart_cwpsrv: line 5: systemctl: command not found

I did notice before this issue happened that CWP update failed to install.

All the websites seem to be working, but no way to modify anything. Did a yum update, and there was another CWP update, but did not fix anything.

i think you've installed centos 7 cwp files on centos 6 cwp 6

Offline
*
Re: Redirect to https, port 2031, http error 500
« Reply #6 on: May 09, 2020, 03:30:49 AM »
If that is what happened, then the auto-update is what created the problem. It was working before auto-update. Any suggestions on how to fix this without losing the configurations that are currently working, but can not access?

Offline
*
Re: Redirect to https, port 2031, http error 500
« Reply #7 on: May 18, 2020, 04:57:49 AM »
I'm having same problem,

after CWP update, I can't go to port 2031.. error 500.

Chronology:

1. I found that my server is down then have tried:
- sh /scripts/restart_cwpsrv

Everything run well

2. then go to port 2031 appear >> Cannot load the ionCube PHP Loader, so I try
- sh /scripts/update_ioncube
- sh /scripts/restart_cwpsrv

3. port 2031 still error 500

4. I try to check PHP version
- /usr/local/cwp/php71/bin/php -v

Cannot load the ionCube PHP Loader - it was built with configuration API320151012,NTS, whereas running engine is API320170718,NTS
PHP 7.2.30 (cli) (built: Apr 23 2020 03:56:24) ( NTS )


5. I've tried this again
- sh /scripts/restart_cwpsrv

many times but still not fixed the problem..

So what I have to do know?

This is production server, I never touch the server since 6months ago, everything is running well, but today, I just realized that I can't go to admin area.
Port 2031 is error 500.

Offline
*
Re: Redirect to https, port 2031, http error 500
« Reply #8 on: May 18, 2020, 08:59:15 AM »