Author Topic: Fresh install looping trying to get csf.tgz  (Read 285 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Fresh install looping trying to get csf.tgz
« on: May 10, 2020, 03:40:15 AM »
I am running the install on Centos7 and it is looping trying to get csf.tgz.
Quote
--2020-05-09 23:17:40--  (try: 9)  https://download.configserver.com/csf.tgz
Connecting to download.configserver.com (download.configserver.com)|94.130.90.175|:443... failed: Connection timed out.
Retrying.

I guess I will need to kill the install :-(

I can download the file easily in my browser, so the server is working, but script is snafu.

Oil
« Last Edit: May 10, 2020, 04:39:10 AM by oilqld »

Offline
*
Re: Fresh install looping trying to get csf.tgz
« Reply #1 on: May 10, 2020, 04:38:32 AM »
So I killed the process at the 14th try to download the csf.tgz file.
Then tried to run the install script again, but it now fails with message that CWP is already installed, so "run update_cwp" script.

But sadly, there is no update_cwp on the server.

Seems I am screwed now. 
Any other way to rerun the installer?

Oil

Offline
*
Re: Fresh install looping trying to get csf.tgz
« Reply #2 on: May 11, 2020, 01:36:27 AM »
I tried 3 more fresh OS installs of CentOS 7 x86-64 minimal   and all failed to install CWP. Everytime it stopped with wget trying to connect to configserver.com to get csf.tgz

I worked around that problem by downloading to my PC then manually using wget to get the file from another host I have.
Next I edited the cwp-el7-latest script to comment out the lines
#rm -fv csf.tgz
#wget https://download.configserver.com/csf.tgz

Then the script ran and CWP is partly working.

Now I cannot get named.service to install and work. So BIND fails and my DNS does not resolve. 

I think my VPS has been given a BAD IP, that is being blocked by configserver.com and some other essential providers.
Looks like MODsecurity cames from configserver.com, and that is now installed

some things are working, but I cannot see the site I added.  Apache is OK, FTP is OK but not much else.

Oh what a pain. I will head back to my VPS provider and see if I can get a CLEAN IP for my server.
If that works out, I will sign up for cwp-pro.

GRRRRRRR.

Oil