Author Topic: query (cache) '[domainname].com/MX/IN' denied  (Read 193 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
query (cache) '[domainname].com/MX/IN' denied
« on: May 15, 2020, 11:18:53 AM »
I am facing few issues with domain name resolving and DNS

BIND DNS is running

When I check status, I see a lot of lines similar to

Quote
May 15 13:11:59 hosting.siteurl.in named[11434]: client @0x7fa2540e2c00 146.88.17.133#61678 (tristarsudan.com): query (cache) 'tristarsudan.com/MX/IN' denied
May 15 13:11:59 hosting.siteurl.in named[11434]: client @0x7fa25410e820 146.88.16.132#41330 (tristarsudan.com): query (cache) 'tristarsudan.com/MX/IN' denied

Please suggest

Online
***
Re: query (cache) '[domainname].com/MX/IN' denied
« Reply #1 on: May 15, 2020, 11:23:27 AM »
If your hosting tristarsudan.com then there may be an issue.

If you are not hosting the domain, it could be that you got an IP that someones old namservers point to.  It shouldn't be too much of an issue if it's the latter, unless you start taking thousands of queries per minute.
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: query (cache) '[domainname].com/MX/IN' denied
« Reply #2 on: May 15, 2020, 11:49:26 AM »
List DNS Zone - > Check All Zones

All domains say

"has no address"

Looks like challenge in resolving IP addresses. Please help.

Example domain

absdecor.com

even tristarsudan.com DNS records are in this server.

Offline
*
Re: query (cache) '[domainname].com/MX/IN' denied
« Reply #3 on: May 15, 2020, 11:53:41 AM »
I am able to ping ns1.hostingawebsite.in and ns2.hostingawebsite.in to correct IPs from my computer and online ping tools.

Edit Nameservers inside CWP not resolving the same to IP

in etc/resolv.conf I have

Quote
nameserver 8.8.8.8
nameserver 8.8.4.4

Online
***
Re: query (cache) '[domainname].com/MX/IN' denied
« Reply #4 on: May 15, 2020, 11:54:52 AM »
Make sure your nameservers have glue records at the registrar.  Also make sure the domains don't have ns1.centos-webpanel as their ns
Google Hangouts:  rcschaff82@gmail.com

Online
***
Re: query (cache) '[domainname].com/MX/IN' denied
« Reply #5 on: May 15, 2020, 12:06:48 PM »
You have a nameservers hell going on

Code: [Select]
NS1.SITEURLHOSTING.COM. IN NS
;ANSWER
;AUTHORITY
SITEURLHOSTING.COM. 1799 IN SOA ns3.siteurl.in. support.siteurl.in. 2020051320 3600 7200 1209600 86400
;ADDITIONAL

Pick one nameserver set, set all your domains to it, and add glue records.  Too many lookups are cause DNS to fail
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: query (cache) '[domainname].com/MX/IN' denied
« Reply #6 on: May 15, 2020, 01:09:41 PM »
You have a nameservers hell going on

Code: [Select]
NS1.SITEURLHOSTING.COM. IN NS
;ANSWER
;AUTHORITY
SITEURLHOSTING.COM. 1799 IN SOA ns3.siteurl.in. support.siteurl.in. 2020051320 3600 7200 1209600 86400
;ADDITIONAL

Ok. I was thinking we can use multiple name server sets.

I have deleted all except

ns1.hostingawebsite.in
ns2.hostingawebsite.in

Also in cwp - name servers, have set these 2

Also in domain registrar has set ns1 and ns2 host records

Also A records & NS records are present

Anything else to be done?

Pick one nameserver set, set all your domains to it, and add glue records.  Too many lookups are cause DNS to fail

Offline
*
Re: query (cache) '[domainname].com/MX/IN' denied
« Reply #7 on: May 15, 2020, 02:15:56 PM »
Quote
rDNS/PTR check for IP 95.111.236.219 = not found!
rDNS/PTR check for IP 95.111.236.221 = not found!

but when i check reverse DNS from outside, it is resolving properly to hosting.siteurl.in

Offline
*
Re: query (cache) '[domainname].com/MX/IN' denied
« Reply #8 on: May 15, 2020, 02:56:39 PM »
OK SOLVED

Disabling networkmanager helped

This is the second server I encountered this issue.

https://forum.centos-webpanel.com/index.php?topic=5179.msg30045#msg30045

Quote
# systemctl stop NetworkManager
# systemctl disable NetworkManager
# nmcli device status

# systemctl list-unit-files | grep NetworkManager

# systemctl enable network.service
# systemctl restart network.service

Reboot The Machine
# reboot

Credit: https://www.awsmonster.com/2019/01/cwp-installation-perquisite-disable.html

I guess (not an expert), this should be done in cwp installation

Online
***
Re: query (cache) '[domainname].com/MX/IN' denied
« Reply #9 on: May 15, 2020, 08:33:42 PM »
Glad you got this resolved.

I see your point in that it should be "Notated" in the installation instructions, but something like this should not be done automatically.

98% of the installs should be on a VPS that sets a static IP for the system anyways, so this is a rare error.  However people setting up on a remote VM would run into trouble if they don't have a static IP assigned, and NetworkManager is turned off.  It would cause the system to brick, and have to have an onsite tech set the static IP. 

I guess it should be noted that on the install page, they do say set a static IP, which "SHOULD" mean NetworkManager is turned off.  But I digress.
Google Hangouts:  rcschaff82@gmail.com