Author Topic: PHP not working while static pages do  (Read 595 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
PHP not working while static pages do
« on: May 21, 2020, 02:17:50 PM »
I have a client (theatre) where they have a local server for ticket selling, and they were not working past two months due to corona virus. When we wanted to check server it looks php on server is not working at all but static pages do. We're receiving error 503 = The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later. There is nothing in access log. However, there is another account on server which is used for their mobile application with just an API on it, and it looks that domain IS working. I'm really confused.

I have updated linux system, deleted php 7.1 and installed 7.3 ... nothing helps.

Any idea?

Regards,
Vojin

Offline
***
Re: PHP not working while static pages do
« Reply #1 on: May 21, 2020, 02:26:28 PM »
check their website config file:

apache:  /usr/local/apache/conf.d/vhosts/(domain).(?ssl).conf
nginx: /etc/nginx/conf.d/vhosts/(domain).(?ssl).conf

Look for .sock file in the config, and make sure it exists.

If your using php-fpm, make sure all version of php-fpm are running
systemctl status php-fpm(73,72,70)
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: PHP not working while static pages do
« Reply #2 on: May 21, 2020, 04:44:58 PM »
in the .conf file I see:

Code: [Select]
        <IfModule proxy_fcgi_module>
                <FilesMatch \.php$>
                        SetHandler "proxy:unix:/opt/alt/php-fpm71/usr/var/sockets/lokalmad.sock|fcgi://localhost"
                </FilesMatch>
        </IfModule>
but folder /opt/alt is completely empty.

Another site (API one) which is working does not have these lines .... I have removed lines and rebuild configuration and now works. :)