Author Topic: IONCUBE LOADER PHP 7.3  (Read 1014 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
IONCUBE LOADER PHP 7.3
« on: June 08, 2020, 01:49:04 AM »
I've just compiled PHP 7.3.18 (after long time on 7.2.9). Once finished, one of my site refused to load as it was missing ioncube loader.
So I went back to the compiler and ticked the ioncube module to be installed. When finished I saw it ended with an error for 7.3:


Code: [Select]
'ioncube_loader_lin_7.1.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.1.so'
'ioncube_loader_lin_7.1_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.1_ts.                                                                                                                                                             so'
'ioncube_loader_lin_7.2.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.2.so'
'ioncube_loader_lin_7.2_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.2_ts.                                                                                                                                                             so'
'loader-wizard.php' -> '/usr/local/ioncube/loader-wizard.php'
yes: standard output: Broken pipe
yes: write error


Checking the /use/local/incube folder indeed shows that there's no ioncube_loader_lin_7.3_ts.so and ioncube_loader_lin_7.3.so files.
So I had to set this domain to 7.2 again.


How can this be fixed please?
« Last Edit: June 08, 2020, 02:19:37 AM by ring_c »

Offline
*
Re: IONCUBE LOADER PHP 7.3
« Reply #1 on: June 08, 2020, 02:19:10 AM »
Did you try running sh /scripts/update_ioncube ?

Offline
**
Re: IONCUBE LOADER PHP 7.3
« Reply #2 on: June 08, 2020, 02:22:03 AM »
Did you try running sh /scripts/update_ioncube ?
Actually not. I wasn't aware of this, and I see that fixed it.
Anyway, I manage to fix it myself just a minute before your answer (thank you) by simply downloading ioncube from its site and copying the 7.3 files to its folder on the server.


Thank you again.

Offline
*
Re: IONCUBE LOADER PHP 7.3
« Reply #3 on: June 08, 2020, 02:27:40 AM »
Did you try running sh /scripts/update_ioncube ?
Actually not. I wasn't aware of this, and I see that fixed it.
Anyway, I manage to fix it myself just a minute before your answer (thank you) by simply downloading ioncube from its site and copying the 7.3 files to its folder on the server.


Thank you again.
No problem. After reading your post I checked both of my servers and one didnt have them as well. When I ran that it fixed the issue. So thanks for bringing it to my attention. ;D

Offline
**
Re: IONCUBE LOADER PHP 7.3
« Reply #4 on: July 03, 2020, 06:22:22 AM »
Did you try running sh /scripts/update_ioncube ?
I've compiled the latest 7.3 version today (7.3.19, I was at 7.3.18) and it happened again. I've ran your command and it worked perfectly, thank you.


But, I still have 2 questions:
1. Why CWP don't take care of that while compiling the new php version?
2. Why only part of my wordpress sites (actually only one) shows errors when trying to reach wp-admin?