Author Topic: iOS devices can't access SSL sites  (Read 129 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
iOS devices can't access SSL sites
« on: September 08, 2020, 01:49:58 PM »
Well, this was a hard one...
Generally all the hosted sites on my CWP server are going through CloudFlare.
A few days ago I've tried to check something in one of the sites, hence grayed out the CloudFlare cloud, meaning the user is reaching the site directly. Then it seemed that iOS devices (I've tried iPhones and iPad) can't reach the site at all, getting a ERR_FAILED (This site can't be reached).



Ok... I've tried the same for other sites - all with the same symptoms - iOS can't reach the site.
I've suspected there's something with the SSL, so I've deleted the SSL and launched the site using HTTP - and it worked!
Recreating the SSL (using the built in Let's Encrypt mechanism) and access the site through HTTPS caused the same error again.


Can any one check this issue with one of his sites?
Do anyone has any clue where the problem can be?
I'm hopeless... already sitting on this for 2 days and no solution!


PS: I'm using CWP Pro.
« Last Edit: September 08, 2020, 01:51:38 PM by ring_c »

Offline
**
Re: iOS devices can't access SSL sites
« Reply #1 on: September 10, 2020, 06:32:37 AM »
Ok, I've fixed it.[/size]It seems I've installed HTTP/2 both in Nginx and Apache. Removing it from Apache - fixed the issue.Actually, I've emptied the http2.conf file and recompiled Apache.[/color]