Author Topic: DNS Failed to BIND after adding nameserver  (Read 79 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
DNS Failed to BIND after adding nameserver
« on: June 28, 2020, 02:59:11 AM »
I have a DNS server from google cloud. After adding it to my CWP account, I couldn't start the DNS BIND as it keeps showing the error below. I will be glad if someone could give a solution to the problem.


● named.service - Berkeley Internet Name Domain (DNS)
   Loaded: loaded (/usr/lib/systemd/system/named.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sun 2020-06-28 02:21:18 UTC; 3min 26s ago
  Process: 10625 ExecStartPre=/bin/bash -c if [ ! "$DISABLE_ZONE_CHECKING" == "yes" ]; then /usr/sbin/named-checkconf -z "$NAMEDCONF"; else echo "Checking of zone files is disabled"; fi (code=exited, status=1/FAILURE)

Jun 28 02:21:18 hydoo-shop bash[10625]: dns_rdata_fromtext: /var/named/cryptobox.ga.db:11: near 'ns-cloud-e1.googledomains.com..': empty label
Jun 28 02:21:18 hydoo-shop bash[10625]: dns_rdata_fromtext: /var/named/cryptobox.ga.db:12: near 'ns-cloud-e2.googledomains.com..': empty label
Jun 28 02:21:18 hydoo-shop bash[10625]: /var/named/cryptobox.ga.db:24: file does not end with newline
Jun 28 02:21:18 hydoo-shop bash[10625]: zone cryptobox.ga/IN: loading from master file /var/named/cryptobox.ga.db failed: empty label
Jun 28 02:21:18 hydoo-shop bash[10625]: zone cryptobox.ga/IN: not loaded due to errors.
Jun 28 02:21:18 hydoo-shop bash[10625]: _default/cryptobox.ga/IN: empty label
Jun 28 02:21:18 hydoo-shop systemd[1]: named.service: control process exited, code=exited status=1
Jun 28 02:21:18 hydoo-shop systemd[1]: Failed to start Berkeley Internet Name Domain (DNS).
Jun 28 02:21:18 hydoo-shop systemd[1]: Unit named.service entered failed state.
Jun 28 02:21:18 hydoo-shop systemd[1]: named.service failed.