Author Topic: cron_notificate_user  (Read 277 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
cron_notificate_user
« on: July 03, 2020, 04:30:36 AM »
Hello,


I didn't really know where to post this question. I hope I'm in the right forum.
Anyway, every day I'm getting a few emails with errors from cron jobs. One of them is the following:



Email subject:
Cron <root@cwp> /usr/local/cwp/php71/bin/php /usr/local/cwpsrv/htdocs/resources/admin/include/cron_notificate_user.php


Email content:
PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /usr/local/cwpsrv/htdocs/resources/admin/include/cron_notificate_user.php on line 0
PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /usr/local/cwpsrv/htdocs/resources/admin/include/cron_notificate_user.php on line 0
PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /usr/local/cwpsrv/htdocs/resources/admin/include/cron_notificate_user.php on line 0
PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /usr/local/cwpsrv/htdocs/resources/admin/include/cron_notificate_user.php on line 0


The funny thing is that I'm not actually running php 7.1 and I can't figure out why cron/CWP are using it.
In php version switcher v2 the version used it 7.3.18.
In php selector v2 version 7.1 is not even installed. Version 7.2 is installed.
In php-fpm selector it is installed, but there are many other php version installed too.


To make a long story short - how can I get rid of these errors, and how can I make sure cron/cwp are using the latest php version installed/defined?


TIA.


Offline
*****
Re: cron_notificate_user
« Reply #1 on: July 04, 2020, 06:35:13 AM »
it can be safely ignored.

Offline
**
Re: cron_notificate_user
« Reply #2 on: July 04, 2020, 06:11:20 PM »
it can be safely ignored.
But I don't want to get it, it's annoying.
And what about it being php 7.1 while I'm using 7.3?

Offline
*
Re: cron_notificate_user
« Reply #3 on: July 05, 2020, 09:30:05 AM »
CWP itself uses php 7.1 at the backend. Take a look at the path.

Any try updating your cron job defining the php path.

/usr/local/bin/php /path/to/the/file.php
« Last Edit: July 05, 2020, 09:35:30 AM by mirdul611 »