Author Topic: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name val  (Read 1932 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Hello Fellows,

I have a problem with my vps. The emails from the mailboxes work perfectly however, no form works and when I see the logs in / var / log / maillog I find the following: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name value : nobody

I can't find the solution. Can you help me? Thank you!

Offline
*
# nano /etc/passwd
Uncomment nobody user

# service postfix restart

Offline
*
Hello!!!
Thank you for your answear! but im into the file /etc/passwd and i didnt find user nobody user. Im just find this: nobody:x:99:99:Nobody:/:/sbin/nologin
Any other idea?

Thank you very much!!!

Offline
*
Try running `postfix set-permissions` as root then restart the service.

Offline
*
hmmm nobody is used by apache so maybe it is mail sending with php.
can you check httpd logs ?

Offline
*
Hello,

When i run command postfix set-permissions its tell me the following:

[root@vps log]# postfix set-permissions
postfix: Postfix is running with backwards-compatible default settings
postfix: See http://www.postfix.org/COMPATIBILITY_README.html for details
postfix: To disable backwards compatibility use "postconf compatibility_level=2" and "postfix reload"