Author Topic: SpamAssassin High CPU Usage  (Read 5781 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
SpamAssassin High CPU Usage
« on: September 06, 2020, 03:44:16 AM »
Followed the Wiki at http://wiki.centos-webpanel.com/how-to-configure-spamassassin

Thought when you rebuilt the Email Server and had this option checked, it enabled it.
But apparently it doesn't, since all the line listed in the Wiki are missing.


After Enabling now though, CPU usable is at 100% for spamd

33279 root      20   0  185136  74772   8532 R 100.0   0.9   0:01.48 spamd


Does the Wiki have to still be done for CWPpro 0.9.8.1006?
Or am I missing something?

Offline
*
Re: SpamAssassin High CPU Usage
« Reply #1 on: September 06, 2020, 07:49:25 AM »
First I had a problem that clamav and amavis had stopped and my mails got stuck in the postfix mail queue. This problem was solved by the mail server rebuilt.

Now my CPU meter keeps ticking 50 percent.
In the top stats, just like yours 100% in use.

I'm not too happy about this.

I reinstall everything and i got an error:
● clamd.service - clamd scanner () daemon
   Loaded: loaded (/usr/lib/systemd/system/clamd.service; disabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Sun 2020-09-06 09:45:12 CEST; 57s ago
     Docs: man:clamd(8)
           man:clamd.conf(5)
           https://www.clamav.net/documents/
 Main PID: 22278 (code=exited, status=203/EXEC)

Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Started clamd scanner () daemon.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: clamd.service: main process exited, code=exited, status=203/EXEC
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Unit clamd.service entered failed state.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: clamd.service failed.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: clamd.service holdoff time over, scheduling restart.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Stopped clamd scanner () daemon.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: start request repeated too quickly for clamd.service
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Failed to start clamd scanner () daemon.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Unit clamd.service entered failed state.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: clamd.service failed.

amaviaAV:
● amavisd.service - Amavis mail content checker
   Loaded: loaded (/usr/lib/systemd/system/amavisd.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: http://www.ijs.si/software/amavisd/#doc

Sep 05 18:22:18 srv1.cs-hosting.nl systemd[1]: Starting Amavis mail content checker...
Sep 05 18:22:19 srv1.cs-hosting.nl systemd[1]: Started Amavis mail content checker.
Sep 05 18:23:32 srv1.cs-hosting.nl systemd[1]: Stopping Amavis mail content checker...
Sep 05 18:23:33 srv1.cs-hosting.nl systemd[1]: Stopped Amavis mail content checker.
Sep 05 18:24:00 srv1.cs-hosting.nl systemd[1]: Starting Amavis mail content checker...
Sep 05 18:24:01 srv1.cs-hosting.nl systemd[1]: Started Amavis mail content checker.
Sep 06 09:44:59 srv1.cs-hosting.nl systemd[1]: Stopping Amavis mail content checker...
Sep 06 09:45:04 srv1.cs-hosting.nl systemd[1]: Stopped Amavis mail content checker.

something is realy fucked up.

Offline
*
Re: SpamAssassin High CPU Usage
« Reply #2 on: September 06, 2020, 07:51:28 AM »
Ow i forgot:
this error i get after reinstall:

mv: cannot stat ‘clamd@scan.service’: No such file or directory

Offline
***
Re: SpamAssassin High CPU Usage
« Reply #3 on: September 06, 2020, 09:57:08 AM »
+1

Offline
*
Re: SpamAssassin High CPU Usage
« Reply #4 on: September 06, 2020, 12:36:02 PM »
First I had a problem that clamav and amavis had stopped and my mails got stuck in the postfix mail queue. This problem was solved by the mail server rebuilt.

Now my CPU meter keeps ticking 50 percent.
In the top stats, just like yours 100% in use.

I'm not too happy about this.

I reinstall everything and i got an error:
● clamd.service - clamd scanner () daemon
   Loaded: loaded (/usr/lib/systemd/system/clamd.service; disabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Sun 2020-09-06 09:45:12 CEST; 57s ago
     Docs: man:clamd(8)
           man:clamd.conf(5)
           https://www.clamav.net/documents/
 Main PID: 22278 (code=exited, status=203/EXEC)

Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Started clamd scanner () daemon.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: clamd.service: main process exited, code=exited, status=203/EXEC
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Unit clamd.service entered failed state.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: clamd.service failed.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: clamd.service holdoff time over, scheduling restart.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Stopped clamd scanner () daemon.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: start request repeated too quickly for clamd.service
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Failed to start clamd scanner () daemon.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Unit clamd.service entered failed state.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: clamd.service failed.

amaviaAV:
● amavisd.service - Amavis mail content checker
   Loaded: loaded (/usr/lib/systemd/system/amavisd.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: http://www.ijs.si/software/amavisd/#doc

Sep 05 18:22:18 srv1.cs-hosting.nl systemd[1]: Starting Amavis mail content checker...
Sep 05 18:22:19 srv1.cs-hosting.nl systemd[1]: Started Amavis mail content checker.
Sep 05 18:23:32 srv1.cs-hosting.nl systemd[1]: Stopping Amavis mail content checker...
Sep 05 18:23:33 srv1.cs-hosting.nl systemd[1]: Stopped Amavis mail content checker.
Sep 05 18:24:00 srv1.cs-hosting.nl systemd[1]: Starting Amavis mail content checker...
Sep 05 18:24:01 srv1.cs-hosting.nl systemd[1]: Started Amavis mail content checker.
Sep 06 09:44:59 srv1.cs-hosting.nl systemd[1]: Stopping Amavis mail content checker...
Sep 06 09:45:04 srv1.cs-hosting.nl systemd[1]: Stopped Amavis mail content checker.

something is realy fucked up.

Today we have had problems with the use of CPU with the process clamd/amavis, if it serves you I pass this link where I put 3 commands that have solved it and eliminated the use of 100% CPU.

https://www.coriaweb.hosting/clientes/index.php/knowledgebase/33/Amavis-orClamd-esta-utilizando-el-100-de-CPU.html
Partner de CWP

Hosting de calidad en España con soporte en Español para CWP - https://www.coriaweb.hosting

Offline
**
Re: SpamAssassin High CPU Usage
« Reply #5 on: September 06, 2020, 03:25:58 PM »
Problem is, when you do a Mail Server Rebuild, it does away with the changes to the config files to activate SpamAssassin.
So your right back to square one.

My mail also got stuck in the queue.

I wound up just disabling SpamAssassin for now.

The server can handle 100% for 1 CPU core.


Another problem I noticed, is last night I did a kernel update and dnf update Amavis as well.
This broke the client from being able to use mail.domaname.com, and had to resort going back to using the hostname for SMTP & IMAP.

He wasn't too happy about that, but at least it working for now.

Offline
**
Re: SpamAssassin High CPU Usage
« Reply #6 on: September 06, 2020, 03:49:10 PM »
Did those 3 steps, am getting:

** (pkttyagent:9592): WARNING **: 15:47:20.946: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject
Error registering authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject (polkit-error-quark, 0)


But clamd CPU did go down.

Offline
*
Re: SpamAssassin High CPU Usage
« Reply #7 on: September 06, 2020, 04:15:06 PM »

Another problem I noticed, is last night I did a kernel update and dnf update Amavis as well.
This broke the client from being able to use mail.domaname.com, and had to resort going back to using the hostname for SMTP & IMAP.


I reported this to the CWP team two days ago and it is already fixed, they told me that in the next update it will be fixed.

You can fix it this way:

1º Remove all SSL from the domain you have the problem with.

2º Issue the SSL only for the domain ( without marking any other service, mail, webmail, etc...).

3º Issue the SSL for the services ( mail, webmail, etc...).

4º Execute this command through SSH: postmap -F hash:/etc/postfix/vmail_ssl.map

5º Restart Dovecot.

With these steps you should get mail.domain working again
Partner de CWP

Hosting de calidad en España con soporte en Español para CWP - https://www.coriaweb.hosting

Offline
*
Re: SpamAssassin High CPU Usage
« Reply #8 on: September 06, 2020, 04:16:59 PM »
Did those 3 steps, am getting:

** (pkttyagent:9592): WARNING **: 15:47:20.946: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject
Error registering authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject (polkit-error-quark, 0)


But clamd CPU did go down.

That error should be ignored, anyway if you have already lowered the CPU, is that it is solved.
Partner de CWP

Hosting de calidad en España con soporte en Español para CWP - https://www.coriaweb.hosting

Offline
***
Re: SpamAssassin High CPU Usage
« Reply #9 on: September 08, 2020, 07:29:39 AM »
First I had a problem that clamav and amavis had stopped and my mails got stuck in the postfix mail queue. This problem was solved by the mail server rebuilt.

Now my CPU meter keeps ticking 50 percent.
In the top stats, just like yours 100% in use.

I'm not too happy about this.

I reinstall everything and i got an error:
● clamd.service - clamd scanner () daemon
   Loaded: loaded (/usr/lib/systemd/system/clamd.service; disabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Sun 2020-09-06 09:45:12 CEST; 57s ago
     Docs: man:clamd(8)
           man:clamd.conf(5)
           https://www.clamav.net/documents/
 Main PID: 22278 (code=exited, status=203/EXEC)

Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Started clamd scanner () daemon.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: clamd.service: main process exited, code=exited, status=203/EXEC
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Unit clamd.service entered failed state.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: clamd.service failed.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: clamd.service holdoff time over, scheduling restart.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Stopped clamd scanner () daemon.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: start request repeated too quickly for clamd.service
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Failed to start clamd scanner () daemon.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: Unit clamd.service entered failed state.
Sep 06 09:45:12 srv1.cs-hosting.nl systemd[1]: clamd.service failed.

amaviaAV:
● amavisd.service - Amavis mail content checker
   Loaded: loaded (/usr/lib/systemd/system/amavisd.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: http://www.ijs.si/software/amavisd/#doc

Sep 05 18:22:18 srv1.cs-hosting.nl systemd[1]: Starting Amavis mail content checker...
Sep 05 18:22:19 srv1.cs-hosting.nl systemd[1]: Started Amavis mail content checker.
Sep 05 18:23:32 srv1.cs-hosting.nl systemd[1]: Stopping Amavis mail content checker...
Sep 05 18:23:33 srv1.cs-hosting.nl systemd[1]: Stopped Amavis mail content checker.
Sep 05 18:24:00 srv1.cs-hosting.nl systemd[1]: Starting Amavis mail content checker...
Sep 05 18:24:01 srv1.cs-hosting.nl systemd[1]: Started Amavis mail content checker.
Sep 06 09:44:59 srv1.cs-hosting.nl systemd[1]: Stopping Amavis mail content checker...
Sep 06 09:45:04 srv1.cs-hosting.nl systemd[1]: Stopped Amavis mail content checker.

something is realy fucked up.

Today we have had problems with the use of CPU with the process clamd/amavis, if it serves you I pass this link where I put 3 commands that have solved it and eliminated the use of 100% CPU.

https://www.coriaweb.hosting/clientes/index.php/knowledgebase/33/Amavis-orClamd-esta-utilizando-el-100-de-CPU.html

????

Offline
***
Re: SpamAssassin High CPU Usage
« Reply #10 on: September 08, 2020, 07:30:38 AM »
Followed the Wiki at http://wiki.centos-webpanel.com/how-to-configure-spamassassin

Thought when you rebuilt the Email Server and had this option checked, it enabled it.
But apparently it doesn't, since all the line listed in the Wiki are missing.


After Enabling now though, CPU usable is at 100% for spamd

33279 root      20   0  185136  74772   8532 R 100.0   0.9   0:01.48 spamd


Does the Wiki have to still be done for CWPpro 0.9.8.1006?
Or am I missing something?


??????

Offline
*
Re: SpamAssassin High CPU Usage
« Reply #11 on: September 08, 2020, 01:09:14 PM »
Wel.. the high performance is gone.
Another problem: clamAV, and Amavis not starting when i reboot the server.
Need to manual start everything.

Offline
***
Re: SpamAssassin High CPU Usage
« Reply #12 on: September 08, 2020, 01:35:27 PM »
Wel.. the high performance is gone.
Another problem: clamAV, and Amavis not starting when i reboot the server.
Need to manual start everything.

Has high productivity not disappeared for me?

Offline
**
Re: SpamAssassin High CPU Usage
« Reply #13 on: September 08, 2020, 04:07:17 PM »
Wel.. the high performance is gone.
Another problem: clamAV, and Amavis not starting when i reboot the server.
Need to manual start everything.

Look under Services Config -> Startup Services

By Default they are set to Disabled, and you have to change them to Enabled.

Offline
***
Re: SpamAssassin High CPU Usage
« Reply #14 on: September 11, 2020, 02:11:53 PM »
High productivity has not disappeared for me?