Author Topic: SpamAssassin High CPU Usage  (Read 5704 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Re: SpamAssassin High CPU Usage
« Reply #15 on: September 17, 2020, 07:56:12 PM »

Today we have had problems with the use of CPU with the process clamd/amavis, if it serves you I pass this link where I put 3 commands that have solved it and eliminated the use of 100% CPU.

https://www.coriaweb.hosting/clientes/index.php/knowledgebase/33/Amavis-orClamd-esta-utilizando-el-100-de-CPU.html

I am still having this problem.
I did try the solutions but it doesn't work. It's starting again after a while.
Any solution?

https://prnt.sc/uj47u6

Offline
**
Re: SpamAssassin High CPU Usage
« Reply #16 on: September 17, 2020, 08:40:06 PM »
Still do intermittently as always.

It's really noticeable if you only have 1 CPU, if you have 4+ then 1 CPU maxing out doesn't affect much.

Offline
*
Re: SpamAssassin High CPU Usage
« Reply #17 on: September 18, 2020, 07:44:35 AM »
Can you try to execute this command? Sometimes it solves it.

Code: [Select]
sh /scripts/clamd_fix_100_cpu_usage

Offline
*
Re: SpamAssassin High CPU Usage
« Reply #18 on: September 18, 2020, 06:14:26 PM »
Can you try to execute this command? Sometimes it solves it.

Code: [Select]
sh /scripts/clamd_fix_100_cpu_usage
The problem continues

Offline
*
Re: SpamAssassin High CPU Usage
« Reply #19 on: September 18, 2020, 08:56:06 PM »
CONTROL WEB PANEL »WEBPANEL »CENTOS-WEBPANEL BUGS »CPU 100% CLAMD
https://forum.centos-webpanel.com/index.php?topic=4426.15

Offline
*
Re: SpamAssassin High CPU Usage
« Reply #20 on: September 22, 2020, 07:44:53 PM »
Guys, I tried all methods but none of them work.
The problem is starting again after a while.
This is really a bad situation.

Any suggestions for solution?


Offline
***
Re: SpamAssassin High CPU Usage
« Reply #21 on: September 23, 2020, 04:45:01 AM »
High productivity has not disappeared for me?

Offline
**
Re: SpamAssassin High CPU Usage
« Reply #22 on: September 23, 2020, 07:02:47 AM »
High productivity has not disappeared for me?

How many CPU's and RAM does the box have?

Offline
***
Re: SpamAssassin High CPU Usage
« Reply #23 on: September 23, 2020, 07:08:48 AM »
High productivity has not disappeared for me?

How many CPU's and RAM does the box have?

2  x  CPU Model: Intel(R) Xeon(R) CPU X5670 @ 2.93GHz
CPU Details: 8 Core (2933 MHz)
RAM - 28 GB

Offline
**
Re: SpamAssassin High CPU Usage
« Reply #24 on: September 23, 2020, 03:51:58 PM »
That definitely should be enough.
Usually clam has a problem with a single CPU and 1-2GB of RAM

Offline
***
Re: SpamAssassin High CPU Usage
« Reply #25 on: October 01, 2020, 03:10:05 PM »
That definitely should be enough.
Usually clam has a problem with a single CPU and 1-2GB of RAM

High productivity has not disappeared for me?

Offline
**
Re: SpamAssassin High CPU Usage
« Reply #26 on: October 01, 2020, 06:48:49 PM »
What happens when you run: sh /scripts/clamd_fix_100_cpu_usage

Usually that takes care of the problem, but only pops back up after a server reboot.

Offline
***
Re: SpamAssassin High CPU Usage
« Reply #27 on: October 02, 2020, 02:12:59 AM »
Of what happens and why? and is there a lasting solution ...?

Offline
**
Re: SpamAssassin High CPU Usage
« Reply #28 on: October 02, 2020, 03:12:53 AM »
I'm guessing its a bug in clamav and/or spamassassin with a cpu/memory leak.

On CentOS 7 I ran: clamscan --version

And got the current version (ClamAV 0.102.4) in the epel repo.

On a server I don't have spamassassin running, just ClamAV there isn't a problem.

Offline
***
Re: SpamAssassin High CPU Usage
« Reply #29 on: October 10, 2020, 11:35:40 AM »
Pls, help....?!?