Author Topic: New Install - Home Server- cant access login 4 panel but IP- test page OK (FIX)  (Read 4999 times)

0 Members and 1 Guest are viewing this topic.

Virtualbox - Centos 7 -  CWP new install

Haven't found much to that provides a thorough explanation. But hope this helps!.

Found the below ports information and put it off the side for referencing while TS.

CWP Admin Panel Link (by hostname) if this is at home and you have no domain pointing to your external IP then use your IP. Google what is my IP. example.

http://serverip:2030.. etc.

CWP Admin Panel Link:
CWP Admin Panel Link:
CWP Admin Panel SSL Link:
CWP Admin Panel SSL Link:

CWP User Panel Link (by hostname)

CWP User Panel Link:
CWP User Panel SSL Link:

Ran update with command:
sh /scripts/update_cwp

Checked and shows port 80 and 2030 as open.
Only opened port 2030 in router initially, then.....

I noticed that the port 2030 automatically forwarded to 2031, so I went back to my router port forwarding and added port 2031. Then the admin login worked.

Admin Login screen for panel now shows. Then tested 2086 and it didn't work. Added port 2086 to the router like I did port 2031 and nothing. So then I added 2087 and then the admin login screen worked. Then added an open port rule in router that ranged from 2082-2083 for the client-side instead of having the rules separate, but I was just proof of concept that both ports need to be open at the same time, so one open port rule should be enough for sequential ports that need to be opened...

Conclusion. You must have both admin ports (2030,2031) or admin (2086,2087) and client (2082,2083), login ports pairs open at same time for that login screen to be accessed. One port forwarding rule per pair would be enough. I originally only opened port 2030 and so it wasnt working up until I opened its corresponding "https" port.

Good luck guys!
« Last Edit: October 14, 2020, 01:08:05 AM by linuxnewb2020 »

you only need https ports
2031 or 2087

http ports are only redirecting to https so you don't need them unless you disable redirect and use http
VPS & Dedicated server provider with included FREE Managed support for CWP.

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Out the box following most installation guides, I ran across this issue, erased and installed multiple times on VIRTUALBOX Centos7 I did not run into this problem when installing on my VPS only in my home installation. that why it was weird to me. You are probably right, but if I don't know about or how to disable redirect. This is the layman's fix. I'm not a Linux guy I just know who to follow instructions and copy paste codes, I have no idea how to input syntax from scratch on Linux to perform the disabling action you just mentioned. I didn't know disabling that redirect is something you can do, there's no guide or heads up for that redirect in the guides online, they were probably meant for Linux people that would know "I need to disable redirect."  I installed at home because I need to do a migration from my VPS to do some testing.  But thanks for the heads up,
« Last Edit: October 15, 2020, 03:00:41 AM by linuxnewb2020 »