Author Topic: Can't open panel: No Loader is installed  (Read 1325 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Can't open panel: No Loader is installed
« on: October 21, 2020, 05:53:48 PM »
Hello,

I accidentally deleted the /usr/local/cwp/php71/php.ini file and copied the /usr/local/php/php.ini in its place. At the time I didn't realize that the cwp .ini file had cwp specific module information. 

When I try to load the panel login I get the following error:

   No Loader is installed, please try to run this command or
   contact support: sh /scripts/update_ioncube restart

I ran sh /scripts/update_ioncube restart with no errors, but still can't start the panel.

I added this to the copied /usr/local/cwp/php71/php.ini file, but it didn't help the outcome:

   zend_extension = /usr/local/ioncube/ioncube_loader_lin_7.4.so

How can I get a hold of a copy of the correct cwp php.ini file for php 7.4.11?  Or how can I recreate this file with having to rebuild cwp and loose hours of work?  Is this even the cause of my problem?

Thank you.



Re: Can't open panel: No Loader is installed
« Reply #1 on: October 21, 2020, 10:11:10 PM »
You're mentioning two different versions of PHP, which is not giving clarity to your question.
On a CWP Pro instance, I have just run a
Code: [Select]
diff /usr/local/php/php.ini  /usr/local/cwp/php71/php.ini
and there's a huge difference.
Can't upload attachments, so you may have to install CWP to a temporary VPS,to grab the file. Perhaps someone will provide a link to the file.

[Edit]
Short-lived share: http://www.filedropper.com/cwp-php71ini
« Last Edit: October 21, 2020, 10:28:32 PM by cynique »

Offline
*
Re: Can't open panel: No Loader is installed
« Reply #2 on: October 26, 2020, 03:57:36 PM »
Thanks, cynique for the php.ini file.  Unfortunately it was too late to save the installation.  I ended up having to rebuild the entire system.  Luckily I wasn't too far along in setting up the server when this occurred.

Re: Can't open panel: No Loader is installed
« Reply #3 on: October 26, 2020, 04:21:29 PM »
Crikey! That was days ago - a lot of water under the bridge since then. I'd forgot.   :o
I did add the file within half an hour, or so. You must be 'merican = difference pace. :P