Author Topic: PHP switcher not working on newly installed CWP.  (Read 1694 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
PHP switcher not working on newly installed CWP.
« on: October 23, 2020, 08:58:33 PM »
I am trying to upgrade the default PHP 5.6 to PHP 7.4.x  but the PHP switcher is not working.   

Does anyone solve this?

------
https://CyFocus.com - Domain, Hosting, Ecommerce, SEO

Offline
*
Re: PHP switcher not working on newly installed CWP.
« Reply #1 on: October 23, 2020, 10:47:32 PM »
What is the problem you have had? What error are you getting?

Offline
*****
Re: PHP switcher not working on newly installed CWP.
« Reply #2 on: October 24, 2020, 05:27:05 PM »
low ram can be an issue or other dependencies are failing to install because of OS issue. CHECK LOG

Offline
*
Re: PHP switcher not working on newly installed CWP.
« Reply #3 on: October 26, 2020, 12:49:42 AM »
low ram can be an issue or other dependencies are failing to install because of OS issue. CHECK LOG

I have 32 gig of ram.  Which log can I check? 
------
https://CyFocus.com - Domain, Hosting, Ecommerce, SEO

Offline
*
Re: PHP switcher not working on newly installed CWP.
« Reply #4 on: October 26, 2020, 12:50:14 AM »
What is the problem you have had? What error are you getting?

There were no error.  It wasn't updating.  Did you try updating yours? 
------
https://CyFocus.com - Domain, Hosting, Ecommerce, SEO

Offline
***
Re: PHP switcher not working on newly installed CWP.
« Reply #5 on: October 26, 2020, 01:27:48 AM »
low ram can be an issue or other dependencies are failing to install because of OS issue. CHECK LOG

I have 32 gig of ram.  Which log can I check?
Looks like you don't pay much attention - scroll to the bottom,when you initiate a build and you'll see:
Quote
PHP Compiler Started in Background. You can monitor PHP rebuild from the console using command: tail -f /var/log/php-rebuild.log
Granted,it would be more useful/noticeable if the message box appeared at the top, given that screen automatically refreshes at the top.  ???
(My 1GB RAM VPS has now locked up reverting 7.4.11 to the last 5.4 build.. patience!)

10 minutes later..
Quote
tail -f /var/log/php-rebuild.log
You may want to add: /usr/local/lib/php to your php.ini include_path
/usr/local/src/php-build/php-5.4.45/build/shtool install -c ext/phar/phar.phar /usr/local/bin
ln -s -f /usr/local/bin/phar.phar /usr/local/bin/phar
Installing PDO headers:          /usr/local/include/php/ext/pdo/
Make Install DONE!
####################
PHP Rebuild Completed
#########################

DELETING DSO Handler
^C

It's CPU & disc bound, not RAM
Quote
Load: 18.02  14.64  6.94
Memory RAM (with Cache): 0.86GB / 1GB ( 86%)
Swap Memory: 0.01GB / 1GB ( 1% )
System CPU Model: AMD Ryzen 9 3950X 16-Core Processor
VPS CPU Details: 1 Core (3493 MHz)
NVMe Disc I/O peaking frequently at 100
« Last Edit: October 26, 2020, 01:52:21 AM by cynique »