Author Topic: CWP | User login --> uerror  (Read 1377 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
CWP | User login --> uerror
« on: November 23, 2020, 12:22:10 AM »
I'm really feeling very frustrated..   >:( >:(
6 hours now and I couldn't figure it out.
Today, and without a good reason I had a "uerror" when trying to login into CWP user panel.


I'm pretty sure of the credentials, also, I've done the following:

1- Changed the user package.
2- Tried to update CWP.
3- Restarted all services.
4- Rebooted server.
5-Deleted and re-created the account.

here are some error logs:

apache error log: https://pastebin.com/HEz5rN4F
cwp php-fpm log: https://pastebin.com/hcHbzUCj
php-fpm-slowlog-cwpsrv: https://pastebin.com/J87b10hV
php-fpm-slowlog-someuser: https://pastebin.com/Yyi53kNc

Any help would be greatly appreciated  :-*


Offline
*
Re: CWP | User login --> uerror
« Reply #1 on: November 23, 2020, 11:52:56 AM »
Hello
run this and try to login, this will help locate the problem
Leave them here and I'll help you solve it

Code: [Select]
tail -f /usr/local/cwp/php71/var/log/php-fpm*.log

Offline
*
Re: CWP | User login --> uerror
« Reply #2 on: November 23, 2020, 04:37:22 PM »
Thanks for your reply:

By the way I've upgraded to PHP 7.4, and this is the result of your given command:

Code: [Select]
[root@server ~]# tail -f /usr/local/cwp/php71/var/log/php-fpm*.log
==> /usr/local/cwp/php71/var/log/php-fpm-slowlog-ahmed.log <==
[0x00007f5027830f50] compileSource() /usr/local/cwpsrv/var/services/twig/lib/Twig/Environment.php:363
[0x00007f5027830b60] loadTemplate() /usr/local/cwpsrv/var/services/twig/lib/Twig/Template.php:329
[0x00007f50278309a0] loadTemplate() /usr/local/cwpsrv/var/services/twig/lib/Twig/Environment.php(373) : eval()'d code:369
[0x00007f502782d0a0] doDisplay() /usr/local/cwpsrv/var/services/twig/lib/Twig/Template.php:389
[0x00007f502782cf40] displayWithErrorHandling() /usr/local/cwpsrv/var/services/twig/lib/Twig/Template.php:366

[23-Nov-2020 00:34:10]  [pool ahmed] pid 34859
script_filename = /usr/local/cwpsrv/var/services/users/ahmed/index.php
[0x00007fda3c22d040] curl_exec() /usr/local/cwpsrv/var/services/users/index.php:0
[0x00007fda3c22cd50] sencurl() /usr/local/cwpsrv/var/services/users/index.php:0

==> /usr/local/cwp/php71/var/log/php-fpm-slowlog-cwpsrv.log <==

[23-Nov-2020 01:42:37]  [pool cwpsrv] pid 40943
script_filename = /usr/local/cwpsrv/htdocs/admin/login/index.php
[0x00007f06f7a1d5c0] shell_exec() /usr/local/cwpsrv/htdocs/resources/admin/include/functions/func_system.php:0
[0x00007f06f7a1d530] ssh_exec() /usr/local/cwpsrv/htdocs/admin/login/index.php:0

[23-Nov-2020 02:22:41]  [pool cwpsrv] pid 42712
script_filename = /usr/local/cwpsrv/htdocs/admin/login/index.php
[0x00007f06f7a1d5c0] shell_exec() /usr/local/cwpsrv/htdocs/resources/admin/include/functions/func_system.php:0
[0x00007f06f7a1d530] ssh_exec() /usr/local/cwpsrv/htdocs/admin/login/index.php:0

==> /usr/local/cwp/php71/var/log/php-fpm-slowlog-cwpsvc.log <==

[22-Nov-2020 17:32:16]  [pool cwpsvc] pid 126360
script_filename = /usr/local/cwpsrv/var/services/pma/import.php
[0x00007fe01e821130] extract() /usr/local/cwpsrv/var/services/pma/libraries/plugins/import/ImportSql.php:129
[0x00007fe01e820de0] doImport() /usr/local/cwpsrv/var/services/pma/import.php:536

==> /usr/local/cwp/php71/var/log/php-fpm.log <==
[23-Nov-2020 10:10:30] WARNING: [pool login] child 54253 said into stderr: "NOTICE: PHP message: PHP Notice:  Undefined index: intended in /usr/local/cwpsrv/var/services/users/login/index.php on line 0"
[23-Nov-2020 10:10:30] WARNING: [pool login] child 54253 said into stderr: "NOTICE: PHP message: PHP Notice:  Undefined index: intended in /usr/local/cwpsrv/var/services/users/login/index.php on line 0"
[23-Nov-2020 10:55:01] WARNING: [pool login] child 55308 said into stderr: "NOTICE: PHP message: PHP Notice:  Undefined index: intended in /usr/local/cwpsrv/var/services/users/login/index.php on line 0"
[23-Nov-2020 10:55:01] WARNING: [pool login] child 55308 said into stderr: "NOTICE: PHP message: PHP Notice:  Undefined index: intended in /usr/local/cwpsrv/var/services/users/login/index.php on line 0"
[23-Nov-2020 13:40:01] WARNING: [pool login] child 58888 said into stderr: "NOTICE: PHP message: PHP Notice:  Undefined index: HTTP_ACCEPT_LANGUAGE in /usr/local/cwpsrv/var/services/users/login/index.php on line 0"
[23-Nov-2020 13:40:01] WARNING: [pool login] child 58888 said into stderr: "NOTICE: PHP message: PHP Warning:  parse_ini_file(/usr/local/cwpsrv/var/services/users/login/conf/en.ini): failed to open stream: No such file or directory in /usr/local/cwpsrv/var/services/users/login/index.php on line 0"
[23-Nov-2020 13:40:01] WARNING: [pool login] child 58888 said into stderr: "NOTICE: PHP message: PHP Notice:  Undefined index: intended in /usr/local/cwpsrv/var/services/users/login/index.php on line 0"
[23-Nov-2020 13:40:01] WARNING: [pool login] child 58888 said into stderr: "NOTICE: PHP message: PHP Notice:  Undefined index: intended in /usr/local/cwpsrv/var/services/users/login/index.php on line 0"
[23-Nov-2020 18:34:20] WARNING: [pool login] child 65870 said into stderr: "NOTICE: PHP message: PHP Notice:  Undefined index: intended in /usr/local/cwpsrv/var/services/users/login/index.php on line 0"
[23-Nov-2020 18:34:20] WARNING: [pool login] child 65870 said into stderr: "NOTICE: PHP message: PHP Notice:  Undefined index: intended in /usr/local/cwpsrv/var/services/users/login/index.php on line 0"

EDIT: I think the problem is here:

Code: [Select]
=> /usr/local/cwp/php71/var/log/php-fpm.log <==
[23-Nov-2020 18:34:20] WARNING: [pool login] child 65870 said into stderr: "NOTICE: PHP message: PHP Notice:  Undefined index: intended in /usr/local/cwpsrv/var/services/users/login/index.php on line 0"
[23-Nov-2020 18:34:20] WARNING: [pool login] child 65870 said into stderr: "NOTICE: PHP message: PHP Notice:  Undefined index: intended in /usr/local/cwpsrv/var/services/users/login/index.php on line 0"
« Last Edit: November 23, 2020, 04:43:46 PM by Ahmed Suror »

Offline
*
Re: CWP | User login --> uerror
« Reply #3 on: November 24, 2020, 10:55:46 AM »
Ohh

Apparently this file is missing: /usr/local/cwpsrv/var/services/users/login/conf/en.ini

i suggest you run cwp update manually and this will solve this problem

Code: [Select]
sh /scripts/update_cwp

Offline
*
Re: CWP | User login --> uerror
« Reply #4 on: November 24, 2020, 12:20:32 PM »
I've done the update and this is the result:
Code: [Select]
[root@server ~]# sh /scripts/update_cwp


====================================================
============= CentOS Web Panel Cron ================
====================================================


###########################
Firewall Flush Daily Blocks
###########################


######################
Update Server Packages
######################
Redirecting to /bin/systemctl restart cwpsrv.service
Redirecting to /bin/systemctl restart httpd.service
Redirecting to /bin/systemctl reload httpd.service
Redirecting to /bin/systemctl reload httpd.service
And unfortunately, this didn't help!
Also, I tried a hack:
I've copied
Code: [Select]
en.ini from the path
Code: [Select]
/usr/local/cwpsrv/var/services/users/login/conf/lang/en.ini to the path given in the warning message
Code: [Select]
/usr/local/cwpsrv/var/services/users/login/conf/en.ini, but no luck also!! :'( :'(


EDIT: I found something in cwpsrv error_log that might help: "POST /v1/loginfail/ HTTP/1.1", host: "127.0.0.1:2302"
Code: [Select]
2020/11/24 14:48:12 [notice] 175494#0: *478 "^/v1/([^/]+)/?$" matches "/v1/loginfail/", client: 127.0.0.1, server: localhost, request: "POST /v1/loginfail/ HTTP/1.1", host: "127.0.0.1:2302"
2020/11/24 14:48:12 [notice] 175494#0: *478 rewritten data: "/v1/index.php", args: "method=", client: 127.0.0.1, server: localhost, request: "POST /v1/loginfail/ HTTP/1.1", host: "127.0.0.1:2302"
2020/11/24 14:48:12 [info] 175494#0: *478 client 127.0.0.1 closed keepalive connection
2020/11/24 14:48:12 [error] 175493#0: *475 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined index: intended in /usr/local/cwpsrv/var/services/users/login/index.php on line 0
PHP message: PHP Notice:  Undefined index: intended in /usr/local/cwpsrv/var/services/users/login/index.php on line 0" while reading response header from upstream, client: 154.236.91.13, server: localhost, request: "GET /login/ HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/login.sock:", host: "server.ahmedsuror.com:2083"
2020/11/24 14:48:21 [notice] 175494#0: *484 "^/v1/([^/]+)/?$" matches "/v1/valid_user/", client: 127.0.0.1, server: localhost, request: "POST /v1/valid_user/ HTTP/1.1", host: "127.0.0.1:2302"
2020/11/24 14:48:21 [notice] 175494#0: *484 rewritten data: "/v1/index.php", args: "method=", client: 127.0.0.1, server: localhost, request: "POST /v1/valid_user/ HTTP/1.1", host: "127.0.0.1:2302"
2020/11/24 14:48:21 [info] 175494#0: *484 client 127.0.0.1 closed keepalive connection
2020/11/24 14:48:23 [notice] 175494#0: *487 "^/v1/([^/]+)/?$" matches "/v1/valid_user/", client: 127.0.0.1, server: localhost, request: "POST /v1/valid_user/ HTTP/1.1", host: "127.0.0.1:2302"
2020/11/24 14:48:23 [notice] 175494#0: *487 rewritten data: "/v1/index.php", args: "method=", client: 127.0.0.1, server: localhost, request: "POST /v1/valid_user/ HTTP/1.1", host: "127.0.0.1:2302"
2020/11/24 14:48:24 [info] 175494#0: *487 client 127.0.0.1 closed keepalive connection
« Last Edit: November 24, 2020, 12:54:22 PM by Ahmed Suror »

Offline
*
Re: CWP | User login --> uerror
« Reply #5 on: November 24, 2020, 08:09:13 PM »
Please

Code: [Select]
sh /scripts/cwpsrv_rebuild_user_conf

Offline
*
Re: CWP | User login --> uerror
« Reply #6 on: November 24, 2020, 09:12:42 PM »
Result:
Code: [Select]
[root@server ~]# sh /scripts/cwpsrv_rebuild_user_conf
Redirecting to /bin/systemctl reload cwpsrv.service
Redirecting to /bin/systemctl reload cwp-phpfpm.service
But unfortunately, the same problem.
Is there any solution or should I reinstall the OS?!!

Offline
*
Re: CWP | User login --> uerror
« Reply #7 on: November 25, 2020, 01:57:04 PM »
Please can you mount a ticket to support and make mention of this thread, do not forget to add the access to your server, we will gladly solve this for you

Offline
*
Re: CWP | User login --> uerror
« Reply #8 on: November 25, 2020, 03:00:05 PM »
They already asked me for the root password but I was afraid to give it to them, so they provided my this info:
 
Code: [Select]
Hello,

for us to be able to check on your issue we will need the following

- Server IP address
- ssh port
- root user login password

For user login issues we also need a user login so we would be able to reproduce this issue.

Best Regards

and then I told them that I decline, so they replied:
Code: [Select]
Hello,

You can check this issue with your hosting provider or a server admin with experience.
In CWP we are using all default Linux software with the custom configuration so any experienced system admin should be able to assist you.

You can also use our support forum for free self-learning help with your issue
http://forum.centos-webpanel.com/

On our wiki, you can also find some useful instructions
http://wiki.centos-webpanel.com/

For a more detailed check of your server and service configuration from the cwp support staff, you can check our Support services.
Each configuration changes or issue which requires free time for resolving will need to be done via our Support services.

You can check our Support Service using the following Link
https://control-webpanel.com/support-services

With our Support services, you have an access to the support ticketing system and our developers will help you with your issues.
Once your issue is resolved our support staff will provide you with more information about your issue.

We suggest that you use our support service if your server provider has no any support service included.
Our support and development staff will try to assist you however we can, we have experienced system admins and developers.

Best Regards and Thank you for supporting further CWP Development.


So do you see that I should give them the info they asked for, and if I did, will they tell me what they did?

Offline
*
Re: CWP | User login --> uerror
« Reply #9 on: November 26, 2020, 01:53:21 PM »
Then it is difficult to help you!

Offline
*
Re: CWP | User login --> uerror
« Reply #10 on: December 04, 2020, 10:51:46 AM »
Hi friends,

Problem is in /home/{USER}/.conf/cwp.ini file. Check it. Maybe you find errors.

Offline
*
Re: CWP | User login --> uerror
« Reply #11 on: December 05, 2020, 12:36:02 AM »
Finally I found the problem but it is very strange!!

After weeks of trying, I've reinstalled the operating system.
Then I configured my server and the user panel worked correctly.
BUT...
I did these steps and the error "uerror" reappeared!!
1- Changed my default MySQL password for root from PhpMyAdmin.
2- To reflect root password changes:
 - I've changed root password in:
Code: [Select]
/usr/local/cwpsrv/htdocs/resources/admin/include/db_conn.php - I've changed root password in:
Code: [Select]
/root/.my.cnfThen tried to enter CWP user panel and again got the annoying "uerror"!!!

To confirm that this was the error, I reverted back to the default root password in all steps above and the CWP user panel worked again without the "uerror" !!

Now what happened?!! and how to get rid of this? because I want to change the default MySQL root password??