Author Topic: Trouble building PHP-FPM 7.4 from PHP-FPM Selector  (Read 389 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Trouble building PHP-FPM 7.4 from PHP-FPM Selector
« on: December 01, 2020, 07:50:03 PM »
Hi,

I had PHP-FPM 7.4.11 installed and tried to install PHP-FPM 7.4.12, that did not work with the error below.
I then removed PHP-FPM 7.4.x and have tried to install PHP-FPM 7.4.7, 7.4.10, 7.4.11 and 7.4.12 but always get the same error.
I am using:
Distro Name: CentOS Linux release 7.9.2009 (Core)
Kernel Version: 3.10.0-1160.6.1.el7.x86_64
Apache version: Apache/2.4.41
PHP version: 7.4.11 PHP-FPM is forced
Web Servers: nginx-varnish-apache
CWP 7 Pro Activated.
The error i get is:
Code: [Select]
/usr/bin/ld: warning: libssl.so.10, needed by /lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by /lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by /lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libcrypto.so.10, needed by /lib64/libssh2.so.1, may conflict with libcrypto.so.1.1
/usr/bin/ld: warning: libcrypto.so.10, needed by /lib64/libssh2.so.1, may conflict with libcrypto.so.1.1
/usr/bin/ld: warning: libcrypto.so.10, needed by /lib64/libssh2.so.1, may conflict with libcrypto.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by /lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by /lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by /lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libcrypto.so.10, needed by /lib64/libssh2.so.1, may conflict with libcrypto.so.1.1
/usr/bin/ld: warning: libcrypto.so.10, needed by /lib64/libssh2.so.1, may conflict with libcrypto.so.1.1
/usr/bin/ld: warning: libcrypto.so.10, needed by /lib64/libssh2.so.1, may conflict with libcrypto.so.1.1
Generating phar.php
PHP Fatal error:  Unable to start pcre module in Unknown on line 0
make: *** [ext/phar/phar.php] Error 254
make: *** Waiting for unfinished jobs....
/usr/bin/ld: warning: libssl.so.10, needed by /lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by /lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by /lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libcrypto.so.10, needed by /lib64/libssh2.so.1, may conflict with libcrypto.so.1.1
/usr/bin/ld: warning: libcrypto.so.10, needed by /lib64/libssh2.so.1, may conflict with libcrypto.so.1.1
/usr/bin/ld: warning: libcrypto.so.10, needed by /lib64/libssh2.so.1, may conflict with libcrypto.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by /lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by /lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by /lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libcrypto.so.10, needed by /lib64/libssh2.so.1, may conflict with libcrypto.so.1.1
/usr/bin/ld: warning: libcrypto.so.10, needed by /lib64/libssh2.so.1, may conflict with libcrypto.so.1.1
/usr/bin/ld: warning: libcrypto.so.10, needed by /lib64/libssh2.so.1, may conflict with libcrypto.so.1.1
Generating phar.phar
PHP Fatal error:  Unable to start pcre module in Unknown on line 0
make: *** [ext/phar/phar.phar] Error 254
mkdir: cannot create directory '/opt/alt/php-fpm74/usr/var/sockets/': No such file or directory
mkdir: cannot create directory '/opt/alt/php-fpm74/usr/etc/php-fpm.d/': No such file or directory
mkdir: cannot create directory '/opt/alt/php-fpm74/usr/etc/php-fpm.d/users/': No such file or directory
/usr/local/src/php-fpm-7.4.sh: line 98: /opt/alt/php-fpm74/usr/etc/php-fpm.d/users.conf: No such file or directory
/usr/local/src/php-fpm-7.4.sh: line 99: /opt/alt/php-fpm74/usr/etc/php-fpm.conf: No such file or directory
/usr/local/src/php-fpm-7.4.sh: line 101: /opt/alt/php-fpm74/usr/etc/php-fpm.d/cwpsvc.conf: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Skipping as php build failed
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Skipping as php build failed
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Skipping as php build failed
exe:/opt/alt/php-fpm74/usr/sbin/php-fpm
Redirecting to /bin/systemctl restart httpd.service

Does anyone have a solution

Re: Trouble building PHP-FPM 7.4 from PHP-FPM Selector
« Reply #1 on: December 02, 2020, 01:01:25 AM »
Why do people try to run servers, when incapable of following error messages?
I have never run into this problem because a stable server is more important than bleeding edge.
Fortunately, you have supplied the output and it is blatantly obvious to me that you have ssh2 ticked in your PHP options list. Remove it.
The alternative is to build without ssl/crypto, then add ssh2, which should add dependencies.