Author Topic: PHP Selector not work  (Read 799 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
PHP Selector not work
« on: December 09, 2020, 12:04:42 AM »
Hi,
Recently, yesterday, I install 3 cwp's and I can swtich to php 7.1.33 (main php version, not for differents domains).

Since a few hours ago, I install a new centos (same version than the other 3) and reinstall cwp some times, but never I can change my main php version 5.6.3 to 7.1.3.

I know that, I can download and install manually but...I don't need more than 1 version of php, in this days I try this new panel for me for transfer all my vps to this panel, for me, its strange, yesterday, I can change my main version in 3 vps, today, I try about 3, 4 o 5 times (fresh installs always of centos) and I can't.

Regards.

Offline
*
Re: PHP Selector not work
« Reply #1 on: December 09, 2020, 02:03:59 AM »
I view the problem, I search in:
/var/log/php-rebuild.log

and I view this error:

Error: Unknown repo: 'PowerTools'

For some reasson the last installations of this centos 8 no contain this repo, I installed epel repo, of course, for install cwp, but in my others vps I have PowerTool repo, but in this not...

Offline
*
Re: PHP Selector not work
« Reply #2 on: December 09, 2020, 06:48:03 AM »
you will need powertools repo as that is required for building PHP from source
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: PHP Selector not work
« Reply #3 on: December 09, 2020, 08:38:38 AM »
you will need powertools repo as that is required for building PHP from source
Yes, I view this, but all my searches indicate that, the Repo powetools is enabled when add epel repo, and in this case, not add this repo.
Continue searching for add this repo...

Regards.

Edit: Adding info:

I view the problem, in the last version of Centos 8, this repo is called with other name, I made a fresh install of CWP and in the installation appears a error that indicate, not view or recognice PowerTools repo.

The name now for this repo is:
CentOS-Linux-PowerTools.repo

I don't know how solved this...
« Last Edit: December 09, 2020, 08:55:11 AM by Wonder »

Offline
*
Re: PHP Selector not work
« Reply #4 on: December 09, 2020, 10:02:41 AM »
Solved.
After search I view the problem.
When go to enable this repo indicate not exist, for enable searh for PowerTools, if I try with powertools then work.
View this, I rename her name from powertools to PowerTools.
This change, before install cwp, then, the rest work fine.