Author Topic: Little Help with install  (Read 1997 times)

0 Members and 1 Guest are viewing this topic.

Little Help with install
« on: November 20, 2019, 08:55:07 AM »

Trying out CWP. Had a little debacle on install.

First issue is that I ran the CentOS 6 script on a CentOS 7 machine.

It seemed to figure that out and the packages it was installing all had "el7" in the names.

It crashed on the database and the install did not complete.

I was able install the database (mariadb) manually, remove the install files, and re-run the install script (proper one for CentOS 7).

That seem to work, but I get this error on all pages for various files.

Warning: mysqli_fetch_array() expects parameter 1 to be mysqli_result, boolean given in /usr/local/cwpsrv/... some.php on line 0

I suspect the tables did not get setup. The only table in root_cwp is "domains".

I really want to get this working as I can no longer stand to use CPanel!

Greetings Programs

Re: Little Help with install
« Reply #1 on: November 20, 2019, 09:51:08 AM »
Alrighty then!

Fixed it myself.

Many tables missing in root_cwp database.

I dropped it and ran the following (from the installer):

curl ''|mysql -uroot -p

-- enter your password at the prompt --

Greetings Programs