Author Topic: Main site work only with www. and don't whitout.  (Read 261 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Main site work only with www. and don't whitout.
« on: May 30, 2017, 07:54:37 AM »
Hi guys.
First of all, I have to say that all the thing I'm doing are just some test to learn something new end improve my skill.
I bought a cheap domain name (with dns management) exclusively for this test (about 2$ year)
I just setup CWP in a vps, and i create dns record A to my machine ip (and mail/webmail/ftp/ cname too)
I created a mai unser in CWP that point to the main domain www.domain.com, now typing www.domain.com i can see the right page inside home/domainname/public_html and it works great.
But if i try to reach http://domain.com i see only the blue cwp default page.
Did i wrong someting with dns setting? (i'm using dns setting of my domain provider)
Or the problem is somewhere else?

Offline
*****
Re: Main site work only with www. and don't whitout.
« Reply #1 on: May 30, 2017, 10:28:19 AM »
Hi guys.
First of all, I have to say that all the thing I'm doing are just some test to learn something new end improve my skill.
I bought a cheap domain name (with dns management) exclusively for this test (about 2$ year)
I just setup CWP in a vps, and i create dns record A to my machine ip (and mail/webmail/ftp/ cname too)
I created a mai unser in CWP that point to the main domain www.domain.com, now typing www.domain.com i can see the right page inside home/domainname/public_html and it works great.
But if i try to reach http://domain.com i see only the blue cwp default page.
Did i wrong someting with dns setting? (i'm using dns setting of my domain provider)
Or the problem is somewhere else?

How did you add the domain in CWP? With www or without (must be without)?

Offline
*
Re: Main site work only with www. and don't whitout.
« Reply #2 on: May 30, 2017, 11:40:15 AM »
How did you add the domain in CWP? With www or without (must be without)?

i didn't create a domain with "add domains" but only created the first user account (with "New Account") like this.
Username domain
Domain     domain.com
IP Adresse xx.xx.xx.xx (and non checked box)


Offline
*
Re: Main site work only with www. and don't whitout.
« Reply #3 on: May 30, 2017, 11:48:39 AM »
oh my god.. i'm very stupid person... a simply ipconfig /flushdns resolve my issue...

Offline
*
Re: Main site work only with www. and don't whitout.
« Reply #4 on: May 31, 2017, 06:03:24 AM »
You make cname record ?