Author Topic: My sites are not open  (Read 2949 times)

0 Members and 1 Guest are viewing this topic.

Offline
****
Re: My sites are not open
« Reply #15 on: September 07, 2018, 04:44:08 PM »
Do post here instead of PM.

Re setup server, install litespeed , create user account , install wordpress and paste here output of the commands below

Code: [Select]
cat /usr/local/apache/conf/sharedip.conf
Code: [Select]
cat /usr/local/apache/conf.d/vhosts.conf

Offline
**
Re: My sites are not open
« Reply #16 on: September 07, 2018, 04:46:09 PM »
Do post here instead of PM.

Re setup server, install litespeed , create user account , install wordpress and paste here output of the commands below

Code: [Select]
cat /usr/local/apache/conf/sharedip.conf
Code: [Select]
cat /usr/local/apache/conf.d/vhosts.conf
Okay thanks. Installation is about to end

Offline
**
Re: My sites are not open
« Reply #17 on: September 07, 2018, 05:33:10 PM »
Do post here instead of PM.

Re setup server, install litespeed , create user account , install wordpress and paste here output of the commands below

Code: [Select]
cat /usr/local/apache/conf/sharedip.conf
Code: [Select]
cat /usr/local/apache/conf.d/vhosts.conf

[root@server /]# cat /usr/local/apache/conf/sharedip.conf
<VirtualHost 80.240.20.xxx:80>
    ServerName 80.240.20.xxx
    DocumentRoot /usr/local/apache/htdocs
    ServerAdmin info@centos-webpanel.com
    <IfModule mod_suphp.c>
        suPHP_UserGroup nobody nobody
    </IfModule>
    <Proxy "*">
        <IfModule mod_security2.c>
            SecRuleEngine Off
        </IfModule>
    </Proxy>
    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^80.240.20.xxx$
    RewriteCond %{HTTP_HOST} ^webmail.
    RewriteRule ^/(.*) http://127.0.0.1:2095/$1 [P]
</VirtualHost>
<Directory "/">
        AllowOverride All
        Require all granted
</Directory>

AND

[root@server /]# cat /usr/local/apache/conf.d/vhosts.conf

# vhost_start mysite.com
<VirtualHost 80.240.20.xxx:8181>
        ServerName mysite.com
        ServerAlias www.mysite.com
        ServerAdmin webmaster@mysite.com
        DocumentRoot /home/mysite/public_html
        UseCanonicalName Off
        ScriptAlias /cgi-bin/ /home/mysite/public_html/cgi-bin/

        # Custom settings are loaded below this line (if any exist)
        # Include "/usr/local/apache/conf/userdata/mysite/mysite.com/*.conf"

        <IfModule mod_userdir.c>
                UserDir disabled
                UserDir enabled zortinge
        </IfModule>

        <IfModule mod_suexec.c>
                SuexecUserGroup zortinge zortinge
        </IfModule>

        <IfModule mod_suphp.c>
                suPHP_UserGroup zortinge zortinge
                suPHP_ConfigPath /home/zortinge
        </IfModule>

        <Directory "/home/mysite/public_html">
                AllowOverride All
        </Directory>

</VirtualHost>
# vhost_end mysite.com

================================

So what do I have to do now?

Offline
****
Re: My sites are not open
« Reply #18 on: September 07, 2018, 05:41:38 PM »
goto https://yourserverip:2087/admin/index.php?module=settings

Under apache port. See if there is 8181. If yes then change it to 80 and click on save changes.

got https://yourserverip:2087/admin/index.php?module=vhost_rebuild

click Rebuild All Virtual Hosts

In ssh restart litespeed

service lshttpd restart

Now see if your site is working fine.

Offline
**
Re: My sites are not open
« Reply #19 on: September 07, 2018, 05:54:16 PM »
goto https://yourserverip:2087/admin/index.php?module=settings

Under apache port. See if there is 8181. If yes then change it to 80 and click on save changes.

got https://yourserverip:2087/admin/index.php?module=vhost_rebuild

click Rebuild All Virtual Hosts

In ssh restart litespeed

service lshttpd restart

Now see if your site is working fine.

Thanks WordPress turned on.
Do you have to do something on myip: 7080?
For example, if I need to edit php.ini, which section do I need to adjust?

Offline
****
Re: My sites are not open
« Reply #20 on: September 07, 2018, 05:59:23 PM »
Its same as how previously you used to edit php.ini file.

using 7080 port you can manage litespeed. Navigate to each setting and play with it if you want to learn. :)

I think you are done with litespeed.


Offline
**
Re: My sites are not open
« Reply #21 on: September 07, 2018, 06:37:19 PM »
Its same as how previously you used to edit php.ini file.

using 7080 port you can manage litespeed. Navigate to each setting and play with it if you want to learn. :)

I think you are done with litespeed.
Thank you so much..

Cyberpanel myip:7080 >>> http://prntscr.com/krtq7l

But litespeed : http://prntscr.com/krtqvw
This is empty. Do not I have to do Cache settings from here?

Offline
****
Re: My sites are not open
« Reply #22 on: September 07, 2018, 06:44:22 PM »
litespeed automatically counts vhost created for Apache. Goto https://yourserverip:7080/service/serviceMgr.php . Scroll down and you will see your vhost files used by litespeed for CWP.


Offline
**
Re: My sites are not open
« Reply #23 on: September 07, 2018, 06:52:03 PM »
litespeed automatically counts vhost created for Apache. Goto https://yourserverip:7080/service/serviceMgr.php . Scroll down and you will see your vhost files used by litespeed for CWP.
I understand thank you
I get a new server. What do you recommend Centos 6 or CentOS 7?

Offline
****
Re: My sites are not open
« Reply #24 on: September 07, 2018, 07:01:59 PM »

Offline
**
Re: My sites are not open
« Reply #25 on: September 07, 2018, 07:03:54 PM »
Obviously Centos 7

https://wiki.centos.org/About/Product

Okay, thank you again for helping me. Good evening.