Author Topic: Wordpress - Error: 403 Forbidden. Check console output for debugging information  (Read 6552 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
I'm having Mod Security issues when trying to save a wordpress translation with the Loco Translate plugin, the following message appears:

- Error: 403 Forbidden. Check console output for debugging information.


I did a test and deactivated Mod Security for the domain the problem was solved, but I want to leave a rule to release the plugin work.
 
Can someone help me.

Thank you

Offline
*
Have you check error logs? That should give you the rule id.

Offline
*
I have the same issue.
Loco Translate is blocked my Mod Security.
Anyone know how to fix this?

Thank you.

Offline
*
How to check which rule is on this case?

Have you check error logs? That should give you the rule id.

Offline
*****
Hi, you can use CWPadmin => Security => Mod Security, and then you can check the log for the rule ID
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Hello,

Thanks for reply.

I can not see the rule, which rule is corresponding to the Loco Translate's Error.
I have tried to seek date and time, there is no clue.


Hi, you can use CWPadmin => Security => Mod Security, and then you can check the log for the rule ID

Offline
*
it looks there is no associated error on Mod security.
But I found this on Log Viewer

2020/01/10 12:36:23 [crit] 1223#0: *12033 open() "/var/lib/nginx/tmp/client_body/0000000003" failed (13: Permission denied), client: xxx.xxx.xxx.xxx, server: domain.tld, request: "POST /wp-admin/admin-ajax.php HTTP/1.1", host: "domain.tld", referrer: "https://domain.tld/wp-admin/admin.php?path=plugins%2Fwoocommerce%2Fi18n%2Flanguages%2Fwoocommerce-id_ID.po&bundle=woocommerce%2Fwoocommerce.php&domain=woocommerce&page=loco-plugin&action=file-edit"

Anyone know with this message?

Hi, you can use CWPadmin => Security => Mod Security, and then you can check the log for the rule ID

Offline
*****
Check the owner and permissions for /var/lib/nginx/ and /var/lib/nginx/tmp and change them. Or update the system software (this bug with nginx cache was long time ago)
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Hello Igor,

Thank you very much for continued reply. You help us much.
  • Changing file permission on that is the solution, thank you, now is fixed. But could you give us best file permission? The default is 770, I changed to 775, is that true? or you have the better one?
  • Updating system software not fix this case, I have tried this.

Thank you vey much Igor, I was very helped. Best luck for you.

Check the owner and permissions for /var/lib/nginx/ and /var/lib/nginx/tmp and change them. Or update the system software (this bug with nginx cache was long time ago)