Author Topic: [module] Simple SpeedTest - using speedtest-cli and SpeedTest.net  (Read 1966 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
[module] Simple SpeedTest - using speedtest-cli and SpeedTest.net
« on: September 27, 2017, 03:50:58 PM »
Simple Speedtest-cli Module for Centos-WebPanel (CWP)

This module uses speedtest-cli python app to speedtest your servers network connection.

Features:
  • Text Only Speedtest
  • Image Only, SpeedTest.net Image for sharing (url/link)
  • SpeedTest.net Server selector

More info and Installation/Download:
https://github.com/gogo1207/cwp-speedtestcli-bridge-module

*Note this module is created primary for my personal usage so there can be errors on different servers!

! Please don't send me PM's. If there is any problem or you have suggestion or request please reply here on the forum.
! Any code modifications, improvements, fixes, etc. can be done via Github.

Offline
*
Re: [module] Simple SpeedTest - using speedtest-cli and SpeedTest.net
« Reply #1 on: September 12, 2018, 02:40:19 AM »
Works great, thanks for sharing!

https://www.speedtest.net/result/7628062076.png

Offline
*
Re: [module] Simple SpeedTest - using speedtest-cli and SpeedTest.net
« Reply #2 on: December 22, 2018, 12:19:25 PM »
Broken after latest cwp updates

Edit actualy module work manualy. but from cwp sidebar not beacuse cwp added some lines in weblink when u login so when u click on it he logout you

Before:

https://host.domain.com:2031/admin/index.php

Now:

https://host.domain.com:2031/cwp_randomnumber/admin/index.php
« Last Edit: December 22, 2018, 12:29:15 PM by MAMAC »

Offline
***
Re: [module] Simple SpeedTest - using speedtest-cli and SpeedTest.net
« Reply #3 on: December 22, 2018, 03:43:26 PM »
It should work now. CWP got some uri changes so old module links were broken.
Thanks for reporting.

Offline
*
Re: [module] Simple SpeedTest - using speedtest-cli and SpeedTest.net
« Reply #4 on: December 24, 2018, 11:32:38 AM »
He still log me out when i go to developer menu than click speedtest

*You have logged out.*

Offline
***
Re: [module] Simple SpeedTest - using speedtest-cli and SpeedTest.net
« Reply #5 on: December 24, 2018, 10:52:22 PM »
You have to replace old file with new one.

Oh, sorry I didn't understand you completely.
Please find file
Code: [Select]
/usr/local/cwpsrv/htdocs/resources/admin/include/3rdparty.phpAnd find button for Speedtest module.
You'll see something like: 
Code: [Select]
href="./admin......."Remove that dot (.) in front of /admin, like this:
Code: [Select]
href="/admin......."That should fix your menu button.
« Last Edit: December 24, 2018, 11:10:59 PM by Gogo »

Offline
*
Re: [module] Simple SpeedTest - using speedtest-cli and SpeedTest.net
« Reply #6 on: December 25, 2018, 12:12:52 PM »
I already did that but same he log me out every time when i click on link.

http://prntscr.com/lzblta

problem is random login numbers in cwp link

Offline
*
Re: [module] Simple SpeedTest - using speedtest-cli and SpeedTest.net
« Reply #7 on: December 25, 2018, 12:13:57 PM »
I did solve putting like this 
<li><a href="./index.php?module=speedtest"><span class="icon16 icomoon-icon-arrow-right-3"></span>Speedtest</a></li>

Offline
***
Re: [module] Simple SpeedTest - using speedtest-cli and SpeedTest.net
« Reply #8 on: December 25, 2018, 01:08:25 PM »
Yeah that should work to as you did, removing /admin completely and leaving index.php?module=speedtest only.

That random string is some kind of session verification as it looks like.