Author Topic: NGINX Proxy + Apache not allowing POST requests  (Read 1195 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
NGINX Proxy + Apache not allowing POST requests
« on: September 21, 2017, 05:57:30 PM »
Not sure if this is a Nginx issue, an Apache issue or a Php conf problem.

I migrated a few website installs from my old Gentoo VM and mostly everything works great. Only problem is POST requests are showing as 404. The same request as a GET request works fine. These sites use Apache and PHP.

I haven't changed anything in the confs. I'm using the default Nginx + Apache generated setup installed via the panel and re-created them a few times.

The Nginx access logs are showing only POST requests 404s but not any GET requests from just visiting the websites. No errors being showen in the error logs.

Offline
*
Re: NGINX Proxy + Apache not allowing POST requests
« Reply #1 on: September 22, 2017, 11:54:45 AM »
try switching your cwp under WebServers in the left menu to apache only mode and then test again if that works then switch to nginx and test again.

I would also recommend checking the logs of apache as it can be mod_security in some cases showing 404
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
***
Re: NGINX Proxy + Apache not allowing POST requests
« Reply #2 on: January 15, 2018, 09:02:40 AM »
I have no problem with  nginx POST/GET requests
mod_security  just gives you more headache! maybe try to disable it.
suggestion: You can do a simple test on 'contact form' for POST and GET request.