Author Topic: CWP PHP Selector [CWPpro required]  (Read 4055 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
CWP PHP Selector [CWPpro required]
« on: June 09, 2018, 01:20:36 PM »
I am a little confused by this as on the home page of centos-webpanel.com there's this "CWP PHP Selector (FREE)". But inside CWP admin area "CWP PHP Selector [CWPpro required]".

Can someone clear this out for me? I am pretty confused.

Offline
***
Re: CWP PHP Selector [CWPpro required]
« Reply #1 on: June 09, 2018, 05:08:19 PM »
It was free for few years ago, starting this year it is commercialized

Offline
***
Re: CWP PHP Selector [CWPpro required]
« Reply #2 on: June 10, 2018, 01:45:58 AM »
Thank you for clearing that out.

How do we know if it's not working? I seem to be able to installed all the PHP versions inside CWP PHP Selector without CWPpro. I tested it with
Code: [Select]
AddHandler application/x-httpd-php70 .php and it does work. What does that mean? Is there something wrong?

Offline
*
Re: CWP PHP Selector [CWPpro required]
« Reply #3 on: October 06, 2019, 12:47:57 PM »
its not working anymore in free version :(
All my web sites giving this error "internal server error 500" which i used .htaccess AddHandler application/x-httpd-php72 .php

Offline
**
Re: CWP PHP Selector [CWPpro required]
« Reply #4 on: October 07, 2019, 04:18:44 AM »
I am a little confused by this as on the home page of centos-webpanel.com there's this "CWP PHP Selector (FREE)". But inside CWP admin area "CWP PHP Selector [CWPpro required]".

Can someone clear this out for me? I am pretty confused.

From Now , you must purchase license to use ""pro option "" which is "Module Disabled [CWPpro required]"

Offline
*
Re: CWP PHP Selector [CWPpro required]
« Reply #5 on: October 08, 2019, 06:28:22 AM »
I don't have a problem with CWP Premium, it's cheap, no problem about it. But i was testing the free version.

Yesterday, the website stop working, "503 down for maintenance", after a time rebuilding apache, checking apache, nginx, etc, i discovered that PHP-FPM was unable to start, because " /opt/alt/php-fpm72/usr/sbin/php-fpm" and the others versions executables, had a wrong chmod, unable to start. I fixed it and the website return to working. Today, same issue, strange. So i checked this forum.

Apparently, now the PHP-FPM selector it's only for paid versions (in the website still says PHP-FPM free), but they did the change without warning anyone, they simply update the panel and broke thousands of websites.

The problem for me it's not to pay 1.5$/month, it's that they do the change without warning anyone, with a dirty method, and breaking thousand of servers around the world. For me, there are not trustworthy anymore.

I have been using other free panels for many years, like ISPConfig, and never have a issue like this. It's a pity, because i think CWP have a great potential, but this movement it's a shame. No warning, the push the button without thinking.

Offline
*
Re: CWP PHP Selector [CWPpro required]
« Reply #6 on: October 08, 2019, 08:40:15 AM »
 >:( This type of behavior is really unsustainable.
Even if i use a free service you can't directly cause a down state on servers which offers services to customers or public services.
This may be counterproductive bringing many agencies to ask for damages especially when talking about crucial services.
You can limit the configuration capabilities but you can't cause someone else's server to stop.

Offline
*
Re: CWP PHP Selector [CWPpro required]
« Reply #7 on: October 08, 2019, 02:50:30 PM »
it's very simple, if you want to use a php-selector then you need to use cwppro version.
You still can use php switcher to change php version.
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
**
Re: CWP PHP Selector [CWPpro required]
« Reply #8 on: October 14, 2019, 10:19:48 AM »
If you take a look at /var/log/cwp/webservers.log you will see a lot of entries trying to stop the service, like these:
2019-10-13 11:10:24 PHP-FPM php-fpm72: stop
2019-10-14 02:10:13 PHP-FPM php-fpm72: stop
2019-10-14 03:10:01 PHP-FPM php-fpm72: stop
2019-10-14 07:10:02 PHP-FPM php-fpm72: stop

Something is forcing this service to stop and to change "/opt/alt/php-fpm72/usr/sbin/php-fpm" file permissions as well.

How can i disable "PHP-FPM Selector" to get back to apache only? Is there a way from the panel?
« Last Edit: October 14, 2019, 10:21:45 AM by pedromidiasf »

Offline
**
Re: CWP PHP Selector [CWPpro required]
« Reply #9 on: October 14, 2019, 11:46:51 AM »