Author Topic: error: PDO_MYSQL configure failed, MySQL 4.1 needed  (Read 2731 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
error: PDO_MYSQL configure failed, MySQL 4.1 needed
« on: June 15, 2017, 04:46:14 PM »
checking for sigprocmask... yes
checking for sigwaitinfo... yes
checking for sigtimedwait... yes
checking for siginfo_t... yes
checking whether to enable PDO support... yes
checking for PDO_DBLIB support via FreeTDS... no
checking for Firebird support for PDO... no
checking for MySQL support for PDO... yes
checking for MySQL UNIX socket location... /var/lib/mysql/mysql.sock
checking for mysql_config... /usr/bin/mysql_config
checking for mysql_commit in -lmysqlclient... no
checking for mysql_commit in -lmysqlclient... (cached) no
configure: error: PDO_MYSQL configure failed, MySQL 4.1 needed. Please check config.log for more information.
Configure DONE!
####################
make: *** No targets specified and no makefile found.  Stop.
Make DONE!
####################
make: *** No rule to make target `install'.  Stop.
Make Install DONE!
####################
PHP Rebuild Completed
#########################

i get this error when changing the php version to 7+ and enabling PDO. How can i fix?

Offline
*
Re: error: PDO_MYSQL configure failed, MySQL 4.1 needed
« Reply #1 on: July 18, 2017, 05:14:51 PM »
Simply replace flag --with-pdo-mysql=/usr with --with-pdo-mysql=mysqlnd  ;)

Offline
*
Re: error: PDO_MYSQL configure failed, MySQL 4.1 needed
« Reply #2 on: March 20, 2018, 05:53:36 PM »
where i can change that in PHP Version Switcher v2?

Offline
*
Re: error: PDO_MYSQL configure failed, MySQL 4.1 needed
« Reply #3 on: April 28, 2018, 10:36:09 AM »
Any ideas?

Having the same issue.

Offline
*
Re: error: PDO_MYSQL configure failed, MySQL 4.1 needed
« Reply #4 on: July 20, 2018, 02:35:29 PM »
If you have this problem, for example, using the switcher to have php 7.2. just go to this directory:

/usr/local/cwpsrv/htdocs/resources/conf/php_switcher

and find the .ini file that correspond with the php version you want to install, in this example will be 7.2.ini

find the line --with-pdo-mysql=/usr and replace /usr with mysqlnd
result: --with-pdo-mysql=mysqlnd

save changes and try again