Author Topic: Install ImageMagick or GD ?  (Read 12025 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Re: Install ImageMagick or GD ?
« Reply #15 on: August 10, 2016, 09:11:40 AM »
i have installed imagmagic success. with basic CWP php 5.4
i can see module loaded success.

but at subdomain, i run php7
i look at
Code: [Select]
<?php phpinfo();?> on php7, there is no imagmagic extension loaded.
i have try add
Code: [Select]
extension=imagick.so at php.ini and restart apache, still can't get it work with php7.
is there anyone can give me solution?

Thank You

Offline
*****
Re: Install ImageMagick or GD ?
« Reply #16 on: August 10, 2016, 10:53:47 AM »
Hi, try to use oldest version.

Offline
*
Re: Install ImageMagick or GD ?
« Reply #17 on: August 10, 2016, 02:42:17 PM »
Hi, try to use oldest version.

yes, i know about that. but i want to use php7
seems the script only install for base php that use by cwp

Offline
*
Re: Install ImageMagick or GD ?
« Reply #18 on: August 10, 2016, 03:55:29 PM »
with php selector php7 i got this error:
Code: [Select]
PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/alt/php7/usr/lib/php/extensions/no-debug-non-zts-20160303/imagick.so' - /opt/alt/php7/usr/lib/php/extensions/no-debug-non-zts-20160303/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0if i change to default php, it has no problem

Offline
*
Re: Install ImageMagick or GD ?
« Reply #19 on: May 01, 2017, 03:26:37 AM »
i am copy the imagemagik.so from -> /usr/local/lib/php/extensions/no-debug-non-zts-20131226
to -> /usr/lib64/extensions/no-debug-non-zts-20100525

and re install imagemagik : sh /scripts/install_imagick
problem solved!!

if same error for ffmpeg copy ffmpeg.so from ...........