Author Topic: Problem switching to PHP 5.4.45  (Read 9703 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Re: Problem switching to PHP 5.4.45
« Reply #15 on: November 22, 2015, 07:29:36 AM »
Sounds good... So I have to recompile the php with "PHP Version Switcher" and will be show the right php version everywhere? I already recompile the php and still shown different php versions...

Dashboard/Application Version/PHP version: 5.4.45
PHP Settings/PHP Info/You are running PHP version: 5.4.45
PHP Settings/PHP Info/PHP Version 5.6.14
PHP Settings/PHP Info/phpinfo() PHP Version => 5.4.27
PHP Settings/PHP Selector/PHP 5.4 Installed/[list Modules]/PHP 5.4.35
PHP Settings/PHP Selector/PHP 5.6 Installed/[list Modules]/PHP 5.6.3
...[/list][/list]
« Last Edit: November 22, 2015, 08:04:08 AM by erntesky »

Offline
*
Re: Problem switching to PHP 5.4.45
« Reply #16 on: November 22, 2015, 09:28:01 AM »
Itīs working for me,

Thanks :)

Offline
*
Re: Problem switching to PHP 5.4.45
« Reply #17 on: November 22, 2015, 09:24:19 PM »
Sounds good... So I have to recompile the php with "PHP Version Switcher" and will be show the right php version everywhere? I already recompile the php and still shown different php versions...


You need to recompile all versions you have
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Problem switching to PHP 5.4.45
« Reply #18 on: November 23, 2015, 07:32:31 AM »
How to recompile all versions, what is the best way?

Offline
*
Re: Problem switching to PHP 5.4.45
« Reply #19 on: January 01, 2016, 11:31:21 PM »
Anybody know how to recompile / reinstall all php versions in "PHP Selector" ? ???

Offline
**
Re: Problem switching to PHP 5.4.45
« Reply #20 on: January 02, 2016, 12:17:09 PM »
hi,
this should work:

1. Install Dependencies
2. check php version which you need to compile / recompile or install
3. click start compiler at the bottom list

regards

Offline
*
Re: Problem switching to PHP 5.4.45
« Reply #21 on: January 02, 2016, 03:07:06 PM »
I already tried, but is not working for me... The log in the console "tail -f /var/log/php-selector-rebuild.log" show me the installation is done, but that is not the fresh installation. The log show me the first installation, so reinstall / recompile is not start! How can I fix it, or recompile all my php versions in "php selector"?

Offline
**
Re: Problem switching to PHP 5.4.45
« Reply #22 on: January 02, 2016, 04:28:04 PM »
did you read this post and try to find scripts like me...
I had same issue without any logs or like that...

this is post

http://forum.centos-webpanel.com/php/problem-switching-to-php-5-4-45/msg4767/#msg4767

there is path where scripts are downloaded I executed them manually seems it works...

try and let us know...

Offline
*
Re: Problem switching to PHP 5.4.45
« Reply #23 on: January 02, 2016, 05:19:43 PM »
I tried before but not seen any "updated" scripts... The scripts included with the older php versions... I don't know why, or whats happened but I checked again the "/usr/local/src" location and find the updated scripts. I started the scripts and its works! Thanks for your help!!! :)

From the "PHP Selector", PHP5.4 - PHP5.5 - PHP5.6 are missing the following:

[Zend Modules]
the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured)

How can I add to .configure?

Offline
**
Re: Problem switching to PHP 5.4.45
« Reply #24 on: January 02, 2016, 05:36:06 PM »
well didnt check where are php.ini files of this additional versions have to check and let you know but you can configure / edit flags before executing scripts in php selector and see does it works..

glad it works I spent whole day figuring out whats the problem but not to broke server...

let us know does edit flags works :)

Offline
*
Re: Problem switching to PHP 5.4.45
« Reply #25 on: January 02, 2016, 05:51:27 PM »
Yeah, its working and I so happy... Thank you again!!! :)

I already configured few flags, but I really don't know how to add fow show the following:

[PHP Modules]
geoip (I figured out with secondary php.ini but I want add automatic...)
iconv (That is shown and added by "--with-iconv")
ionCube Loader (What is the config for that?)

[Zend Modules]
the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured)

That things is already shown by the main php, but I really don't know how to add to "php selector" all php versions?

Offline
**
Re: Problem switching to PHP 5.4.45
« Reply #26 on: February 17, 2017, 04:54:47 PM »
@ erntesky,
Hiya, did you find out how to add the IonCube Loader in any of the php versions with php selector, when adding it manual in the php ini file I get an 500 error...

Without adding in the 5.6 php.ini file I get this:
ionCube Loader
Status: Run-time loading should be possible on your system but no suitable Loader was found.
Instructions: The Loader for Linux (PHP 5.6) is required.

After compiling add:
echo "zend_extension = /usr/local/sourceguardian/ixed.5.6.lin" >> /opt/alt/php56/usr/php/php.ini
echo "zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.6.so" >> /opt/alt/php56/usr/php/php.ini

500