Author Topic: Problems with switching from PHP 5.4.45 to PHP 7.0.12  (Read 1476 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Problems with switching from PHP 5.4.45 to PHP 7.0.12
« on: November 08, 2016, 08:55:13 PM »
Hi, I have problems with switching to PHP 7.0.12.
I've searched the forums and didn't finy answers to the problems I'm having.

What I did:

Run Install Dependencies on PHP Selector
- Wait for it to finish

Start Compiler for PHP 7.X
- Wait for it to finish

Selected new PHP version with IMAP enabled, waited for it to finish, used PHP -v and the result was still 5.4.45

I've been trying to do this for quite some time and help would be appreciated.

Offline
*
Re: Problems with switching from PHP 5.4.45 to PHP 7.0.12
« Reply #1 on: November 08, 2016, 09:10:23 PM »
I had problems with this on a newly installed server too just this week. It couldn't find recode.h and some other files that were required.
I'd suggest you try installing the PHP version again, but go to your SSH terminal and do the Tail command that php selector gives you on the last step. Paste it and watch the log to see when the error happens.

Offline
*
Re: Problems with switching from PHP 5.4.45 to PHP 7.0.12
« Reply #2 on: November 08, 2016, 09:20:43 PM »
I've been watching the logs, they're still open on my console rn.

On the end it only gives a "make install" error, saying install is not defined.

I'm trying a custom .sh for installing PHP 7, wish me luck :P

Offline
*****
Re: Problems with switching from PHP 5.4.45 to PHP 7.0.12
« Reply #3 on: November 09, 2016, 05:07:46 AM »
Pm me the server details we need to check it and install for you.
« Last Edit: November 09, 2016, 05:09:22 AM by Sandeep »