Author Topic: Update your PHP ASAP 🚨  (Read 3953 times)

anandmys and 10 Guests are viewing this topic.

Offline
*
Re: Update your PHP ASAP 🚨
« Reply #75 on: October 25, 2026, 03:20:32 AM »
yes 1.24, i got a bug, i needed to install libC, and relaunch cwp8.3update script, now 1.24 full with php8.3.36

Offline
*
Re: Update your PHP ASAP 🚨
« Reply #76 on: October 25, 2026, 06:51:49 AM »
After the latest cron run the cwp version is now 1.24 and the internal php version has been updated to 8.3.36 - you are correct emerysteele

Offline
*
Re: Update your PHP ASAP 🚨
« Reply #77 on: October 25, 2026, 07:44:20 AM »
@emerysteele

Code: [Select]
[root@server /]# /usr/local/cwp/php71/bin/php -v
PHP Warning:  PHP Startup: Unable to load dynamic library 'intl' (tried: /usr/local/cwp/php71/lib/php/extensions/no-debug-non-zts-20230831/intl (/usr/local/cwp/php71/lib/php/extensions/no-debug-non-zts-20230831/intl: cannot open shared object file: No such file or directory), /usr/local/cwp/php71/lib/php/extensions/no-debug-non-zts-20230831/intl.so (/usr/local/cwp/php71/lib/php/extensions/no-debug-non-zts-20230831/intl.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP 8.3.36 (cli) (built: Oct 22 2026 14:30:10) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.3.36, Copyright (c) Zend Technologies
    with the ionCube PHP Loader v15.5.1, Copyright (c) 2002-2026, by ionCube Ltd.
[root@nimbus /]#

I note you are seeing that "Unable to load dynamic library 'intl'" error.  I also had that and ended up just quoting out:
;extension=intl
(yes with semi-colon) in /usr/local/cwp/php71/php.d/intl.ini

Not sure if that is the right solution but was the best one for me.
« Last Edit: October 25, 2026, 07:46:24 AM by kadybee »

Offline
*
Re: Update your PHP ASAP 🚨
« Reply #78 on: October 25, 2026, 09:02:07 AM »
I'm stuck at CWP 1.21 here (Almalinux 8.10, public php updated via alphagnu.com script).
When I run /scripts/update_cwp, I get the following errors:
Code: [Select]
error: Failed depencencies:
          perl(Date::Calc) is needed by postfix-2:3.4.8-2.centos.8+p18.0.24.0+t200128.1353.x86_64
Redirecting to /bin/systemctl reload httpd.service
cp: cannot stat '/root/.ssh/authorized_keys': No such file or directory

I tried installing the missing Date::Calc module via
perl -MCPAN -e 'install Date::Calc'
This worked but I'm still getting the same errors from update_cwp. perl now reports that Date::Calc is up to date (6.4).

Edit: I had to install Date::Calc via
dnf install perl-Date-Calc -y
and create an empty authorized_keys file to make the update proceed. Maybe this helps others with the same problem.
« Last Edit: October 25, 2026, 09:22:53 AM by chrisg »

Offline
*
Re: Update your PHP ASAP 🚨
« Reply #79 on: October 25, 2026, 11:16:33 AM »
As others who run cwppro 1.24 and thereby also the 8.3.36 for the cwp internal php, I see that the error reported by others with not showing emailaccounts is present - the following error is reported by the panel:

DataTables warning: table id=m_table_1 - Ajax error. For more
information about this error, please see http://datatables.net/tn/7

Offline
**
Re: Update your PHP ASAP 🚨
« Reply #80 on: October 25, 2026, 11:21:46 AM »
As others who run cwppro 1.24 and thereby also the 8.3.36 for the cwp internal php, I see that the error reported by others with not showing emailaccounts is present - the following error is reported by the panel:

DataTables warning: table id=m_table_1 - Ajax error. For more
information about this error, please see http://datatables.net/tn/7

 1.23 is the latest version according to the change log page.

Offline
*
Re: Update your PHP ASAP 🚨
« Reply #81 on: October 25, 2026, 01:48:20 PM »
As others who run cwppro 1.24 and thereby also the 8.3.36 for the cwp internal php, I see that the error reported by others with not showing emailaccounts is present - the following error is reported by the panel:

DataTables warning: table id=m_table_1 - Ajax error. For more
information about this error, please see http://datatables.net/tn/7


Appears to be a bug in the latest versions 1.23 and above.
Still no one knows when will be fixed.

Offline
*****
Re: Update your PHP ASAP 🚨
« Reply #82 on: October 25, 2026, 03:23:11 PM »
In my case most servers updated properly, but one server was very problematic. Maybe it was my provider doing scheduled network maintenance Thursday night, or there may have been a conflict with Sandeep's php-manager. Somehow the upgrade to PHP 8.3 on the backend failed. There was a mismatch of Ioncube loader versions and bad PHP syntax keeping CWP from loading. Admin panel just read:
Quote
No Loader is installed, please try to run this command or contact support: sh /scripts/update_ioncube
I tried emerysteele's PCRE workaround, but that just resulted in a 500 error due to PHP syntax version differences between the old CWP 7.2 backend and the new 8.3.36. So I had to revert back to the previous ldconfig:
Code: [Select]
mv /root/pcre2_local_backup/* /usr/local/lib/ && ldconfigMy self-help fix was to remove the MARK file from the filesystem and edit.the PHP 8.3 upgrade script:
Code: [Select]
/scripts/update_cwpphp83I just commented out the MARK logic to get the script to re-run manually. After a while running, it worked to reinstall the admin panel! This is probably an edge case, but maybe it will help someone else.

Offline
*****
Re: Update your PHP ASAP 🚨
« Reply #83 on: October 25, 2026, 08:44:02 PM »
CWP did have a bug where it configured the wrong ionCube loader for the PHP version.

It was a simple fix, you just had to correct:

Code: [Select]
nano /usr/local/php/php.d/ioncube.ini
And enter the correct loader, e.g. 8.3, etc.

Offline
*****
Re: Update your PHP ASAP 🚨
« Reply #84 on: Today at 02:26:36 AM »
That Ioncube .ini file had 8.2 referenced in it -- so incorrect, but not the root cause of my issue (probably an edge case).

Offline
*
Re: Update your PHP ASAP 🚨
« Reply #85 on: Today at 08:32:39 AM »
How can you tell if latest upgrade has been applied?

Online
**
Re: Update your PHP ASAP 🚨
« Reply #86 on: Today at 10:22:14 AM »
Hi mate, run the below command in terminal. If if says PHP 8.3.36 your all set.

Code: [Select]
/usr/local/cwp/php71/bin/php -v
6Sense - Web Design, Development & Web Hosting