Author Topic: Emails are staying in postfix queue  (Read 1798 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Emails are staying in postfix queue
« on: May 13, 2016, 10:08:06 PM »
Hi, my php script is using php mail () function to send notifications, verifications, newsletters and more...
I have a php script which is run in a special time and it is sending the newsletter to around 400 addresses every day. once a week it is sending a newsletter to 8000 addresses.
problem is appearing after this weekly newsletter, some messages around 3-4000 is staying in the postfix queue. and because of that all the other emails (notifications, verifications, password reset) are not arrive, or arrive late, which is bad for my site functionality.

Only when I delete the queue, everything continues to function normally , until the next weekly newsletter.

Do you have any ideas what can be the cause of this problem?

Offline
***
Re: Emails are staying in postfix queue
« Reply #1 on: May 13, 2016, 11:04:21 PM »
from queue manager, you can find reason for every sinngle mail being deffered...  post it here

Offline
*****
Re: Emails are staying in postfix queue
« Reply #2 on: May 14, 2016, 04:39:34 AM »
jae was right without log how the members will help you.

Offline
*
Re: Emails are staying in postfix queue
« Reply #3 on: May 16, 2016, 10:27:38 PM »
These errors occur:





Support told me to add relayhost= 109.201... to main.cf.

Offline
***
Re: Emails are staying in postfix queue
« Reply #4 on: May 17, 2016, 03:35:09 AM »
Follow this link http://steam.io/2013/04/01/postfix-rate-limiting/

you must limit sending email to yahoo, hotmail and google groups, including any domain hosted to them...
« Last Edit: May 17, 2016, 03:44:30 AM by Jae »

Offline
*
Re: Emails are staying in postfix queue
« Reply #5 on: May 18, 2016, 02:10:51 PM »
I added these lines to main.cf

Code: [Select]
smtp_destination_concurrency_limit = 2
smtp_destination_rate_delay = 1s
smtp_extra_recipient_limit = 10

Is this ok?
Now i have errors:

and


when i restart postfix it send 20-30 mails and then stops and shows these errors.
Sorry for bad english.
« Last Edit: May 18, 2016, 03:30:54 PM by danilo »