Author Topic: I can send emails. But I do not get. I can pay for fixing issue  (Read 814 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
I can send emails. But I do not get. I can pay for fixing issue
« on: October 28, 2017, 10:38:10 PM »
I have problem with email serwer.
I can send email without any problems.
Problem is that when I send email from outside server I do not get it.
Can someone help me ?
I can pay for fix this problem.

Offline
***
Re: I can send emails. But I do not get. FIXED
« Reply #1 on: October 29, 2017, 12:02:45 PM »
I found solution.
There is problem with Centos 7

When rebuild mail server i so that yum updating and installing this:

Updating:
 pypolicyd-spf   noarch   1.3.2-2.el7   epel   44 k
Installing for dependencies:
 python-ipaddress   noarch   1.0.16-2.el7   base   34 k

There is issue with python-ipaddress liblary on Centos 7

Read more:
https://bugs.centos.org/view.php?id=12393

Offline
*
Re: I can send emails. But I do not get. I can pay for fixing issue
« Reply #2 on: October 30, 2017, 11:42:08 AM »
Any update on this problem I have to disable dkim and spf on rebuild to get mail working Tried other solutions but unable to work.

Offline
***
Re: I can send emails. But I do not get. I can pay for fixing issue
« Reply #3 on: October 30, 2017, 11:49:48 AM »
there is fix on centos forum

my fix:
use python3

yum install python34
yum install python34-setuptools
easy_install-3.4 pip
pip3 install pyspf
pip3 install py3dns
pip3 install pypolicyd-spf

change python3 path in /etc/postfix/master.cf
e.g.
policyd-spf unix - n n - 0 spawn user=nobody argv=/usr/bin/python3 /usr/libexec/postfix/policyd-spf

I hope this will help someone out there.

---------------------------------------
I didn't do this becouse I want to have my cwp compatible with master

Offline
*
Re: I can send emails. But I do not get. I can pay for fixing issue
« Reply #4 on: October 30, 2017, 12:25:07 PM »
there is fix on centos forum

my fix:
use python3

yum install python34
yum install python34-setuptools
easy_install-3.4 pip
pip3 install pyspf
pip3 install py3dns
pip3 install pypolicyd-spf

change python3 path in /etc/postfix/master.cf
e.g.
policyd-spf unix - n n - 0 spawn user=nobody argv=/usr/bin/python3 /usr/libexec/postfix/policyd-spf

I hope this will help someone out there.

---------------------------------------
I didn't do this becouse I want to have my cwp compatible with master

No package python34 available.

I installed and complied 3.4.4 but keep getting permission issued in the maillog
« Last Edit: October 30, 2017, 12:30:41 PM by ARF »

Offline
*
Re: I can send emails. But I do not get. I can pay for fixing issue
« Reply #5 on: October 30, 2017, 04:33:24 PM »
there is fix on centos forum

my fix:
use python3

yum install python34
yum install python34-setuptools
easy_install-3.4 pip
pip3 install pyspf
pip3 install py3dns
pip3 install pypolicyd-spf

change python3 path in /etc/postfix/master.cf
e.g.
policyd-spf unix - n n - 0 spawn user=nobody argv=/usr/bin/python3 /usr/libexec/postfix/policyd-spf

I hope this will help someone out there.

---------------------------------------
I didn't do this becouse I want to have my cwp compatible with master

No package python34 available.

I installed and complied 3.4.4 but keep getting permission issued in the maillog

post maillog error...

Offline
*
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: I can send emails. But I do not get. I can pay for fixing issue
« Reply #7 on: December 30, 2017, 09:11:41 AM »
- or read this http://forum.centos-webpanel.com/spf/policyd-spf-skip_addresses-not-ip-network/msg14109/?topicseen#msg14109


Anyhow - the issue persists after 3 months and was introduced after an update by CWP - so why they still havenīt fixed it after 3 months is hard to say.....

Offline
***
Re: I can send emails. But I do not get. I can pay for fixing issue
« Reply #8 on: December 30, 2017, 09:39:55 AM »
There is no this issue anymore.