Author Topic: postfix [127.0.0.1]:10024: Connection refused  (Read 6076 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
postfix [127.0.0.1]:10024: Connection refused
« on: April 07, 2015, 06:32:23 AM »
my postfix with rDNS is working fine, but if I rebuild it with AntiSpam/AntiVirus the mails I send are kept in queue with this error:

connect to 127.0.0.1[127.0.0.1]:10024: Connection refused

I guess there's a line missing in /etc/postfix/main.cf:

smtp-content_filter = amavis:[127.0.0.1]:10024

Anyway I always get the root's emails from lfd and others

« Last Edit: April 07, 2015, 07:01:26 AM by banane »


Offline
*
Re: postfix [127.0.0.1]:10024: Connection refused
« Reply #2 on: April 07, 2015, 03:51:19 PM »

Offline
*
Re: postfix [127.0.0.1]:10024: Connection refused
« Reply #3 on: April 10, 2015, 10:11:49 AM »
Fix:
Code: [Select]
nano /etc/yum.repos.d/epel.repo
Make it enabled, like this:
Code: [Select]
[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6

Manual install:
Code: [Select]
yum install amavisd-new
Agree with:

Code: [Select]
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
Importing GPG key 0x0608B895:
 Userid : EPEL (6) <epel@fedoraproject.org>
 Package: epel-release-6-8.noarch (installed)
 From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
Is this ok [y/N]: y

Rebuild mail stack from cwp again (to install cwp configs).

Last step:
Make epel, disabled like this:
Code: [Select]
[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
failovermethod=priority
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6

Or you will face problems on yum update.
Done.
« Last Edit: April 10, 2015, 10:18:51 AM by ashpak »

Offline
*
Re: postfix [127.0.0.1]:10024: Connection refused
« Reply #4 on: April 10, 2015, 12:08:24 PM »
thanks ashpak
I did it few hours ago as posted here: http://forum.centos-webpanel.com/centos-6-problems/centos-6-6-0-9-8-3-amavisd-not-installed-lfd-mails/msg2728/?topicseen#msg2728

by the way, I had to add manually content_filter= smtp-amavis:[127.0.0.1]:10024 in /etc/postfix/main.cf and remove reject_rbl_clientzen.spamhaus.org,reject_rbl_clientbl.spamcop.net,reject_rbl_clientdnsbl.sorbs.net, from smtpd_recipient_restrictions

Offline
*
Re: postfix [127.0.0.1]:10024: Connection refused
« Reply #5 on: November 09, 2015, 02:59:45 AM »
Thank you @ashpak & @banane!  :)

Offline
*
Re: postfix [127.0.0.1]:10024: Connection refused
« Reply #6 on: July 18, 2016, 09:56:28 PM »
hello.

i got the same message i dont fix this.  how can i do that ?

thank you