Author Topic: Wordpress and Postfix Mail Server Problem  (Read 458 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Wordpress and Postfix Mail Server Problem
« on: February 06, 2019, 12:01:26 AM »
Hello everyone,

I used CWP 7.

I have a website that uses 2 wordpress woocommerce infrastructure on my server.

The e-mail addresses I created from my server are outlook etc. I can establish. But wordpress and woocommerce do not send notification mails in any way. SMTP cannot connect.

Has anybody ever encountered this problem before? And how can I solve?

Thanks.

Offline
***
Re: Wordpress and Postfix Mail Server Problem
« Reply #1 on: February 06, 2019, 03:20:26 PM »
You have to allow outgoing traffic to ports 25, 465, 587 and in the case of Mandrill 2525 as will. You should actually be fine enabling only the one you will connect to. So:
Code: [Select]
sudo vim /etc/csf/csf.confadd 25,2525,465,587 to TCP_OUT, and to TCP6_OUT if you use IPv6.
[/color]You might also need to remove that ports from SMTP_PORTS if you have SMTP_BLOCK enabled (if it is set to 1).

Offline
*
Re: Wordpress and Postfix Mail Server Problem
« Reply #2 on: February 07, 2019, 12:25:36 AM »
You have to allow outgoing traffic to ports 25, 465, 587 and in the case of Mandrill 2525 as will. You should actually be fine enabling only the one you will connect to. So:
Code: [Select]
sudo vim /etc/csf/csf.confadd 25,2525,465,587 to TCP_OUT, and to TCP6_OUT if you use IPv6.
[/color]You might also need to remove that ports from SMTP_PORTS if you have SMTP_BLOCK enabled (if it is set to 1).

I edited the file. but the same problem continues. SMTP settings; http://prntscr.com/mho46z
« Last Edit: February 07, 2019, 12:29:45 AM by gkhnpkr »

Offline
***
Re: Wordpress and Postfix Mail Server Problem
« Reply #3 on: February 07, 2019, 06:43:58 AM »
I edited the file. but the same problem continues. SMTP settings; http://prntscr.com/mho46z
This might mean the issue is not with the firewall (though I had the exact same issue not long ago).
I suggest you disable the firewall and test again. If it works - it IS the firewall and you're doing something wrong.
If it doesn't work, we'll have to continue guess.
Don't forget to enable the firewall back again.


By the way, do you have mod_sec activated? I've disabled it. Too many false positive cases.

Offline
*
Re: Wordpress and Postfix Mail Server Problem
« Reply #4 on: February 08, 2019, 07:27:07 AM »
I edited the file. but the same problem continues. SMTP settings; http://prntscr.com/mho46z
This might mean the issue is not with the firewall (though I had the exact same issue not long ago).
I suggest you disable the firewall and test again. If it works - it IS the firewall and you're doing something wrong.
If it doesn't work, we'll have to continue guess.
Don't forget to enable the firewall back again.

The firewall is offline when applying your suggestions. I did what you said and activated the wall of trust. Still not working.

By the way, do you have mod_sec activated? I've disabled it. Too many false positive cases.

Offline
*
Re: Wordpress and Postfix Mail Server Problem
« Reply #5 on: February 08, 2019, 07:48:02 AM »
I edited the file. but the same problem continues. SMTP settings; http://prntscr.com/mho46z
This might mean the issue is not with the firewall (though I had the exact same issue not long ago).
I suggest you disable the firewall and test again. If it works - it IS the firewall and you're doing something wrong.
If it doesn't work, we'll have to continue guess.
Don't forget to enable the firewall back again.

There is a problem with Postfix.

Code: [Select]
[root@server ~]# tailf -n 15 /var/log/maillog
Feb  5 07:47:21 server postfix/smtpd[19523]: connect from localhost[127.0.0.1]
Feb  5 07:47:21 server postfix/smtpd[19523]: SSL_accept error from localhost[127.0.0.1]: 0
Feb  5 07:47:21 server postfix/smtpd[19523]: warning: TLS library problem: 19523:error:14094418:SSL routines:ssl3_read_bytes:tlsv1 alert unknown ca:s3_pkt.c:1493:SSL alert number 48:
Feb  5 07:47:21 server postfix/smtpd[19523]: lost connection after STARTTLS from localhost[127.0.0.1]
Feb  5 07:47:21 server postfix/smtpd[19523]: disconnect from localhost[127.0.0.1]
Feb  5 07:47:28 server postfix/postfix-script[19554]: stopping the Postfix mail system
Feb  5 07:47:28 server postfix/master[5395]: terminating on signal 15
Feb  5 07:47:29 server postfix/postfix-script[19619]: warning: not owned by root: /etc/postfix/mysql-virtual_vacation.cf
Feb  5 07:47:29 server postfix/postfix-script[19636]: starting the Postfix mail system
Feb  5 07:47:29 server postfix/master[19638]: daemon started -- version 2.10.1, configuration /etc/postfix
Feb  5 07:47:36 server postfix/smtpd[19666]: connect from localhost[127.0.0.1]
Feb  5 07:47:36 server postfix/smtpd[19666]: SSL_accept error from localhost[127.0.0.1]: 0
Feb  5 07:47:36 server postfix/smtpd[19666]: warning: TLS library problem: 19666:error:14094418:SSL routines:ssl3_read_bytes:tlsv1 alert unknown ca:s3_pkt.c:1493:SSL alert number 48:
Feb  5 07:47:36 server postfix/smtpd[19666]: lost connection after STARTTLS from localhost[127.0.0.1]
Feb  5 07:47:36 server postfix/smtpd[19666]: disconnect from localhost[127.0.0.1]


By the way, do you have mod_sec activated? I've disabled it. Too many false positive cases.

Offline
***
Re: Wordpress and Postfix Mail Server Problem
« Reply #6 on: February 09, 2019, 01:40:45 AM »
Seems you have problems with the permissions of the file '/etc/postfix/mysql-virtual_vacation.cf':

Code: [Select]
(...)
Feb  5 07:47:29 server postfix/postfix-script[19619]: warning: not owned by root: /etc/postfix/mysql-virtual_vacation.cf
(...)

So, post your permissions of the file '/etc/postfix/mysql-virtual_vacation.cf' with the command:
Code: [Select]
# stat /etc/postfix/mysql-virtual_vacation.cf

Regards,
Netino

Offline
*
Re: Wordpress and Postfix Mail Server Problem
« Reply #7 on: February 09, 2019, 03:43:06 AM »
Seems you have problems with the permissions of the file '/etc/postfix/mysql-virtual_vacation.cf':

Code: [Select]
(...)
Feb  5 07:47:29 server postfix/postfix-script[19619]: warning: not owned by root: /etc/postfix/mysql-virtual_vacation.cf
(...)

So, post your permissions of the file '/etc/postfix/mysql-virtual_vacation.cf' with the command:
Code: [Select]
# stat /etc/postfix/mysql-virtual_vacation.cf

Regards,
Netino

http://prntscr.com/minmfq