Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - emar

Pages: [1] 2
1
Installation / Need to update Python should I update it or install twice?
« on: December 05, 2018, 03:27:37 AM »
Hi,

I have an app to test that requires Python 3.6 but the installed versionn is 2.7.5
How can I update it or should I install the new version of Python beside version 2.7.5?

Thanks in advance.

2
FTP / Re: FTP Manager v2 no access to public_html /home/user/public_html/./
« on: November 20, 2018, 11:43:59 PM »
Ah I sorted it, I logged in as root user instead.

3
FTP / FTP Manager v2 no access to public_html /home/user/public_html/./
« on: November 20, 2018, 05:20:57 AM »
Hi,

When I create an FTP account with FTP Manager v2
I can log in but I only see .bash_profilt, .bashrc, .bash_logout,
I can't see the public_html directory or any other.

In the FTP Manager the path says /home/user/public_html/./

https://snag.gy/YkoSIu.jpg

How can I solve this?

Thanks

4
SSL / Re: AutoSSL keeps expiring then won't install new cert
« on: October 23, 2018, 08:35:25 AM »
It's already ticked, under Auto Renovation

5
SSL / Re: AutoSSL keeps expiring then won't install new cert
« on: October 23, 2018, 04:53:57 AM »
I just clicked Force All Renovations under SSL certificates then it renewed the cert.
How do I make this cert auto renew before it expires each time?

6
SSL / AutoSSL keeps expiring then won't install new cert
« on: October 23, 2018, 04:38:32 AM »
Can anyone explain how to get autossl to install.
I went to ssl certificates and see the autosll cert has expired again,
So I deleted the cert then clicked AutoSSL FREE and tried to create a new cert.

I've no clue why I have to keep renewing this cert, can I set it to auto renew?

How do I fix this issue, can't instal la new cert.

Error...!
DNS of your domain doesn't point to this server or you have htaccess restrictions

I have a .htaccess in the public_html

########################################################
# package:    minPHP
# filename:   .htaccess
########################################################

# Do not allow direct access to templates
# or an unauthorized backdoor from CE
<Files ~ "blesta2ce.php|\.(pdt)$">
   order deny,allow
   deny from all
</Files>

# Protect against Clickjacking
#Header append X-Frame-Options "SAMEORIGIN"

RewriteEngine on

# Force HTTPS
#RewriteCond %{HTTPS} !=on
#RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [R=307,NE,L]

RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php

RewriteCond %{REQUEST_URI} ^(.*)/install.php$
RewriteRule install.php %1/install/ [R=301,L]

7
SSL / Re: AutoSSL has expired on domain, can't renew it..
« on: July 11, 2018, 02:41:02 AM »
I tried deleting the cert then added a new one, under Manual Install tab, but still shows as expired.

Successfully...!
Successful operation

Still shows as expired under List Installed tab.

8
SSL / Re: AutoSSL has expired on domain, can't renew it..
« on: July 07, 2018, 06:28:42 PM »
This is really disappointing after the amount of time I spent putting this together,

https://snag.gy/3OE8T9.jpg

9
SSL / Re: AutoSSL has expired on domain, can't renew it..
« on: July 07, 2018, 04:08:56 PM »
Is this fixable or do I need another Os with free certs?
I tried deleting the cert and creating it in Manual install, but the cert is still expired.

10
SSL / AutoSSL has expired on domain, can't renew it..
« on: July 02, 2018, 12:17:48 PM »
Hello,

I have an AutoSSL cert on a subdomain that has expired,
I clicked the Renew Now button under SSL Configurations,
The green popup indicated it was successful, but it hasn't renewed the cert.

I am trying to get this cert to auto update when it expires.

Also tried reload and restarting web server.

I ran the commands posted in this thread but not sure if they did anything:
http://forum.centos-webpanel.com/ssl/autorenew-ssl-is-enabled-yet-my-certificates-will-expired-after-6-days/msg12229/#msg12229

Any help appreciated.

11
I just did a fresh install on Centos 7 and I'm locked out of CWP again, the subdomain / website works.
The only thing I did on the VPS was enable firewalld and changed the default login port.

I created one user account and used subdomain.mysite.com for the domain.
I also ticked anable autossl.

Think the last thing I did was enable firewall in CWP.

When I'm in terminal I'm greeted by CWP so i guess it's running,
Restarted apache and rebooted server, no joy.

This site canít be reached
652.942.256.122 refused to connect.
Try:

Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_REFUSED

12
It's happened again on a fresh install, locked out of the admin panel.

13
Informations / Re: Will CWP work with a subdomain?
« on: March 15, 2018, 12:53:33 PM »
I see,

So for the hostname, should I have a subdomain setup at the other server (cpanel) and set the dns for that subdomain
under the main domain's dns zone? then set up another subdomain to use for my vps.

14
Informations / Re: Will CWP work with a subdomain?
« on: March 14, 2018, 09:28:19 PM »
Whatever I put in: Not a valid Hostname.
I think I have the whole subdomin thing a bit mixed up, I should use a FQDN but testing it with a subdomain.
I set it up on another server, dns records are there, pointed that to the vsp. maybe A records are mixed up.
Now I'm trying to use that subdomain for the CWP setup and my main site at home/user/public_html
Or maybe I need two subdomain I dunno, one for the site and one for svr1.clients.domain.com

Anyway I just did a fresh install, Centos 7, CWP 7

15
Informations / Will CWP work with a subdomain?
« on: March 14, 2018, 05:22:38 PM »
Hi,

Can I use a subdomain that was set up on another linux server in whm/cpanel?

Example clients.domain.com
This subdomain is pointed to my VPS.
The VPS Hostname is set to clients.domain.com
The VPS has one IP.

CWP installs fine but when I start playing with the settings,
I keep getting errors with the Hostname

Can anyone take a look at my setup in teamviewer or something?
I don't mind paying for support if I can get this setup correctly.

I created a user and added the subdomain as a domain, then enabled autossl and got locked out somehow.
So I completely rebuilt Centos 7 and enabled firewalld and changed the root login port.
I'm installing CWP again, but i need someone to have a look at my configuration.

Pages: [1] 2