Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - glorency

Pages: [1] 2 3
2
PHP / Re: PHP accelerator and Short_open_tag with prestashop
« on: March 15, 2019, 05:01:04 AM »
Hi,

...at points 1, 2 and 3 you say "and also select the required extension", which extension?
and item 5 what happens in its implementation?

Br
Venty

1. For PHP-FPM : Select all the extension except memcached & recode because Php IMAP will not work with recode and I will not use memcached because it is vulnerable with udp 11211

2. Repeat the step 1 using PHP Selector v2
3. Now Install and Build Latest PHP 7.3.2 using PHP Version Switcher v2 with all the extension except  litespeed, memcached & recode , dso-handler and fpm

N.B: fpm - Php Handler. Experimental not for public use!!!

PHP-FPM supports zend-opcache and apcu which are prerequisite for Presta 1.7.5

Think your have a domain which is domain.com and you have username for that domain. which is domain.

4.Now Goto WebServer Settings >> WebServer Domain Conf >> Select a UserName >> username >> Apache->php-fpm
5.Now Fix the permission : User Accounts >> Fix Permissions , If necessary

if you need more help , just reply

3
PHP / Re: PHP accelerator and Short_open_tag with prestashop
« on: March 14, 2019, 08:59:00 AM »
Hello,

I tried to install prestashop version 1.7.3.3 and one of my screens come up with the following inscriptions:

Install and/or enable a PHP accelerator (highly recommended)???
Short_open_tag set Off in php.ini?!!?

What to do??

Thanks in advance!

BR
Venty

To Fulfill Presta Requirement is quite easy on CWP Server. My suggestions:
1.Install Latest PHP-FPM 7.3.2 using PHP-FPM Selector  and also select the required extension
2.Again Install Latest PHP 7.3.2 using PHP Selector v2 and also select the required extension
3.Now Install and Build Latest PHP 7.3.2 using PHP Version Switcher v2 and don't forget to select the required extension
4.WebServer Settings >> WebServer Domain Conf >> Select a UserName >> username >> Apache->php-fpm
5.Now Fix the permission : User Accounts >> Fix Permissions

But Remember intl  is backdated for Latest Presta 1.7.5 , So you need to update this library to intl 63.1

Now your environment is ready for Presta hosting. [Tested]

4
Running directly php -m from the console won't run same php as the website does, these are completely different phps.

Inside the client web interface under the left side menu check what php version is set by default.
Then go to admin web interface and via the php selectors rebuild that version (be sure needed modules are checked on the [Options List] of the the version you need to rebuild.


I have checked with the followings:
Code: [Select]
[root@host ~]# /usr/local/cwp/php71/bin/php -v
PHP 7.0.32 (cli) (built: Oct  2 2018 06:39:45) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.4, Copyright (c) 2002-2018, by ionCube Ltd.

[root@host ~]# /usr/local/cwp/php71/bin/php -m
[PHP Modules]
bz2
Core
ctype
curl
date
dom
fileinfo
filter
ftp
gd
gettext
hash
iconv
ionCube Loader
json
libxml
mbstring
mcrypt
mysqli
mysqlnd
openssl
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
posix
Reflection
session
SimpleXML
sockets
SPL
sqlite3
standard
tokenizer
xml
xmlreader
xmlwriter
zip
zlib

[Zend Modules]
the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured)

And Installed ImageMagick using Script :
Code: [Select]
# sh /scripts/install_imagick
I know that CWPSRV is running as nginx with php71, So how can i build/Install another PHP Modules(Extension) for cwpsrv .

5
SSL / Re: http not forwarding to https
« on: March 14, 2019, 07:15:13 AM »
Use this code

Code: [Select]
return 301 https://$host:2031$request_uri;   on 

Code: [Select]
# vi /usr/local/cwpsrv/conf/cwpsrv.conf
server {
        listen       2030;
        listen       2086;
        server_name  localhost;
        return 301 https://$host:2031$request_uri;
        rewrite "/cwp_([0-9a-zA-Z]{32})/(.*)" /$2;

or Just follow this Guide : https://bit.ly/2UC49eu

6
SSL / Re: [BUG] AutoSSL Centos 6
« on: March 14, 2019, 07:11:25 AM »
admin/index.php?module=ssl_certificate

Clicking renew

Produces error

[Tue Aug  7 01:33:27 EDT 2018] Renew: 'domain.com'
[Tue Aug  7 01:33:27 EDT 2018] 'domain.com' is not a issued domain, skip.

As this command is trying to run

sh /root/.acme.sh/acme.sh --home /root/.acme.sh/cwp_certs --renew -d domain.com --force --debug

but it should run

sh /root/.acme.sh/acme.sh --home /root/.acme.sh/cwp_certs --renew -d www.domain.com --force --debug

www is missing in front of domain.


Just create a cname records for that domain with www , if missing 

7
SSL / Re: Error add AUTOSSL on domain. Certificate name mismatch
« on: March 14, 2019, 07:07:56 AM »
First I try CWP on a VPS and i see the ssl works fine. so now i installed cwp on my main server but i see some erros.

when i add a autossl certificate to mydomain.com and then i enter via https to that domain i got an error, and i when i check the certificate i got the next message
"Certificate name mismatch",
because the certificate name is the "hostname, this means server.hostingdomain.com"

so i cant add the autossl to that domain :(


Any Kind of SSL Issue with Let's Encrypt, Please follow the CWP Article  : https://bit.ly/2EYYLMb

8
SSL / Re: client login issue in ssl
« on: March 14, 2019, 07:07:15 AM »
Any Kind of SSL Issue with Let's Encrypt, Please follow the CWP Article  : https://bit.ly/2EYYLMb

9
ok. I need to restart cwpsrv and clenup browser cache


If you have any problem , Please check CWP Article for Hostname SSL with Let's Encrypt : https://bit.ly/2TBlzM0

10
SSL / Re: how to install letsencrypt for admin panel & user panel ?
« on: March 14, 2019, 07:00:18 AM »
This is for Server Hostname SSL settings . At Present CWP Team has been removed Lets Encrypt that's why it will not renew any cert . They made Auto SSL by default but Auto SSL grade is B and I'm satisfied with Auto SSL.

Can you please clarify this?  I thought Auto SSL was just a wrapper for letsencrypt?

Editing the hostname (Server Settings / Change Hostname) generates an invalid self-signed certificate.  Why has support for auto generated hostname letsencrypt certificates been removed, and is it coming back?


Also, the instructions in the thread "Install Letsencrypt SSL Certificate for your Server Hostname/FQDN, 100% Working" are not valid anymore as they refer to "Apache Settings >> Letsencrypt Manager >> Install Letsencrypt" which doesn't seem to exist anymore.


No , Auto SSL is still exist
New solution for Let'sEncrypt : goo.gl/Ys764T , This is google short link url .

Could you share that workaroud please that blog is invite only.
I like to be able to login to my pannel with out chrome throwing a vit.


Please check : https://bit.ly/2TBlzM0

11
PHP / Re: update ICU system package and the intl PHP extension
« on: March 10, 2019, 10:33:42 AM »
Quote
[root@cwp7 source]# yum list available | grep libicu
libicu.i686                               50.1.2-15.el7                  base
libicu-devel.i686                         50.1.2-15.el7                  base
libicu-doc.noarch                         50.1.2-15.el7                  base

Quote
[root@cwp7 ~]# icuinfo | grep version
    <param name="version">50.1.2</param>
    <param name="version.unicode">6.2</param>
    <param name="cldr.version">22.1.1</param>
    <param name="tz.version">2012j</param>


Well 50.1.2 the latest version of icu available for centos 7 base repository.

If you need any other version then you need to compile it from source (http://download.icu-project.org/files/icu4c/).

So lets take 62.1 version and compile it.


Quote
cd /usr/local/src
wget http://download.icu-project.org/files/icu4c/62.1/icu4c-62_1-src.tgz
tar -xvf icu4c-*.tgz
cd icu/source/
sed -i '/#define __UCONFIG_H__/a #define UCONFIG_ENABLE_PLUGINS 1' common/unicode/uconfig.h
./configure --prefix=/usr --bindir=/usr/bin --libdir=/usr/lib64 --datadir=/usr/share --enable-plugins
make -j4 && make install

Quote
[root@cwp7 source]# icuinfo | grep version
    <param name="version">62.1</param>
    <param name="version.unicode">11.0</param>
    <param name="cldr.version">33.1</param>
    <param name="tz.version">2018e</param>

More compiling options can be found inside "configure" and you can use as per your need.


Think you have a sub-domain sub1.abc.com and you want to install latest prestashop 1.7.5.0 on that sub-domain.
The best way , you have to use FPM/FastCGI for best performance and you have to identify lib-icu( intl PHP extension )

How do i identify ?
Go to your sub-domain home directory for sub1.abc.com , Copy the latest prestashop 1.7.5.0.zip and unzip here .

Now run the below command:
#php bin/symfony_requirements

Then install required intl PHP extension  and compile

12
How to / How to monitor CWP Server Services using Monit ?
« on: March 09, 2019, 11:38:26 AM »
Monit is a free open source and a very helpful program that automatically monitors and manages server process, files, directories, checksums, permissions, filesystems and services like Apache, Nginx, MySQL, FTP, SSH, Postfix and so on in a UNIX/Linux based systems and provides an excellent monitoring functionality to system administrators.

Follow The Below Guide:
CWP: How to monitor CWP Server Services using Monit on CentOS 7.6
https://blog.awsmonster.com/2019/03/cwp-how-to-monitor-cwp-server-services.html

CWP: How to Add Let's Encrypt SSL to Monit on CentOS 7.6
https://blog.awsmonster.com/2019/03/cwp-how-to-add-lets-encrypt-ssl-to.html

13
SSL / Re: SSL for the mail server?
« on: February 04, 2019, 04:14:29 PM »
Here it is : goo.gl/Ys764T , This is google short link url .

direct link: http://forum.centos-webpanel.com/ssl/install-let'sencrypt-for-admin-panel-user-panel-again-100-working/

I wrote a blog on http://forum.centos-webpanel.com regarding Let's Encrypt SSL Certificate for CentOS Web Panel when "Letsencrypt Manager"  option was exist under Apache Settings >> Letsencrypt Manager >> Install Letsencrypt .

At Present CWP Team has been removed "Letsencrypt Manager"  that's why it will not renew any cert automatic . They made Auto SSL by default but Auto SSL grade is B and I'm not satisfied with Auto SSL.

Previous Article Link : http://forum.centos-webpanel.com/ssl/install-letsencrypt-ssl-certificate-for-your-server-hostnamefqdn-100-working/

15
SSL / Re: LetsEncrpt wildcard SSL issues.
« on: January 19, 2019, 10:08:20 AM »
can you try *.domain.com

Pages: [1] 2 3