Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - planetjoin

Pages: [1]
1
Well

sh /scripts/mail_roundcube_update

###############################
Roundcube is already up-to-date
###############################

And if i create a new client/domain, then create a new email account, and then try to login using roundcube i get this error in roundcube :

"An ERROR OCURRED"
Server Error: STATUS: Internal error occurred. Refer to server log for more information.

and the error is the folder of the domain is NOT created under /var/vmail    :(

If i do all the steps described above, round cube and outlook begins to work.

I have centos 7.5 and last panel version

Regards
Fabian

2
Hello

Ive tried creating a new domain, and going first to roundcube, and nothing happens.
I will try updating roundcube now with sh /scripts/mail_roundcube_update and try again.

Anyway.. the panel itself must to create the folder and enable the email account when we create a new email address, WITHOUT login to roundcube.. many people use emails in outlook and never uses webmail

I will post if the update of roundcube works.

Thanks
Fabian


3
Hello guys

I was all day trying to fix this issue and finally i found the problem.

PROBLEM :
1 - I create a new client account/domain in CWP : example : domain.com
2 - all goes well but.. when we create a new email , apparently it is created without errors, but never works. (we can SEND but NOT receive). In forums and Google there are LOT people with the same issue in CWP.
3 - Obviusly, another "associated" issue is that roundcubemail not works neither.

SOLUTION :

1 - create a new folder under /var/vmail with the domain created above (like /var/vmail/domain.com)
2 - change group and owner of this folder :
# chown vmail.mail /var/vmail/domain.com
3 - change permissions from 755 to 700 to that folder :
# chmod 700 /var/vmail/domain.com

DONE!

You can now login in roudncube and it creates the corresponding folders, and you also can use the account in OUtlook, Thunderbird, etc, like a charme...

But, CWP PEOPLE.. this is not just a "bug" this is ridiculous!!! Each time we create a new site, we must to do this MANUALLY ????

The domain.com folder under /var/vmail MUST TO BE CREATED AUTOMATICALLY!!!

I hope someone from CWP can read this an fix this terrible issue.
For other things.. the Panel looks perfect, and until now is working all well.

Thanks
Fabian

4
PHP / i cant run php as html files
« on: January 26, 2019, 06:34:17 PM »
Hello

I have is php switcher 7.2.15
also compiled the same verion 7.2.15 in php_selector 2

I have a site using html files but with php code.
Normally, in all servers with cpanel and other panels i do this with the addhanlder line in htaccess like this :

AddHandler application/x-httpd-php72 .php .html

not working here.. the files with html extension and php code display the code.

Ive tried everything.. i set at "webserver domains conf" for the domain : apache + nginx php-cgi
i modified this part in the domain.conf under nginx (/etc/nginx/conf.d/vhosts/domain.com.conf)

 location ~ .*\.(php|jsp|cgi|pl|py)?$ {
                proxy_pass http://1.1.1.1:8181;
                include proxy.inc;
        }

for this :

 location ~ .*\.(php|html|jsp|cgi|pl|py)?$ {
                proxy_pass http://1.1.1.1:8181;
                include proxy.inc;
        }


then restarted Nginx and apache

nothing happens :(

any help ?

5
PHP / Re: PHP Switcher not Switching?
« on: January 12, 2019, 01:24:45 AM »
DONE!

all worked fine now ;)
When ive tried to install PHP selector,, from 5.6 to 7.3 included, installed 5.6, 7.0 and 7.1 NEVER install 7.2 and 7.3
Then.. ive updated 5.6, 7.0 and 7.1 perfectly in php selector.

After this.. i tried again in phpswitcher, and changed 5.6.37 to 7.1.25 and worked perfect.

Apparently the panel not allow PHP 7.2 and 7.3 for some reason.

Maybe a bug ?

Thanks
Fabian

6
PHP / Re: PHP Switcher not Switching?
« on: January 11, 2019, 08:12:11 PM »
Hello

I have by default 5.6.37
Ive already compiled many times.. 7.2, 7.3 etc.

When i enter thru console this :
/usr/local/cwpsrv/htdocs/resources/conf/php_switcher/7.3.ini

I get this :

sh /usr/local/cwpsrv/htdocs/resources/conf/php_switcher/7.3.ini: Permission denied

What im doing wrong?
Thanks
Fabian




7
PHP / New Install - i cant understand PHP Switcher - never works
« on: January 11, 2019, 07:22:23 PM »
Hello

I just instaled the panel to test it.
I have as main PHP version installed 5.6.37 (display in "PHP info")

Then, i want to switch it to 7X

Ive try to 7.2, to 7.3 etc..
Apparently all compile fine.. but ALWAYS appears 5.6.37 as PHP version.

What think Im doing wrong ??

Anyway.. to use PHP selector V2 I need to upgrade to CWP PRO ?? or can still using the free version?

Thanks in advance
Fabian

Pages: [1]