Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Sandeep

Pages: [1] 2 3 ... 52
1
Apache / Re: HTTP2 / SPDY
« on: August 17, 2018, 07:27:48 AM »

2
CentOS-WebPanel Bugs / Re: BUG on PHP Builder
« on: June 18, 2018, 06:35:29 AM »
Switch to php7.2.5 and stuck at this:

Code: [Select]
Libraries have been installed in:
   /usr/local/src/uploadprogress/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------

Build complete.
Don't forget to run 'make test'.

Installing shared extensions:     /usr/local/lib/php/extensions/no-debug-non-zts-20170718/

But it did switched to php7.2.5. It worries me because I see it stuck there. Does that mean something is wrong with my php7.2.5? Is the installation incomplete?

you didn't provided much information
does php 7.2.5 is now installed or something else ?

3
CentOS 7 Problems / Re: Port 443 not working with nginx on
« on: April 27, 2018, 11:55:07 AM »
copy the cert to CA bundle file and rebuild vhost or web-server

4
PHP / Re: How to add yaz extension to php?
« on: April 12, 2018, 07:45:23 AM »
Hi I run a joomla site and one of its components requires the yaz extension.  How do I find and install yaz extension.

Thanks in advance for your help :)

I am running PHP version: 7.2.0

Code: [Select]
cd /root
wget http://ftp.indexdata.dk/pub/yaz/yaz-5.23.1.tar.gz
tar -zxvf yaz-5.23.1.tar.gz
cd yaz-5.23.1
./configure
make
make install

cd /root
wget https://pecl.php.net/get/yaz-1.2.2.tgz
tar -zxvf yaz-1.2.2.tgz
cd yaz-1.2.2
phpize
./configure
make
make install

add this line to php.ini :
Code: [Select]
extension=yaz.so

5
CentOS-WebPanel GUI / Re: Login to CWP (SSL_ERROR_RX_RECORD_TOO_LONG)
« on: March 19, 2018, 02:03:28 PM »
unfortunately this error is caused due to OS/backend firewall issues you need to reinstall or if you've backend firewall check with the admin

6
you can install it via php switcher

7
implement memcached or redis for your script this will lower the load to 30-40%

8
OS language should be in eng (us)

9
CentOS-WebPanel GUI / Re: Login to CWP (SSL_ERROR_RX_RECORD_TOO_LONG)
« on: March 18, 2018, 02:13:16 PM »
reinstall the os ensure you ran this command before installing cwp :
Code: [Select]
yum update -y && reboot now

10
E-Mail / Re: Clamav
« on: February 02, 2018, 03:39:45 PM »
Run this command and paste the output here
Code: [Select]
uname -sr

11
is port 80 is open globally ?

12
if you want to disable pureftpd you can stop it and disable start up after reboot. It will shown unknown status

13
it will show because it is integrated with CWP.

14
PHP / Re: PHP7.1 ZendGuardLoader.so: undefined symbol: zval_used_for_init
« on: February 01, 2018, 03:11:08 PM »
you can learn more about zend engine : http://www.zend.com/products/zend_engine/in_depth

15
PHP / Re: PHP7.1 ZendGuardLoader.so: undefined symbol: zval_used_for_init
« on: February 01, 2018, 03:08:44 PM »
downgraded to PHP5.6.3 through the PHP switcher

Code: [Select]
rpm -qa php\* | sort; rpm -Va php\*; php -m
rpm -qa php-cgi\* | sort; rpm -Va php\*; php -m
rpm -qa php-fpm\* | sort; rpm -Va php\*; php -m
no issues reported

Code: [Select]
php -v
php-cgi -v
no issues reported

Code: [Select]
php-fpm -vFailed loading /usr/local/zend/5.6/ZendGuardLoader.so:  /usr/local/zend/5.6/ZendGuardLoader.so: undefined symbol: zval_used_for_init
PHP 7.0.10 (fpm-fcgi)

The issue is fixed by the developer
thanks for reporting

Pages: [1] 2 3 ... 52