Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Dexxa

Pages: [1] 2
1
CentOS 6 Problems / Re: No package pure-ftpd available centos 6
« on: October 31, 2018, 01:35:19 PM »
yum install pure-ftpd --enablerepo=epel doesn't work sometimes as it took me all night to try and get centos panel installed,

I found a way around it tho, before you install the panel

rpm -Uvh http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
This should place a file at /etc/yum.repos.d/epel.repo, with a first line:

[epel]
That first line is the name of the repo, so if you don't see it, it's not there.

Try downloading the file first -- just paste the URL into the address bar of a browser:

http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
And work from there by installing it:

sudo rpm -ivh epel-release-6-8.noarch.rpm
The package enables the epel repo by default, so you shouldn't have to say --disablerepo='*' --enablerepo=epel (note my difference of opinion on quotes).

and then do yum install pure-ftpd --enablerepo=epel

and now it should install :-)

2
I can build it / Re: Boxbilling Integration
« on: August 29, 2018, 06:26:30 PM »
Are you willing to share the code so other people can use your good work on their servers? :-)

3
New Modules / Re: [module] GamePanel Module
« on: December 30, 2017, 02:40:10 AM »
Or might be a good idea if you could use this https://gameservermanagers.com/

Maybe use them scripts to install games from the panel?

4
New Modules / Re: [module] GamePanel Module
« on: December 30, 2017, 12:44:55 AM »
Are you ever planning on making the code avalible on github. Im sure I'm not the only person who would be intresting in contributing.

That would be a good idea, Will take some of the stress off GoGo :-)

5
SSL / Re: letsencrypt + Python Problems!
« on: September 28, 2016, 06:55:23 PM »
Did you solved this issue? It happened to me too..

Yes, on the 32bit version, do this

To solve it:

1- First install python requirements
$yum install epel-release
$rpm -ivh https://rhel6.iuscommunity.org/ius-release.rpm
yum --enablerepo=ius install git python27 python27-devel python27-pip python27-setuptools python27-virtualenv -y
2- Workaround for missing files
$ echo /opt/rh > /etc/scl/prefixes/python27
$mkdir /opt/rh/python27
$touch /opt/rh/python27/enable

This solve for me the problem with the Unable to open: /etc/scl/prefixes/python

Then i got another problem virtualenv not found, this can be solved using symbolink link
$cd /usr/bin
$ln -s  virtualenv-2.7  virtualenv

on the 64bit version you dont need to do anything as it works fine

6
New Modules / Re: Game Panel Plugin :D
« on: September 20, 2016, 07:39:19 PM »
Is this project still being worked on?

7
SSL / Re: Letsencrypt new domain
« on: September 10, 2016, 03:17:59 PM »
It seems you need to do it on the 32Bit version, but be cafeful when i rebooted server webpages wouldnt load.  But on the 64Bit version it works as normal without doing that trick

8
SSL / Re: Letsencrypt new domain
« on: August 27, 2016, 12:21:53 PM »
This worked for me on centos to :-D

Hi I had the same Issue, I'm using CentOS 6.8

I did a workaround (Is not the best solution but it works). This happens because for some reason scl is not working properly.

To solve it:

1- First install python requirements
$yum install epel-release
$rpm -ivh https://rhel6.iuscommunity.org/ius-release.rpm
yum --enablerepo=ius install git python27 python27-devel python27-pip python27-setuptools python27-virtualenv -y
2- Workaround for missing files
$ echo /opt/rh > /etc/scl/prefixes/python27
$mkdir /opt/rh/python27
$touch /opt/rh/python27/enable

This solve for me the problem with the Unable to open: /etc/scl/prefixes/python

Then i got another problem virtualenv not found, this can be solved using symbolink link
$cd /usr/bin
$ln -s  virtualenv-2.7  virtualenv

I hope this work for you too.

9
SSL / Re: letsencrypt + Python Problems!
« on: August 26, 2016, 01:03:20 AM »
I have done that :)

10
SSL / Re: letsencrypt + Python Problems!
« on: August 25, 2016, 11:19:04 AM »
Also getting Initialized empty Git repository in /opt/cwp_letsencrypt/.git/

11
SSL / letsencrypt + Python Problems!
« on: August 25, 2016, 12:20:00 AM »
Hi

Im trying to install letsencrypt ssl certs via the control panel, followed the video etc, tried upgrading pyton  but i keep getting the same error message

WARNING! Letsenycrpt Certificate installation failed, please check /etc/letsencrypt/live/**********.co.uk !
Unable to read or file empty /etc/scl/prefixes/python27!


Anyone know how to fix this, it'd be a great help to me :)

12
How to / Re: How to install Freepbx with CWP?
« on: May 16, 2016, 12:27:44 PM »
I dont think you can

13
How to / Re: How To Install Forever
« on: May 16, 2016, 12:26:26 PM »
A simple CLI tool for ensuring that a given script runs continuously (i.e. forever)

https://github.com/foreverjs/forever

14
New Modules / Re: Game Panel Plugin :D
« on: January 13, 2016, 02:52:48 PM »
Hope your feeling better soon :)

I have some medical problems so for now i stop with development. :/ But i'll continue to develop plugin soon.

15
New Modules / Re: Game Panel Plugin :D
« on: November 13, 2015, 01:51:35 PM »
That's good :). You'll have a regular customer with me :)

What a like is that you dont give small one line info like many people do, You've provided us with all the info we need on one post!

Are you having a reseller feature to? so vps providers can provide your panel to its vps clients?

Pages: [1] 2