Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - dg1

Pages: [1] 2
1
PHP / Re: Installation of php 7.x fails
« on: September 26, 2017, 04:38:00 PM »
PHP 7.1 installs 7.1.7

How to get 7.1.9 then if 7.x fails?

Also, if 7.x is for advanced users or experimental, it should be marked as such. Right?

2
Installation / Re: Horde Webmail Installation
« on: September 24, 2017, 08:27:23 PM »
These instructions do not seem to work for Centos 7. Too many warnings / errors about deprecated and obsolete files.

Does anyone have updated instructions? Preferably more detailed.

3
PHP / Re: Cron jobs containing relative paths fail
« on: September 23, 2017, 03:40:47 AM »
OK, this works for files in the same folder by supplying the absolute URL, but what about relative paths?

What's the replacement for ('../abc.php')?

How about ('../../abc.php')?

Or ('./abc.php')?

4
PHP / Re: Installation of php 7.x fails
« on: September 23, 2017, 03:32:32 AM »
An obvious fix didn't work.

Code: [Select]
yum install libzip
Just resulted in another error:

checking libzip... yes
checking for the location of zlib... /usr
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for libzip... configure: error: system libzip must be upgraded to version >= 0.11
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.


5
PHP / Re: built custom version using PHP Selector, how do I set as default?
« on: September 23, 2017, 02:59:55 AM »
Use PHP Version Switcher under PHP Settings if you want to change the default PHP version.

PHP Selector is for additional PHP versions, which you specify in .htaccess

6
PHP / Installation of php 7.x fails
« on: September 23, 2017, 02:56:42 AM »
While trying to install PHP 7.x, installer fails. Does not apply to 7.0/7.1, these install with no issues.

Error:

checking pcre install prefix... no
checking libzip... yes
checking for the location of zlib... /usr
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for libzip... not found
configure: error: Please reinstall the libzip distribution
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.
Redirecting to /bin/systemctl restart httpd.service


Any ideas why?

7
Updates / Re: Apache 2.4.27 option missing in Apache Builder (compiler)
« on: September 22, 2017, 01:53:25 PM »
Yes, it is now available with CWP v0.9.8.358

8
Updates / Re: Apache 2.4.27 option missing in Apache Builder (compiler)
« on: September 21, 2017, 01:25:18 PM »
Yes, that worked. Thanks for the tip.

I was just wondering why it's not available in the Apache Re-Build pulldown menu here:


9
Postfix / Warnings when trying to view e-mail in Manage Mail Queue
« on: September 19, 2017, 06:46:44 PM »
I'm getting warnings when trying to view e-mail delivery details in Manage Mail Queue

Warning: [obfuscated](): charset `US-ASCII' not supported, assuming utf-8 in /usr/local/cwpsrv/htdocs/resources/admin/addons/mail_explorer_addon.php on line 0

and

Warning: [obfuscated](): Requires argument 2, 'TagsWorker', to be a valid callback in /usr/local/cwpsrv/htdocs/resources/admin/addons/mail_explorer_addon.php on line 0

10
PHP / Re: Cron jobs containing relative paths fail
« on: September 18, 2017, 09:41:11 PM »
An example of a fix (not tested thoroughly) could be to include this line in the beginning of each script that is executed via cron.

Code: [Select]
chdir(__DIR__);
Still, would be nice to see a fix on CWP level.

11
CentOS-WebPanel Bugs / Re: Segmentation fault caused by ZendGuardLoader.so
« on: September 18, 2017, 07:31:48 PM »
Somehow, the PHP Version Switcher re-build created a wrong entry.

Affected file: /usr/local/php/php.d/zend.ini

Code that causes "segmentation fault" error:
Code: [Select]
extension=/usr/local/zend/5.6/ZendGuardLoader.so
Corrected code (no error)
Code: [Select]
zend_extension=/usr/local/zend/5.6/ZendGuardLoader.so
FYI

12
PHP / Cron jobs containing relative paths fail
« on: September 18, 2017, 01:18:39 PM »
It seems, if a PHP script contains something like:

Code: [Select]
include('../another-file.php');
It will work properly if opened in browser or CLI, but fail in cron with a message similar to:

Code: [Select]
PHP Warning:
include(../another-file.php): failed to open stream: No such file or directory in /home/account/public_html/cron-test.php on line 3

Scripts can be modified to use absolute paths instead of relative paths, but that's not the best solution for everyone, especially if lots of files are executed using cron jobs.

Is there a fix for this at the control panel (CWP) level?

13
CentOS-WebPanel Bugs / Segmentation fault caused by ZendGuardLoader.so
« on: September 18, 2017, 12:59:50 PM »
It seems, after recompiling using PHP Version Switcher v2, the command line (CLI) version of PHP starts triggering this error:

Code: [Select]
PHP 5.6.31 (cli) (built: Sep 18 2017 00:20:10)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend Guard Loader v3.3, Copyright (c) 1998-2015, by Zend Technologies

Segmentation fault

Caused by ZendGuardLoader.so called in /usr/local/php/php.d/zend.ini

Any ideas why?

14
PHP / Re: How to remove unwanted php version?
« on: September 18, 2017, 04:52:34 AM »
Deleting /opt/alt/phpXX is an easy fix.

But why not make it even easier by adding a "Remove" button (with confirmation) besides the installed PHP versions in CWP PHP Selector? In a future version of CWP...

15
Updates / Apache 2.4.27 option missing in Apache Builder (compiler)
« on: September 17, 2017, 02:35:09 PM »
2.4.27 installed, but no option to recompile without downgrade.

Only options available are 2.4.23, 2.4.25 and 2.4.26

Pages: [1] 2