Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - ring_c

Pages: [1] 2
1

I've got the following mail from the firewall. Any idea what it means? I didn't see anything odd and the site is loading.
[/size]I've replaced the username with {USERNAME}.[/color]
[/size][/color]


[/size][/color]
[/size]Subjetct: lfd on {HOSTNAME}: Suspicious process running under user {USERNAME}[/color]
[/size]Time:    Thu Feb 14 22:38:21 2019 +0200[/color][/size]PID:     25646 (Parent PID:3086)Account: {USERNAME}Uptime:  67 seconds


Executable:

/opt/alt/php-fpm56/usr/sbin/php-fpm


Command Line (often faked in exploits):

php-fpm: pool {USERNAME}


Network connections by the process (if any):

tcp: 127.0.0.1:42342 -> 127.0.0.1:3306


Files open by the process (if any):

/tmp/.ZendSem.Od78F8 (deleted)
/dev/urandom
/home/{USERNAME}/public_html/wp-content/wflogs/ips.php
/home/{USERNAME}/public_html/wp-content/wflogs/config.php
/home/{USERNAME}/public_html/wp-content/wflogs/attack-data.php
/home/{USERNAME}/public_html/wp-content/wflogs/config-synced.php
/home/{USERNAME}/public_html/wp-content/wflogs/config-livewaf.php
/home/{USERNAME}/public_html/wp-content/wflogs/config-transient.php
/home/{USERNAME}/public_html/wp-content/wflogs/GeoLite2-Country.mmdb
/etc/pki/nssdb/cert9.db
/etc/pki/nssdb/key4.db
[/size]

2
PHP / Changes in PHP.INI won't work!
« on: February 05, 2019, 08:16:55 AM »
Hi,


I'm using CWP PRO 0.9.8.763 and my server is configured to use NGINX+APACHE+VARNISH+PHP-FPM, and I was trying to increase upload_max_size for a user. I've tried the following:
1. Adding a php.ini file - didn't work.
2. Editing php.ini within the user's CWP panel - didn't work.
3. Deleting php.ini caused the panel to create a default php.ini, yet - didn't work.
4. I've found an answer here that since 0.9.8.742 we should use .user.ini instead of php.ini - didn't work.
5. Putting this .user.ini in wp-admin folder - didn't work.
6. Putting php.ini in wp-admin folder - didn't work.
7. Another answer here said something about a trailing slash after localhost - but mine didn't have this slash.


So... why do we have to guess? Why for instance the definitions for php.ini the user sets in his panel won't work. Even the definitions under PHP Settings -> PHP Simple Editor in the main CWP panel won't change anything.


I'm really puzzled where I can change this php settings either globally or per user (preferably per user).

3
Mod_Security / Hugh log files!
« on: February 02, 2019, 10:01:00 PM »
I just found that my mod security log file was 4GB large!!!
Is there a way to limit this log?

4
Apache / Large domlogs files
« on: February 02, 2019, 09:59:44 PM »
In /usr/local/apache/domlogs/ I have very large log files. Is there a way to make them up to a specific size?


5
Mod_Security / Changing rules on Comodo WAF with CWP Pro
« on: December 10, 2018, 06:00:08 AM »
Hi,


I've just got my CWP Pro enabled and installed Comodo's WAF but I need to disable some rules. Where do I do that?

6
Aplications / Wordfence / Ninja Firewall
« on: December 09, 2018, 06:14:36 PM »
Hi,


Since the update to PHP-FPM I can't install Wordfence or Ninja Firewall (both are using auto_prepend_file) on my wordpress sites.
My webserver is apache + varnish + php-fpm. I've also tried changing the webserver to use fastcgi, but it didn't change anything.


Any idea?

7
PHP / Can't use personal php.ini
« on: December 06, 2018, 04:15:47 PM »
Hi,


I was going through this guide, but couldn't make the persoanl php.ini (per account, and not a global one) to work.
By the way, I beleive it was working properly before I upgraded to php-fpm yesterday.


Would appretiate if anyne can advise what I might be missing.
By the way, during the php-fpm upgrade, I was also compiling some other php versions. Might this cause such an issue?


TIA.

8
Installation / Login loop prior to CWP update
« on: December 05, 2018, 11:39:33 AM »
Hi,


As most of you I was prompted to update CWP to PHP-FPM. I tried. But once I clicked the next (?) button, I got into a loin loop.
CWP is asking me again and again to login. I'm inputting my credentials, the dashboard loads and immediately asks again to login.


Any idea?

9
Informations / Spam on this forum
« on: September 20, 2018, 05:36:03 AM »
I hope this is the right place to post this. Couldn't find a specific forum which is only related to CWP forum itself.
Anyway, lately there's a lot of spam posts, and while I'd like to report them to the admin, there's a limitation of 120 second in between reports, which makes it really hard to report when there's so many spam like today...


Would you consider reducing the report gap to something like 15 sec?

10
Aplications / NetData vs Glances
« on: September 20, 2018, 05:30:24 AM »

Did anyone try to install Glances along side to CWP?
How is it compare to Neddata?


Here's the installation guide for Glance I've came across accidently.https://www.tecmint.com/install-glances-influxdb-grafana-to-monitor-centos-7/


Important note: I didn't install Glances, hence can't say if it works well with CWP.

11
Backup / Error found on the email from - Anacron job 'cron.daily'
« on: September 03, 2018, 05:44:00 AM »
For the first time I've looked deeply into the email received for the daily backups and found some errors (marked the errors in Red):

---
mysqldump: unknown variable 'local-infile=0'
Database Backup: dbb_dba --> /backup/mysql/daily//dbb_dba.sql
mysqldump: unknown variable 'local-infile=0'
Database Backup: dbb_dbb --> /backup/mysql/daily//dbb_dbb.sql
mysqldump: unknown variable 'local-infile=0'
Database Backup: dbb_dbc --> /backup/mysql/daily//dbb_dbc.sql
mysqldump: unknown variable 'local-infile=0'
Database Backup: dbb_dbd --> /backup/mysql/daily//dbb_dbd.sql
mysqldump: unknown variable 'local-infile=0'
Database Backup: dbb_dbe --> /backup/mysql/daily//dbb_dbe.sql
mysqldump: unknown variable 'local-infile=0'
Database Backup: dbb_dbf --> /backup/mysql/daily//dbb_dbf.sql
mysqldump: unknown variable 'local-infile=0'
Database Backup: dbb_dbg --> /backup/mysql/daily//dbb_dbg.sql
Skipping database: information_schema.
mysqldump: unknown variable 'local-infile=0'
Database Backup: dbb_dbh --> /backup/mysql/daily//dbb_dbh.sql
mysqldump: unknown variable 'local-infile=0'
Database Backup: mysql --> /backup/mysql/daily//mysql.sql
mysqldump: unknown variable 'local-infile=0'
Database Backup: oauthv2 --> /backup/mysql/daily//oauthv2.sql
mysqldump: unknown variable 'local-infile=0'
Database Backup: performance_schema --> /backup/mysql/daily//performance_schema.sql
mysqldump: unknown variable 'local-infile=0'
Database Backup: postfix --> /backup/mysql/daily//postfix.sql
mysqldump: unknown variable 'local-infile=0'
Database Backup: root_cwp --> /backup/mysql/daily//root_cwp.sql
mysqldump: unknown variable 'local-infile=0'
Database Backup: roundcube --> /backup/mysql/daily//roundcube.sql
mysqldump: unknown variable 'local-infile=0'
Database Backup: dbb_dbi --> /backup/mysql/daily//dbb_dbi.sql
warning: /var/tmp/rpm-tmp.RpBiRK: Header V4 DSA/SHA1 Signature, key ID cd2efd2a: NOKEYerror: Failed dependencies:
       perl(DBD::mysql) >= 1.0 is needed by percona-toolkit-2.2.16-1.noarch
---

Any idea what might be wrong?

12
CentOS-WebPanel GUI / Resources monitor per user/website
« on: September 01, 2018, 08:54:37 PM »
Hi,


Is there a way for me as admin to see how many resources each user/site is using (RAM/CPU/etc...)?
Couldn't find a page with such info.


TIA.

13
I've installed memcached and redis but found out it's causing severe issued on my server, so I've uninstalled them.
But I still see there are 2 folders under the root folder named php-memcached and php-redis which are about 22mb altogether.
Is it safe to remove them?

14
Installation / How to enable Expires headers
« on: August 30, 2018, 03:05:40 PM »
Hi there, I hope this is the right forum to post this question to.


I'm getting "Add Expires headers" in GTmetrix. I'm using Apache + Nginx + Varnish.
According to this tutorial (dated 2015):


Quote
For additional module activation you only need to add a new line in the text box, like for example:


--enable-expires
--enable-headers
--enable-proxy



But I don't see any text box to add these.


Can you please advise how to properly enable Expires headers?


TIA!

15
CentOS-WebPanel Bugs / Addons issue
« on: August 27, 2018, 02:49:50 PM »
Are you aware of the following?

1. When trying to install Joomla or Drupal from the addon menu, the message floating on the screen says it installs wordpress.
2. I had no problem to remove Drupal from the installation screen, but Joomla won't be removed.

Pages: [1] 2