Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Gogo

Pages: [1] 2 3 ... 10
1
PHP / Re: PHP Selector
« on: January 16, 2019, 04:41:19 PM »
https://pastebin.com/  because that log is large and you won't be able to paste it full here on the forum

2
PHP / Re: PHP Selector
« on: January 16, 2019, 10:13:53 AM »
@venty paste full log (use pastebin due large log file) /var/log/php-selector-rebuild.log

3
Other / Re: Admin Login Problem
« on: January 15, 2019, 03:42:20 PM »
I didn't mention that this 99.9%  includes not running processes.

As studio4host mentione above hostname ssl cert can be reason for not starting cwp, you can try .
(run as root)
Try to run:
Code: [Select]
sh /usr/local/cwpsrv/htdocs/resources/scripts/generate_hostname_sslThen:
Code: [Select]
sh /usr/local/cwpsrv/htdocs/resources/scripts/restart_cwpsrv
If won't work after that, check if /etc/pki/tls/certs/hostname.crt  exist (it should be symbolic link linked to hostname sub.domain.tld.crt  located in the same ...certs/ directory).

4
Other / Re: Admin Login Problem
« on: January 15, 2019, 02:33:41 PM »
Run  journalctl -xe  and paste output here.

Seems your firewall settings are messed up, because connection refused error in browsers is 99,9% sure that port isn't opened or you are on the firewall's black list.

5
New Modules / Re: [module] PhpMyAdmin auto login
« on: January 14, 2019, 11:13:33 PM »
@ekgrad
Replace:
Code: [Select]
action="http://<?php echo $_SERVER["SERVER_NAME"];?>/phpMyAdmin/"with:
Code: [Select]
action="/pma/"

6
PHP Selector / Re: php_selector3 Error
« on: January 06, 2019, 06:47:36 PM »
That't not related to my server, it's a CWP problem.

I've tested that on 10+ servers (different specs) and every single one of them had same problem. Also I am not the only one who have that problem. Just check the rest of the forum how many people faced it.

7
PHP Selector / Re: php_selector3 Error
« on: January 02, 2019, 04:45:45 PM »
I have temporarly fixed this by disabling xpm-dir in Options list before building/rebuilding 7.x versions.

And still, that have to be fixed inside CWP because that php builder script has a memory leak looks like.

8
E-Mail / Re: Problem with mail
« on: January 02, 2019, 04:33:46 PM »
First part, blacklisting has nothing to do with CWP. That's because part of the network where your ip is hosted (same hosting/service provider) is on Hotmail's block/black list.

If your IP wasn't used for spam you can manually fill this online form to delist just your server IP address: https://support.live.com/eform.aspx?productKey=edfsmsbl3&ct=eformts&wa=wsignin1.0
Otherwise you have to contact your hosting/service provider and paste them this mail response you've got.


Second part, you have to set server hostname, it has to be a subdomain. Then rebuild mail server.
Be sure your subdomain is pointed to server IP address directly using A record on Cloudflare, you can't use Cloudflare Proxy for this, that orange cloud has to be gray for this subdomain. So your IP address has to be exposed by hostname (subdomain used for hostname), hostname can't be behind proxy.

10
PHP / Re: Imap not activated on Php 7.2.13
« on: December 27, 2018, 02:28:17 PM »
Rebuild that php version via php selectors, be sure you checked imap on the [Options List] for that version before rebuilding it.

11
PHP / Re: How to Load PHP extensions Imagick & Exif for Rouncube Webmail
« on: December 27, 2018, 02:26:06 PM »
Running directly php -m from the console won't run same php as the website does, these are completely different phps.

Inside the client web interface under the left side menu check what php version is set by default.
Then go to admin web interface and via the php selectors rebuild that version (be sure needed modules are checked on the [Options List] of the the version you need to rebuild.

12
New Modules / [module] Fix Account Permissions Better
« on: December 26, 2018, 06:41:02 PM »
Since I had custom directories for multiple domains for one user, CWP's stock fix acc perm didn't work (for any files/folders outside of the default public_html directory) so I managed to create a custom module to fix permissions.

Warning:
Since this module will modify (CHMOD and CHOWN) user files in it's own directory it can break your website!
(eg. if your CMS needs different CHMOD for a single file you'll need to manually return it to the required CHMOD)

Disclaimer:
By using this module (better-fix-account-permissions) you agree with the terms located in this disclaimer. This module is released AS-IS. I (developer of this modelue) am NOT responsible for any damage caused by using this module nor I will provide any help for the damage cause by using this module. Use this module at your own risk!

Download and Infos:
https://github.com/gogo1207/cwp/tree/master/admin/modules/better-fix-account-permissions

Any suggestion can be made on github or here in this topic.

13
Yeah that should work to as you did, removing /admin completely and leaving index.php?module=speedtest only.

That random string is some kind of session verification as it looks like.

14
You have to replace old file with new one.

Oh, sorry I didn't understand you completely.
Please find file
Code: [Select]
/usr/local/cwpsrv/htdocs/resources/admin/include/3rdparty.phpAnd find button for Speedtest module.
You'll see something like: 
Code: [Select]
href="./admin......."Remove that dot (.) in front of /admin, like this:
Code: [Select]
href="/admin......."That should fix your menu button.

15
 Any fix for this problem? Rebuild script doesn't work.

Pages: [1] 2 3 ... 10