Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - monkeyking

Pages: [1] 2 3 ... 8
1
Did you rebuild your vhost?

2
CentOS 7 Problems / Re: CWP Pro: User accounts are locked
« on: December 11, 2018, 12:40:21 PM »
Status: No is to disable or Yes is to disable? I have the same issue but mine was set to No to begin with. I am confused.

3
Varnish / Re: working or not?
« on: December 09, 2018, 05:56:20 AM »
by default varnish is off even if your webserver is nginx+varnish+apache. you have to turn it on through "WebServers Domain Conf" or "WebServers Main Conf".

4
CentOS-WebPanel Bugs / Re: Logout does't work in user panel
« on: December 09, 2018, 05:50:37 AM »
What version are you on? Also try a different browser.

5
CentOS-WebPanel Bugs / Re: Logout User Control Panel
« on: December 09, 2018, 05:49:29 AM »
It was Firefox that didn't work. Try a different browser. Anyways, this is solved now in the new release.

6
CentOS 7 Problems / Re: I can not start Apache what should i do?
« on: December 09, 2018, 05:44:55 AM »
Try rebuild apache

7
Updates / Re: Issues After version: 0.9.8.742 Update
« on: December 08, 2018, 11:21:15 AM »
If you're using WordPress then you have another option. That is to add this to your wp-config.php.

Code: [Select]
if ($_SERVER['HTTP_X_FORWARDED_PROTO'] == 'https')
    $_SERVER['HTTPS']='on';

if (isset($_SERVER['HTTP_X_FORWARDED_HOST'])) {
    $_SERVER['HTTP_HOST'] = $_SERVER['HTTP_X_FORWARDED_HOST'];
}

8
How to / Re: Disable varnish on xenforo 2
« on: December 08, 2018, 10:22:46 AM »
I have on same domain wordpress and /forum is xenforo... so i dont want to disable varnish for wordpress only for subfolder.

i try many things in /etc/varnish/ including in hosts i add

if (req.url ~ "^/\forum/") {
      return (pass);
   }

i try like everything that i find on net but it seems like it doesent apply... i even try to reboot machine after changes...


EDIT:

http://prntscr.com/lrlk2y

try pipe instead of pass
Code: [Select]
if (req.url ~ "^/\forum/") {
return (pipe);
}

9
Updates / Re: CWP 0.9.8.746-My site is down.
« on: December 08, 2018, 10:16:15 AM »
Try reboot

10
Updates / Re: Issues After version: 0.9.8.742 Update
« on: December 08, 2018, 10:13:39 AM »
What u use? Apache ningx varnish or? I had loop problem i solve it setting default WebServer in nginx insted php-fpm. Also rebuild apache, and php to latest version. And remove all configs ( if u have) in domain conf.

I'm using NginX+Varnish+Apache and now + PHP-FPM too. I found the problem. It's when you're using https you get some resources requested from insecure http. That causes the mixed content. I found the solution to it by adding this to my htaccess to force https.
Code: [Select]
SetEnvIf X-Forwarded-Proto "https" HTTPS=on
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTPS} !=on
RewriteCond %{HTTP:X-Forwarded-Proto} !https [NC]
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
</IFModule>
That works for me. But I wish someone can come up with a solution for server end so we don't have to do this every times. I think it can be done through vhost but I don't know how.

11
Other / Re: Server Time on user Dashboard Problem
« on: December 04, 2018, 04:48:07 AM »
Try editing time zone in your php.ini for each php.

12
Apache / Re: 403 Forbidden on all subdomains
« on: December 04, 2018, 04:45:32 AM »
Did you tried "User Accounts > Fix Permissions"?

13
Thank for the idea. I've contacted them just now. Can you also do so too and anyone else? Hopefully they will see it's important. This cause redirect issues and app breaks because of the mixed content.

14
PHP / Re: php.ini configuration per user
« on: December 03, 2018, 07:15:56 PM »
php.ini doesn't work with php-fpm in CWPpro version: 0.9.8.741 and above. You have to change it.

from
Code: [Select]
php.ini
to
Code: [Select]
.user.ini

15
Whenever you are using [Nginx + Varnish + Apache] or [Nginx + Apache] you need to tell Apache that a SSL request is being served by a proxy server. So use the code below to force SSL .htaccess

Code: [Select]
SetEnvIf X-Forwarded-Proto "https" HTTPS=on
<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteCond %{HTTPS} !=on
  RewriteCond %{HTTP:X-Forwarded-Proto} !https [NC]
  RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
</IFModule>

This work great! Is possible to do this through vhost on the server side so we don't have to add this every time?

Pages: [1] 2 3 ... 8