Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - venty

Pages: [1] 2 3 ... 15
1
Hi,

The problem was found in the ICU version - because of the use of prestashop, I had to compile the latest version of ICU,  version 63.1...

I did so by following and applying the help my colleagues gave to the following address:

http://forum.centos-webpanel.com/php/update-icu-system-package-and-the-intl-php-extension/msg20852/#msg20852

and more precisely, in the following terms:

Quote
[root@cwp7 source]# yum list available | grep libicu
libicu.i686                               50.1.2-15.el7                  base
libicu-devel.i686                         50.1.2-15.el7                  base
libicu-doc.noarch                         50.1.2-15.el7                  base

Quote
[root@cwp7 ~]# icuinfo | grep version
    <param name="version">50.1.2</param>
    <param name="version.unicode">6.2</param>
    <param name="cldr.version">22.1.1</param>
    <param name="tz.version">2012j</param>


Well 50.1.2 the latest version of icu available for centos 7 base repository.

If you need any other version then you need to compile it from source (http://download.icu-project.org/files/icu4c/).

So lets take 62.1 version and compile it.


Quote
cd /usr/local/src
wget http://download.icu-project.org/files/icu4c/62.1/icu4c-62_1-src.tgz
tar -xvf icu4c-*.tgz
cd icu/source/
sed -i '/#define __UCONFIG_H__/a #define UCONFIG_ENABLE_PLUGINS 1' common/unicode/uconfig.h
./configure --prefix=/usr --bindir=/usr/bin --libdir=/usr/lib64 --datadir=/usr/share --enable-plugins
make -j4 && make install

Quote
[root@cwp7 source]# icuinfo | grep version
    <param name="version">62.1</param>
    <param name="version.unicode">11.0</param>
    <param name="cldr.version">33.1</param>
    <param name="tz.version">2018e</param>

More compiling options can be found inside "configure" and you can use as per your need.

This version of ICU works with PHP 7 and later, but it did not work with PHP 5.6.38 - 40 ... and when compiling with the PHP selector does not get ...
When removed the "INTL" from option list, the version 5.6.40 is installed without problems ...

With PHP Switcher I have installed a version of PHP 7.2.14 and there things are ok ...

Before I changed the ICU version to 63.1 with the other PHP-FPM selector I have compiled a version of PHP 5.6.38 and it is still active and uses the old version of ICU 50.1

This means I have both ICU versions, but when compiling an older version of a PHP, for example, 5.6.38 or 5.6.40 should be said to use the older ICU or maybe in the compilation of the PHP and choosing the "INTL" module should be told to which version of the ICU should be compiled ...

Thanks in advance!

BR

Venty

To ask again is there a variant of not one server to use two versions of intl (both ICU versions)???

BR
Venty

2
PHP / Re: PHP Selector
« on: Today at 04:01:34 PM »
Hi,

The problem was found in the ICU version - because of the use of prestashop, I had to compile the latest version of ICU,  version 63.1...

I did so by following and applying the help my colleagues gave to the following address:

http://forum.centos-webpanel.com/php/update-icu-system-package-and-the-intl-php-extension/msg20852/#msg20852

and more precisely, in the following terms:

Quote
[root@cwp7 source]# yum list available | grep libicu
libicu.i686                               50.1.2-15.el7                  base
libicu-devel.i686                         50.1.2-15.el7                  base
libicu-doc.noarch                         50.1.2-15.el7                  base

Quote
[root@cwp7 ~]# icuinfo | grep version
    <param name="version">50.1.2</param>
    <param name="version.unicode">6.2</param>
    <param name="cldr.version">22.1.1</param>
    <param name="tz.version">2012j</param>


Well 50.1.2 the latest version of icu available for centos 7 base repository.

If you need any other version then you need to compile it from source (http://download.icu-project.org/files/icu4c/).

So lets take 62.1 version and compile it.


Quote
cd /usr/local/src
wget http://download.icu-project.org/files/icu4c/62.1/icu4c-62_1-src.tgz
tar -xvf icu4c-*.tgz
cd icu/source/
sed -i '/#define __UCONFIG_H__/a #define UCONFIG_ENABLE_PLUGINS 1' common/unicode/uconfig.h
./configure --prefix=/usr --bindir=/usr/bin --libdir=/usr/lib64 --datadir=/usr/share --enable-plugins
make -j4 && make install

Quote
[root@cwp7 source]# icuinfo | grep version
    <param name="version">62.1</param>
    <param name="version.unicode">11.0</param>
    <param name="cldr.version">33.1</param>
    <param name="tz.version">2018e</param>

More compiling options can be found inside "configure" and you can use as per your need.

This version of ICU works with PHP 7 and later, but it did not work with PHP 5.6.38 - 40 ... and when compiling with the PHP selector does not get ...
When removed the "INTL" from option list, the version 5.6.40 is installed without problems ...

With PHP Switcher I have installed a version of PHP 7.2.14 and there things are ok ...

Before I changed the ICU version to 63.1 with the other PHP-FPM selector I have compiled a version of PHP 5.6.38 and it is still active and uses the old version of ICU 50.1

This means I have both ICU versions, but when compiling an older version of a PHP, for example, 5.6.38 or 5.6.40 should be said to use the older ICU or maybe in the compilation of the PHP and choosing the "INTL" module should be told to which version of the ICU should be compiled ...

Thanks in advance!

BR

Venty

To ask again is there a variant of not one server to use two versions of intl (both ICU versions)???

BR
Venty

3
PHP / Activate / Unaktivate
« on: Today at 10:34:30 AM »
HI,

how can I set a folder - module in the global PHP compiled setting to stop being active and how can I set a module that is not active when compiling to activate ... ???

BR
Venty

4
PHP / Important for Prestashop....
« on: Today at 10:15:11 AM »
Hi,

which modules, parts of the PHP are important for Prestashop and should be included in the compilation???
Which modules are required and popular PHP setting for the Prestashop???

BR
Venty

5
PHP / Important for joomla....
« on: Today at 10:14:05 AM »
Hi,

which modules, parts of the PHP are important for joomla and should be included in the compilation???
Which modules are required and popular PHP setting for the Joomla???

BR
Venty

6
PHP / modules of the PHP recode and ioncube
« on: Today at 09:02:41 AM »
Hi,

the modules of the PHP recode and ioncube.....Are they important?

BR
Venty



7
PHP / Re: PHP accelerator and Short_open_tag with prestashop
« on: Today at 08:19:14 AM »
Hi,

Where IMAP is used in mail communication - I did not include IMAP in the compilation of the PHP and the service sends messages to the shop users when registering and ordering ...

Are there other emails that are sent to test if they work?

BR
Venty

8
PHP / Re: PHP accelerator and Short_open_tag with prestashop
« on: March 15, 2019, 07:15:07 AM »
Hi,

thank you for the answer, but ask:
Why is memcached vulnerable?
IMAP why do I use it in a presta?
Аnd about 4 only Apache->php-fpm , Varnish & Nginx ???

Thanks in advance!

BR
Venty

9
PHP / Re: PHP accelerator and Short_open_tag with prestashop
« on: March 14, 2019, 11:16:11 AM »
Hi,

...at points 1, 2 and 3 you say "and also select the required extension", which extension?
and item 5 what happens in its implementation?

Br
Venty

10
PHP / Re: Issue with IonCube Loader for PHP Version 7.3.2
« on: March 11, 2019, 06:30:48 PM »
Hi,

I've compiled the PHP version 7.2.15 (with PHP Version Switcher v2) , but at the end of the php-rebuild file I saw the following:

..........
'ioncube_loader_lin_7.1_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.1_ts.so'
'ioncube_loader_lin_7.2.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.2.so'
'ioncube_loader_lin_7.2_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.2_ts.so'
'loader-wizard.php' -> '/usr/local/ioncube/loader-wizard.php'
yes: standard output: Broken pipe
yes: write error

Please, what is the problem?

Thanks in advance!

BR
Venty

11
PHP / PHP v. 7.2.15 with PHP switcher
« on: February 13, 2019, 01:43:52 PM »
Hi,

I compiled PHP v. 7.2.15 with PHP switcher, then I looked at the end file and finally saw:

'loader-wizard.php' -> '/usr/local/ioncube/loader-wizard.php'
yes: standard output: Broken pipe
yes: write error



What is the problem of what to do?

BR
Venty

12
PHP / Re: PHP Selector
« on: January 17, 2019, 10:51:53 AM »
Hi,

The problem was found in the ICU version - because of the use of prestashop, I had to compile the latest version of ICU,  version 63.1...

I did so by following and applying the help my colleagues gave to the following address:

http://forum.centos-webpanel.com/php/update-icu-system-package-and-the-intl-php-extension/msg20852/#msg20852

and more precisely, in the following terms:

Quote
[root@cwp7 source]# yum list available | grep libicu
libicu.i686                               50.1.2-15.el7                  base
libicu-devel.i686                         50.1.2-15.el7                  base
libicu-doc.noarch                         50.1.2-15.el7                  base

Quote
[root@cwp7 ~]# icuinfo | grep version
    <param name="version">50.1.2</param>
    <param name="version.unicode">6.2</param>
    <param name="cldr.version">22.1.1</param>
    <param name="tz.version">2012j</param>


Well 50.1.2 the latest version of icu available for centos 7 base repository.

If you need any other version then you need to compile it from source (http://download.icu-project.org/files/icu4c/).

So lets take 62.1 version and compile it.


Quote
cd /usr/local/src
wget http://download.icu-project.org/files/icu4c/62.1/icu4c-62_1-src.tgz
tar -xvf icu4c-*.tgz
cd icu/source/
sed -i '/#define __UCONFIG_H__/a #define UCONFIG_ENABLE_PLUGINS 1' common/unicode/uconfig.h
./configure --prefix=/usr --bindir=/usr/bin --libdir=/usr/lib64 --datadir=/usr/share --enable-plugins
make -j4 && make install

Quote
[root@cwp7 source]# icuinfo | grep version
    <param name="version">62.1</param>
    <param name="version.unicode">11.0</param>
    <param name="cldr.version">33.1</param>
    <param name="tz.version">2018e</param>

More compiling options can be found inside "configure" and you can use as per your need.

This version of ICU works with PHP 7 and later, but it did not work with PHP 5.6.38 - 40 ... and when compiling with the PHP selector does not get ...
When removed the "INTL" from option list, the version 5.6.40 is installed without problems ...

With PHP Switcher I have installed a version of PHP 7.2.14 and there things are ok ...

Before I changed the ICU version to 63.1 with the other PHP-FPM selector I have compiled a version of PHP 5.6.38 and it is still active and uses the old version of ICU 50.1

This means I have both ICU versions, but when compiling an older version of a PHP, for example, 5.6.38 or 5.6.40 should be said to use the older ICU or maybe in the compilation of the PHP and choosing the "INTL" module should be told to which version of the ICU should be compiled ...

Thanks in advance!

BR

Venty

13
PHP / Re: PHP Selector
« on: January 16, 2019, 10:54:24 AM »
what should I use to pаste the full log?

14
PHP / Re: PHP Selector
« on: January 16, 2019, 09:48:56 AM »
you probably have some old notifications in the panel about php build so you can't add duplicate

?!?

15
PHP / Re: PHP Selector
« on: January 16, 2019, 09:00:58 AM »
thanks for the answer, but here is the second option, I have no version installed ... or more precisely ...

I had a old version installed and tried to upgrade it but it did not work, and then I deleted the old version with the link "delete" and tried to install again with PHP selector the cleaner version, but again it did not work ...

when I go and uncover Contents of File: /var/log/php-selector-rebuild.log at the end I see it, what is in the picture below:

http://prntscr.com/m7uaf7

BR
Venty

Pages: [1] 2 3 ... 15