Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - KanibalCz

Pages: [1]
1
Backup / Re: Backup Issue
« on: February 14, 2018, 10:41:58 PM »
Why do you have in user panel section under backups this message then?

"Currently, there is no automatically generated backup available. The administrator or the server owner must enable this function."

2
Backup / Re: Backup Issue
« on: February 13, 2018, 07:22:15 PM »
Used to be in previous versions. But in the new update, they let user see status of automatic backups.

3
Backup / Re: Backup Issue
« on: February 13, 2018, 07:07:37 PM »
If you mean "Download a full website backup" - if you click it, the backup generates - that's ok and it's working.

But i need automatic backups (daily, weekly, monthly). Guess we're both talking about something different :(

4
Backup / Re: Backup Issue
« on: February 13, 2018, 06:40:34 PM »
If you log into https://79.137.25.230:2083/testacc/?module=backups - you'll see that there is a message: "Currently, there is no automatically generated backup available. The administrator or the server owner must enable this function."

in the attached log file above you can see, that there is backup of every user in CWP. But in the user panel section you can't see the automatic generated backups.

5
Backup / Re: Backup Issue
« on: February 13, 2018, 05:44:45 PM »
Same here...

Tried to make a backup on demo machine - enabling all backup options in root section and then i ran

Code: [Select]
/usr/local/cwp/php71/bin/php -d max_execution_time=1000000 -q /usr/local/cwpsrv/htdocs/resources/admin/include/cron_backup.php
Everything seem fine in log
Code: [Select]
###############################################
Daily Files Backup starting
###############################################
Username: testacc
========================================
sending incremental file list
sent 336 bytes  received 18 bytes  708.00 bytes/sec
total size is 5539  speedup is 15.65
Username: cwppro
========================================
sending incremental file list
sent 145 bytes  received 13 bytes  316.00 bytes/sec
total size is 5511  speedup is 34.88
Username: cwphost
========================================
sending incremental file list
sent 338 bytes  received 17 bytes  710.00 bytes/sec
total size is 955606511  speedup is 2691849.33
Username: testcwp
========================================
sending incremental file list
sent 145 bytes  received 13 bytes  316.00 bytes/sec
total size is 5511  speedup is 34.88
###############################################
Daily Files Backup finished
###############################################
###############################################
Daily MySQL Backup starting
###############################################
Skipping database: information_schema.
Database Backup: mysql --> /backup/mysql/daily//mysql.sql
Database Backup: oauthv2 --> /backup/mysql/daily//oauthv2.sql
mysqldump: Got error: 1142: "SELECT, LOCK TABLES command denied to user 'root'@'localhost' for table 'accounts'" when using LOCK TABLES
Database Backup: performance_schema --> /backup/mysql/daily//performance_schema.sql
Database Backup: postfix --> /backup/mysql/daily//postfix.sql
Database Backup: root_cwp --> /backup/mysql/daily//root_cwp.sql
Database Backup: roundcube --> /backup/mysql/daily//roundcube.sql
curl: (7) Failed connect to dl1.centos-webpanel.com:80; Connection timed out
error: skipping http://dl1.centos-webpanel.com/files/mysql/percona-toolkit.rpm - transfer failed
###############################################
Daily MySQL Backup finished
###############################################

But when i look into testacc account, there is still message: "Currently, there is no automatically generated backup available. The administrator or the server owner must enable this function."

Can't say what is the problem, same symptoms on my machine, even on the demo machine, i'll try contact support.

6
Functions / Re: CWP accoutn API
« on: April 10, 2017, 10:32:11 AM »
I checked.

What was kinda weird was that it sent two requests.

In CWP Apache log i found that first response was ok,  then CWP resets the connection, and then send the "Username already in database" error because the request is called again.

I think (it's only a thought), that something went wrong in API, and before setting password for the user it ended. Weird is, that it's working in a browser.

What is working correctly is creating a user, everything even with this error, but the user has no password set.

When i was looking in messages log, it says that it could not find a passwd file, i tried to look in CWP code, but it is encrypted/encoded, and i respect the rules, so i did'nt dig deeper, then i was looking for a workaround.

Hope it helps :-)


7
Functions / Re: CWP accoutn API
« on: March 27, 2017, 03:48:18 PM »
Hello,

i've got this problem too... So i tried to diagnose, how to solve the problem. I found out that if you run PHP script as user "nobody" (default apache user), it ends up with this error.

I figured it out by saving PHP piece of code to a file, and then running it with cron /usr/local/bin/php /path/to/your/script.php

What surprised me was, that even running a wget in a cron didn't helped.

Hope someone will find this useful, i've spent a whole weekend on this thing :D

Pages: [1]