Author Topic: policyd-spf skip_addresses not IP network  (Read 1006 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
policyd-spf skip_addresses not IP network
« on: May 29, 2017, 01:16:07 AM »
Quote
May 28 18:52:53 server policyd-spf[12368]: ERROR: 127.0.0.0/8 in skip_addresses not IP network.  Message: '65.54.190.90' does not appear to be an IPv4 or IPv6 address. Did you pass in a bytes (str in Python 2) instead of a unicode object?. Aborting whitelist processing.

Fix...

Quote
yum install -y python34
sed -i "s|/usr/bin/python|/usr/bin/python3|" /etc/postfix/master.cf
/bin/systemctl restart postfix


Bye
« Last Edit: May 29, 2017, 01:18:56 AM by thefantas »

Offline
*
Re: policyd-spf skip_addresses not IP network
« Reply #1 on: June 12, 2017, 01:09:05 PM »
When I follow this I get an error as follows

Code: [Select]
Traceback (most recent call last):
  File "/usr/libexec/postfix/policyd-spf", line 35, in <module>
    import spf
ImportError: No module named 'spf'

(As a work around until I get this fixed in master.cf I use: user=nobody argv=/usr/bin/python /usr/libexec/postfix/policyd-spf
instead of: user=nobody argv=/usr/bin/python3 /usr/libexec/postfix/policyd-spf

Also I have to disable the ipaddress modules in python. While this causes other problems the server can at least receive mails)


Offline
*
Re: policyd-spf skip_addresses not IP network
« Reply #2 on: June 16, 2017, 11:10:43 PM »
Solved this by:

1) installing pip for python 3 following this: https://stackoverflow.com/questions/32618686/how-to-install-pip-in-centos-7

2) then seeing what modules were missing by invoking the script from ssh with
Code: [Select]
sudo -u nobody /usr/bin/python3.4 /usr/libexec/postfix/policyd-spf     I added the following:
2a) module spf with
Code: [Select]
pip3 install pyspf2b) module dns with
Code: [Select]
pip3 install py3dns2c) module policydspfsupp with
Code: [Select]
pip3 install pypolicyd-spf
3) then changed back to python3 (as per the original solution above) in /etc/postfix/master.cf
Code: [Select]
user=nobody argv=/usr/bin/python3 /usr/libexec/postfix/policyd-spf
4) restarted postfix